Dual Booting All discussion on Dual Booting 2 operating systems (or even more!) on the Dell Mini

Reply
 
Thread Tools Display Modes
  (#1) Old
virusdoc virusdoc is offline
Senior Member
 
Posts: 174
Join Date: Dec 2009
Default OS X resets BIOS time to GMT at each boot - 01-17-2010, 11:50 PM

I have a dual boot 10v, running Snow Leopard and Windows 7 ultimate. Each time I boot into Snow Leopard, it changes the system BIOS time to Greenwich Mean Time (5 hours ahead of my local). The change is made at the BIOS level, although Snow Leopard still reads the correct local time, Windows 7 reads this BIOS time and displays it as if it were current. I find it surprising that Snow Leopard can reset the system time at all, since it was my understanding OS X could not interact with BIOS. Any ideas how to keep OS X from doing this?

Thanks!

-virusdoc

P.S. I did search and found a slightly related thread in the mini 9 forum, but I cannot find any mention of the OS X install actually changing the BIOS time.

related thread:

http://www.mydellmini.com/forum/dell...ot-w7-osx.html
Reply With Quote
  (#2) Old
w7ox w7ox is offline
Senior Member
 
w7ox's Avatar
 
Posts: 449
Join Date: Dec 2009
Default 01-18-2010, 12:10 AM

I'm running only OS X and the BIOS likes GMT, it seems. But in OS X the time displayed is correct for the time zone I'm in. So I'm good with it.

Phil


Netbook: Mini 10v, BIOS A05, OS X 10.6.4, 2 GB RAM, 160 GB HDD, BT
Reply With Quote
  (#3) Old
Side.Step.Society Side.Step.Society is offline
Senior Member
 
Side.Step.Society's Avatar
 
Posts: 289
Join Date: Dec 2009
Location: Canada
Send a message via MSN to Side.Step.Society
Default 01-18-2010, 12:38 AM

This is a problem with all dual boot systems because of how the different OS's store time. This worked on my Mac mini with Windows 7 and SL.

Run > RegEdit

Find;
HKEY_LOCAL_MACHINE > SYSTEM > CurrentControlSet > Control > TimeZoneInformation

Add key ( REG_DWORD type );
RealTimeIsUniversal

Double-click and set value to 1
and
If your clock is constantly out of sync even though it says the sync was successful, the problem could be that your computer is losing time because of a system clock problem. A workaround in this instance is to change the NTP client to update more often.
Open regedit.exe through the start menu search box, and then find this registry key:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic es\w32time\TimeProviders\NtpClient
Double-click on the key on the right-hand side for SpecialPollInterval
The default time period is 7 days calculated in seconds. If you wanted to change this to update every day, you would use 86400, or 60 seconds * 60 minutes * 24 hours * 1 day.
Reply With Quote
  (#4) Old
mattyparanoid mattyparanoid is offline
Junior Member
 
Posts: 5
Join Date: Oct 2009
Default This is normal... - 01-18-2010, 01:28 AM

...and is due to the way the two operating systems define system time. Windows based systems treat the system time as local. OSX treats system time as GMT.

It was driving me crazy until found the answer for myself. I was sure something was broken...

Cheers.

M
Reply With Quote
  (#5) Old
virusdoc virusdoc is offline
Senior Member
 
Posts: 174
Join Date: Dec 2009
Default 02-03-2010, 01:30 AM

Quote:
Originally Posted by Side.Step.Society View Post
This is a problem with all dual boot systems because of how the different OS's store time. This worked on my Mac mini with Windows 7 and SL.

Run > RegEdit

Find;
HKEY_LOCAL_MACHINE > SYSTEM > CurrentControlSet > Control > TimeZoneInformation

Add key ( REG_DWORD type );
RealTimeIsUniversal

Double-click and set value to 1
and
If your clock is constantly out of sync even though it says the sync was successful, the problem could be that your computer is losing time because of a system clock problem. A workaround in this instance is to change the NTP client to update more often.
Open regedit.exe through the start menu search box, and then find this registry key:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic es\w32time\TimeProviders\NtpClient
Double-click on the key on the right-hand side for SpecialPollInterval
The default time period is 7 days calculated in seconds. If you wanted to change this to update every day, you would use 86400, or 60 seconds * 60 minutes * 24 hours * 1 day.
Thanks much. This worked. I apologize for not replying sooner--I thought I was subscribed to the thread, but was not.

-virusdoc
Reply With Quote
  (#6) Old
canada eh canada eh is offline
Member
 
canada eh's Avatar
 
Posts: 76
Join Date: Dec 2009
Location: Barrie, Ontario
Default 02-06-2010, 04:37 PM

I have the same problem on my genuine mac using bootcamp the time is always messed up after switching.


Dell Mini 10v Hackintosh 10.6.2 160gb hard drive 2gb RAM
Reply With Quote
  (#7) Old
w7ox w7ox is offline
Senior Member
 
w7ox's Avatar
 
Posts: 449
Join Date: Dec 2009
Default 02-06-2010, 04:54 PM

Quote:
Originally Posted by canada eh View Post
I have the same problem on my genuine mac using bootcamp the time is always messed up after switching.
Hmmm .. No problem with Parallels running Windows on my MacBook. But with a virtual machine it's a different situation.

Phil


Netbook: Mini 10v, BIOS A05, OS X 10.6.4, 2 GB RAM, 160 GB HDD, BT
Reply With Quote
  (#8) Old
Side.Step.Society Side.Step.Society is offline
Senior Member
 
Side.Step.Society's Avatar
 
Posts: 289
Join Date: Dec 2009
Location: Canada
Send a message via MSN to Side.Step.Society
Default 02-06-2010, 06:12 PM

Quote:
Originally Posted by canada eh View Post
I have the same problem on my genuine mac using bootcamp the time is always messed up after switching.
Try the solution I posted above.
Reply With Quote
  (#9) Old
0212353 0212353 is offline
Junior Member
 
Posts: 25
Join Date: Jan 2010
Location: STL, MO
Default 03-05-2010, 05:49 PM

Quote:
Originally Posted by Side.Step.Society View Post
This is a problem with all dual boot systems because of how the different OS's store time. This worked on my Mac mini with Windows 7 and SL.

Run > RegEdit

Find;
HKEY_LOCAL_MACHINE > SYSTEM > CurrentControlSet > Control > TimeZoneInformation

Add key ( REG_DWORD type );
RealTimeIsUniversal

Double-click and set value to 1
Did this not work for anyone here?

I am running SL and 7 Ultimate on my 10v. Tried this, didn't work.
Reply With Quote
  (#10) Old
Side.Step.Society Side.Step.Society is offline
Senior Member
 
Side.Step.Society's Avatar
 
Posts: 289
Join Date: Dec 2009
Location: Canada
Send a message via MSN to Side.Step.Society
Default 03-05-2010, 06:02 PM

It may take a few reboots/switches between OS's to work, but as of right now, it's working on both my Mac mini and my 10v.
Reply With Quote
Reply

« Previous Thread | Next Thread »
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Copyright © 2008-2016 MyDellMini.com.