Ubuntu Discussion on Ubuntu on the Dell Inspiron Mini range of netbooks.

Thread Tools Display Modes
  (#11) Old
ugm6hr ugm6hr is offline
Senior Member
Posts: 127
Join Date: Jan 2009
Default Re: Ignoring Trackpad While Typing - 01-20-2009, 08:00 AM

Originally Posted by mercury7
Can't access shared memory area. SHMConfig disabled?
My default xorg.conf on a standard Dell Mini 9 Ubuntu Hardy lpia:

Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver		"kbd"
	Option		"XkbRules"	"xorg"
	Option		"XkbModel"	"pc105"
	Option		"XkbLayout"	"gb"

Section "InputDevice"
	Identifier	"Configured Mouse"
	Driver		"mouse"
	Option		"CorePointer"

Section "InputDevice"
	Identifier	"Synaptics Touchpad"
	Driver		"synaptics"
	Option		"SendCoreEvents"	"true"
	Option		"Device"		"/dev/psaux"
	Option		"Protocol"		"auto-dev"
	Option		"SHMConfig"		"true"

Section "Device"
	Identifier	"Configured Video Device"
	Option		"UseFBDev"		"true"

Section "Monitor"
	Identifier	"Configured Monitor"

Section "Screen"
	Identifier	"Default Screen"
	Monitor		"Configured Monitor"
	Device		"Configured Video Device"

Section "ServerLayout"
	Identifier	"Default Layout"
	Screen		"Default Screen"
	InputDevice	"Synaptics Touchpad"

Section "DRI"
	Mode 0666
You'll note the "true" rather than "on" - in previous (manual) installations, I have had to try all of true, on, and 1 - they all seem to work, but not on all computers the same.

PS: If you have a default installed (i.e. Factory install) - it should already be there.
Reply With Quote
  (#12) Old
nbock01 nbock01 is offline
Junior Member
Posts: 26
Join Date: Dec 2008
Default Re: Ignoring Trackpad While Typing - 01-20-2009, 06:34 PM

Originally Posted by jeffburg
Hey guys. Was looking over the internet for this and it is really simple and works perfetly.
the default installation of Ubuntu from dell already uses the correct drive

just run this command in the terminal
syndaemon -i 1 -d

You can add it so Sessions under System > Preferences to get it to run every time on startup if you like it

this way when you are typing you don't accidentally move the mouse or tap on things to click them
This is great!!! I have tried touchfreeze but that did not work for me, this works great how ever!!! Definately needed on this small keyboard...

Thanks again!!
Reply With Quote
  (#13) Old
mercury7 mercury7 is offline
Junior Member
Posts: 14
Join Date: Dec 2008
Default Re: Ignoring Trackpad While Typing - 01-22-2009, 05:34 AM

I found my problem. I had copied the line into my xorg.conf off a web page somewhere but it was using some sort of evil smart quotes, not REAL quote marks. When I fixed that, it worked.

See the difference?
Evil quote marks:
Option “SHMConfig” “true”
Real quote marks:
Option "SHMConfig" "true"
Reply With Quote
  (#14) Old
johnnybirdman johnnybirdman is offline
Junior Member
johnnybirdman's Avatar
Posts: 18
Join Date: Apr 2009
Location: PA
Default 05-17-2009, 08:40 PM

works great, thanks.

Mini9 - Black - 2GB RAM - 4GB STEC HD
OS - Ubuntu 9.04
Reply With Quote

« Bluetooth issues | Wireless utilies »
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Copyright © 2008-2016 MyDellMini.com.