Ubuntu Discussion on Ubuntu on the Dell Inspiron Mini range of netbooks.

Thread Tools Display Modes
  (#1) Old
ViDAR85 ViDAR85 is offline
Junior Member
Posts: 1
Join Date: Apr 2009
Default Compiz keeps breaking - 04-01-2009, 12:55 AM

Ok I have searched all over the net and can not find a way to fix this problem. I am running Ubuntu 8.10 and Compiz was working fine until I hooked my Mini 9 up to my TV via VGA. When I try and enable Normal visual effects I get a error saying "Desktop effects could not be enabled". When I run compiz in a terminal i get
Checking for Xgl: not present. 
Detected PCI ID for VGA: 
Checking for texture_from_pixmap: not present. 
Trying again with indirect rendering:
Checking for texture_from_pixmap: present. 
Checking for non power of two support: present. 
Checking for Composite extension: present. 
Comparing resolution (1024x600) to maximum 3D texture size (2048): Passed.
Checking for Software Rasterizer: present. 
Software rasterizer detected, abortingaborting and using fallback: /usr/bin/metacity
I have tried reinstalling ever compiz thing and nothing works. This has happened to me 3 times now and the only way I have fixed it is to reinstall Ubuntu.
Reply With Quote
  (#2) Old
ryuko2002 ryuko2002 is offline
Posts: 39
Join Date: Mar 2009
Default Re: Compiz keeps breaking - 04-04-2009, 04:23 PM

I had a problem like this on my ubuntu installation after connecting my mini to a 22" monitor. I'm pretty sure something in the xorg file is wrong. You have two options:
- Open the terminal Go to "cd /etc/X11/" (not 100% sure, i'm on a windows computer now) and look for the xorg.conf file. If you do a "ls" you may see some xorf.conf backup files. Try renaming one of those backup files to the xorg.conf file. Ie (sudo cp xorg.conf xorg.conf2, sudo cp xorg.conf_backupXXXX xorg.conf). Then reboot. This fixed my problem.
- Another option is to do a "sudo dpkg-reconfigure xserver-xorg" and answer the question. If you don't know just use the default option.
- Or you can probably boot from a live cd and if compiz works on the live cd just copy the xorg.conf file, reboot to your regular OS and overwrite the messed-up xorg.conf file.
Good luck!!
Reply With Quote

« ext2 vs ext3 vs ext4 | Can't run LiveCD or install Ubuntu »
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Copyright © 2008-2016 MyDellMini.com.