Ubuntu Discussion on Ubuntu on the Dell Inspiron Mini range of netbooks.

Thread Tools Display Modes
  (#1) Old
nietzche nietzche is offline
Junior Member
Posts: 1
Join Date: Dec 2010
Unhappy mini1018 wifi switch? (f2 doesn't work) - 12-03-2010, 12:33 AM

hey all, sorry to add another "my wifi won't work thread"...but i'd tried everything i can find and it still won't work.

i just got a new dell mini 1018 and first thing i did was throw ubuntu on it. at first it didn't recognize the fact that i had a wireless card at all, so i downloaded and installed the wireless drivers according to the thread below started by yerayenrique. now my wifi0 actually shows up in iwconfig, but it's still hardblocked for some reason.

rfkill list shows

0: dell-wifi: Wireless LAN
Soft blocked: yes
Hard blocked: yes

(I've tried rfkill unblock all / rfkill unblock wifi and everything else I can think of, but it doesn't seem to be changing anything)

I hear of others enabling/disabling wifi by pressing F2, but that seems to do nothing (along with Ctrl-F2, Fn-F2, and Alt-F2). In my Network Manager I now see "Wireless Networks" in gray, and "wireless is disabled" in gray letters below that.

I have a feeling that I need to be able to reenable my ability to turn on/off wifi with F2, but the only drivers that I can find to do that (on dell's site) are only for Windows.

I've downloaded Wicd and any other network management software i can think of, but none of them work b/c wireless isn't on in the first place to connect to any networks...

Has anyone experienced this before or have any ideas to fix this?

Thank you in advance for any help!
Reply With Quote
  (#2) Old
reflex reflex is offline
reflex's Avatar
Posts: 1,997
Join Date: Apr 2009
Default 12-03-2010, 01:14 AM

I dunno.

On my similar 1012 (but with a different WiFi card), the wireless kill switch is F2 or Fn+F2 depending on whether you have multimedia keys or function keys set as the default in BIOS. And it seems to work like expected, hitting Fn+F2 cripples WiFi and rfkill reports a "hard block". Hitting it again makes the hard block go away, and the WiFi comes back up.

You have the latest version of the driver? Should be here: Realtek.

Try "rfkill unblock all".

Mini 9 | Intel 5100 Wifi | Ubuntu 10.04 Netbook
Mini 1012 | SSD | Intel 6200 Wifi | Ubuntu 11.10 64bit
Reply With Quote

wifi enable f2

« Disable power management ubuntu | enable cube »
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Copyright © 2008-2016 MyDellMini.com.