Ubuntu Discussion on Ubuntu on the Dell Inspiron Mini range of netbooks.

Reply
 
Thread Tools Display Modes
  (#21) Old
8bitDesigner 8bitDesigner is offline
Junior Member
 
Posts: 6
Join Date: Aug 2009
Default 02-05-2010, 08:50 AM

You know, this sounds a lot like the issues the Mini 9 has when sleeping on a Hackintosh system. In that case, you need to go into BIOS and disable the two USB options "Wake on USB" and "USB Legacy mode".

Once those are disabled, reboot, and you should now be able to suspend the computer.

Anyways, I ran into the same problem in a fresh 9.10 install, and tried disabling the "USB Legacy Mode" and "Wake on USB" options in BIOS, and sure enough, the damned thing suspends and hibernates perfectly now.

Just a though; haven't tried it with the SD card mounted yet, however.
Reply With Quote
  (#22) Old
jej.514 jej.514 is offline
Senior Member
 
Posts: 282
Join Date: Sep 2008
Location: DeKalb, IL (near Chicago)
Default 02-05-2010, 08:38 PM

@8bitDesigner - Have you lost any functionality with those disabled?


Mini 9 | Black | 32GB RunCore SSD | 2GB RAM | .3MP cam
Windows 7 Home Premium
Reply With Quote
  (#23) Old
supergrover supergrover is offline
Junior Member
 
Posts: 1
Join Date: Jul 2009
Default I used "umount /dev/mmcblk0p1" instead. - 02-09-2010, 12:06 AM

Rather then try to un-mount the SDHC card by name as in the aforementioned example, I set mine to un-mount it by the device. Now it doesn't matter if I have a different named SDHC card in there. Any card I swap in and out of the machine will be un-mounted prior to suspend/hibernate.
Reply With Quote
  (#24) Old
craptree craptree is offline
Junior Member
 
Posts: 1
Join Date: Mar 2010
Default 03-02-2010, 04:11 PM

mmcblk0p1 appliers only to sd cards. I think memory sticks go to mmcblk0

A better option is to unmount them all with
umount /dev/mmcblk*

]Rather then edit the pm-suspend script directly, it is much better to add the required commands to a file in /etc/pm/sleep.d. That way we don't screw with Ubuntus core scripts.

Heres a copy of my /etc/pm/sleep.d/10sdcard file that unmounts upon hibernation and suspension.

Code:
#!/bin/bash

case $1 in
    hibernate|suspend)
	umount /dev/mmcblk*
        ;;
#    thaw|resume)
#        ;;    
    *)  echo $1 
        ;;
esac
exit 0
Dont forget to make the file executable with
Code:
chmod +x 10sdcard
Reply With Quote
  (#25) Old
orlando orlando is offline
Junior Member
 
Posts: 2
Join Date: Mar 2010
Default 03-13-2010, 01:11 AM

Worked perfect...thank you.

Quote:
Originally Posted by craptree View Post
mmcblk0p1 appliers only to sd cards. I think memory sticks go to mmcblk0

A better option is to unmount them all with
umount /dev/mmcblk*

]Rather then edit the pm-suspend script directly, it is much better to add the required commands to a file in /etc/pm/sleep.d. That way we don't screw with Ubuntus core scripts.

Heres a copy of my /etc/pm/sleep.d/10sdcard file that unmounts upon hibernation and suspension.

Code:
#!/bin/bash

case $1 in
    hibernate|suspend)
    umount /dev/mmcblk*
        ;;
#    thaw|resume)
#        ;;    
    *)  echo $1 
        ;;
esac
exit 0
Dont forget to make the file executable with
Code:
chmod +x 10sdcard
Reply With Quote
  (#26) Old
joelaw joelaw is offline
Junior Member
 
Posts: 2
Join Date: Mar 2009
Default 03-15-2010, 06:51 PM

CountZer0, I have been having the same suspend problem with 9.1 since installing all of my programs and setting my system up as I liked. I then noticed that it will not come out of suspend.

You are the only one that suggested a fix from many searches. Yes, it seems to be the SD card installed and mounted that causes the lock up. If I remove it it works great.

My question is that I tried to fix the problem as you suggested but the SD cards that I mount have different volume names and won't unmount if I plug in a different SD. There must be a name for any SD card mounted that can be added to the suspend file.

Thanks for help.
Reply With Quote
  (#27) Old
joelaw joelaw is offline
Junior Member
 
Posts: 2
Join Date: Mar 2009
Default 03-19-2010, 04:18 PM

As I am new to this stuff, I generated a new file named 10sdcard with the code from CRAPTREE's message and saved it into the sleep.d directory. I then did a chmod and rebooted.

Still doesn't stop the lockup after closing the lid of my Dell mini9 usining Ubuntu 9.1. The only way I can put to sleep is remove the SD card before closing.

What am I doing wrong?
Reply With Quote
  (#28) Old
psypher246 psypher246 is offline
Junior Member
 
Posts: 1
Join Date: May 2010
Default Problem still exists on Lucid - 05-04-2010, 12:32 PM

none of the work arounds work in my situation. Not the BIOS changes, not unmounting it in the pm-suspend script or adding the 10sdcard script. I think that is due to me having only a 4GB SSD and I installed Ubuntu with /usr mounted to the sd card so i have some free space in root.

Does anyone have any ideas as to how to get this device to suspend with usr running on the sd card, or any other folders for that matter?

Thanks
Reply With Quote
  (#29) Old
JEBB JEBB is offline
Member
 
Posts: 33
Join Date: Apr 2009
Default 05-24-2010, 04:45 PM

Isn't this a problem that should be addressed in an Ubuntu update? How do we bring it to the attention of the programmers?
Reply With Quote
  (#30) Old
ubuntufanXD ubuntufanXD is offline
Member
 
Posts: 38
Join Date: Dec 2008
Default 06-01-2010, 03:27 PM

launchpad.net
Reply With Quote
Reply

Tags
hibernate, suspend

« Dell Mini 9 Ubuntu Restore iso image | 10.10 netbook remix wireless driver fail »
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Copyright © 2008-2016 MyDellMini.com.