Ubuntu Discussion on Ubuntu on the Dell Inspiron Mini range of netbooks.

Thread Tools Display Modes
  (#21) Old
JEBB JEBB is offline
Posts: 33
Join Date: Apr 2009
Default 11-10-2009, 02:56 PM

Is this a problem that can be fixed at the mother ship so that the fresh install download next week or next month won't produce this problem?
I had this kind of problem with a Thinkpad R40 going from 7.10 to 8.04. The Thinkpad and Ubuntu weren't important to me at the time so I put in the closet for 6 months. All worked fine with 8.10.
Reply With Quote
  (#22) Old
wjones23 wjones23 is offline
Junior Member
Posts: 10
Join Date: Sep 2009
Default 11-10-2009, 04:34 PM

I am glad I am not the only one...I have tried the suggestions on this thread several times. Once and a while I can get the wireless working, but once I reboot the wireless is once again gone (running persistently on a 2GB USB stick). For a trial, I downloaded Fedora 12 and using their utility, created a persistent installation on my USB drive. My wireless drivers were not correctly installed with that distro either. After a search of Fedora's forum, I quickly found a solution, tried it, working, saving on reboot, no issues. I would rather use UNR. I like the interface much better. I find on other distros every now and again, there are windows that will not fit on the screen (leaving the OK and Cancel in an area I cannot click, thank goodness for keyboard shortcuts). Why are these Broadcom cards so difficult for Linux? I am looking for an Atheros card to replace mine, but in the meantime would love to get it working in UNR. All help is appreciated.


Mini 10v, Obsidian Black, 2GB RAM, Windows 7 Home Premium
Reply With Quote
  (#23) Old
OmgFriday OmgFriday is offline
Posts: 87
Join Date: Sep 2009
Default 11-10-2009, 04:53 PM

Here is a quick temporary solution to enable the wireless when I want the wireless

1. get a terminal,

2. type in the following
cd ~
source my_wireless.sh

1.The script my_wireless.sh is under home and looks like following
#start of script
sudo rmmod ssb
sudo rmmod wl

sudo modprobe lib80211
sudo insmod <your wl.ko physical path>/wl.ko
# end of script

2. you need to follow early post to get broadcom driver compiled and get wl.ko file. If needed, I can try to post it here.

3.It works for me now. I am looking a way to get this module hooked up at boot time.

Mini10v| 2GRAM| 160GB| BT(Added)| A05| QuadBoot(SnowLeopard10.6.2,WinXP.SP3,Ubuntu.Deskto p9.10,Moblin2.1)|
USB wake OFF, L support ON| NBI 8.2 -> NBI 083RC3 -> NBI 083RC4-> NBI 083Final
Reply With Quote
  (#24) Old
turnermike turnermike is offline
Junior Member
Posts: 2
Join Date: Nov 2009
Default The solution - 11-14-2009, 07:00 PM

Originally Posted by TBA View Post
I attempted to perform your above action but the only message I receive after it searches is "No proprietary drivers are in use on this system" How do I work around this to get wireless to work?
Had the same problem. Here's how I solved it

Connect to network via hardwire

Go to update manager and run it a couple of times until you are sure you are up to date. Re-boot each time.
When you are up to date go to system, admin, hardware drivers
Install the broadcom sta wireless driver
You should then be able to connect
Reply With Quote
  (#25) Old
KMC KMC is offline
Posts: 57
Join Date: Sep 2009
Default 11-14-2009, 07:49 PM

It is interesting to note the problems that some people have had with wireless on a Mini 9 running Ubuntu.

I had a recurring problem with (very) persistent dropouts when my Mini 9 was running Ubuntu - nothing I did would cure the problem. Eventually I got so brassed off that I wiped Ubuntu and loaded XP - immediately the wireless was rock solid reliable. I currently run an XP/WIN7 dual boot and wireless is completely stable.

This 'solution' may not suit everyone but it sure solved things for me!

Reply With Quote
  (#26) Old
Paul Paul is offline
Posts: 44
Join Date: Jan 2009
Red face 11-18-2009, 06:31 PM

I Installed UNR 9.10 this afternoon from an image I downloaded on Saturday (14/11). The installed automatically downloaded a driver when I first ran Ubuntu - I did have a wired connection as I thought I was going to have to chase the wireless driver. (Using a mini 9)
Reply With Quote
  (#27) Old
AK Dave AK Dave is offline
AK Dave's Avatar
Posts: 79
Join Date: Feb 2009
Default 11-18-2009, 09:43 PM


I suspect that the intermittent nature of YOUR problem has to do with the way that you made that "persistent USB stick".

I have a full Karmic UNR install to the internal SSD. I applied the above bcmwl fix while on a wired network connection, and have since then had ZERO problems with wireless.

You, on the other hand, have a "persistent USB stick". You have a "LiveUSB", not a "full install to a USB stick". You have a copy of the CD install ISO burned to a USB stick as a compressed filesystem. I submit to you that ALL of your problems and frustrations would disappear if you were to simply install Karmic onto a USB stick as a full normal install.

This can be done easily and is really the best way to run Karmic from a USB stick if you're not going to be bouncing the stick around to a bunch of very different computers. One computer, one stick, do a full install to the USB stick. It is really very simple. You merely boot your Karmic LiveUSB stick, insert a SECOND stick to install to, select "install", at the partitioning stage select the second stick (not the internal SSD) as the target, and at the very end of the install menus you'll find an "advanced" setting. In the "advanced" section, select the USB stick as the location for grub.

His: Obsidian Mini-9: Karmic UNR w/ Vbox-XP, 2gb, 32gb STEC, 16gb Transcend(6), US-INTL, sgpstore carbon
Hers: Arctic Mini-9: Dell Ubuntu, 1gb, 16gb STEC, 8gb SDHC(6)
Are you a Help Vampire?
Reply With Quote

« Persistent Jaunty UNR install on USB | WTF?! YOU MUST BE KIDDING?! Can't switch to regular desktop? »
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Copyright © 2008-2016 MyDellMini.com.