Dual Booting All discussion on Dual Booting 2 operating systems (or even more!) on the Dell Mini

Reply
 
Thread Tools Display Modes
  (#101) Old
anguish anguish is offline
Super Moderator
 
anguish's Avatar
 
Posts: 1,203
Join Date: Apr 2009
Location: Detroit
Default 02-17-2010, 11:54 AM

Has to do with the partitioning. I can't for the life of me remember if there is a workaround for it or not, unfortunately. Hopefully someone can chime in with a definitive answer. I remember having that issue as well at one point, but I never investigated it.


Alienware M11xR2 - Core i5 1.06 - 4 GB - 250 GB HD

Triple Boot Guide - 10v RAM Upgrade Videos - mechdrew's OSX guides
Reply With Quote
  (#102) Old
minimalpc minimalpc is offline
Expert Member
 
Posts: 560
Join Date: Dec 2009
Default 02-18-2010, 12:11 AM

Quote:
Originally Posted by tutorial View Post
thanks...


OSX fine
Linux Fine
Windows Fine

here's my list partition:

OSX <--- 40GB
Win7 <-- 30GB
Ubuntu <--- 10gb
Swap <--- 2gb
Data <---- rest space -- using for transfering data between OS (NTFS for future format) = windows can not read this

Windows can not read DATA partition ?any solution
I have posted about this before (earlier in this very thread IIRC). You can only have 4 partitions listed in the MBR, which is what Windows uses (it does not use GPT). Thus, the gptsync tool that is used to create the hybrid GPT/MBR setup most here use (whether they know it or not) syncs the first 4 GPT partitions to the MBR. Your Data partition is at least #5 (and probably actually #6 or 7 because there may be up to 2 hidden partitions for EFI etc.), so gptsync did not put it into the MBR and Windows cannot see it. I believe, but have never personally confirmed, that you can use an enhanced gptsync tool to specify which 4 GPT partitions you want to appear in the MBR. That way, you could use it to include your Data partition in the MBR, thus making it visible to Windows. Try it and report back.


Dell Mini 10v | Mac OS X 10.6.2 | Windows 7 Professional | Ubuntu Netbook Remix 9.10 | 1GB RAM | 160GB HDD | BIOS A05 | USB Legacy: OFF | USB Wake: OFF | BT: Enabled (self-installed BCM2046) | NBI 0.8.3 final
Reply With Quote
  (#103) Old
teklife teklife is offline
Junior Member
 
Posts: 1
Join Date: Feb 2010
Unhappy 02-19-2010, 06:38 PM

summary:
OS X - fine 132GB
UNR - fine 4GB (3.5GB swap)
WIN7 - installed but now not booting, not even bootable usb install disk



i have been struggling with this triple boot on my 10v for days now. dozens of hours spent, with both successes and failures. i haver read through the forums and googled extensively, but ive not found my answer, so i will post here my current problem, and try to be as succinct as possible.

after a point where neither os x or win 7 were working, just a black flashing cursor(before the ubuntu install), i re-created bootable thumb drives for each os, and now can consistently get os x and UNR to boot. however, my win 7 partition does not appear, nor can i boot from the win 7 bootable thumb drive.

i've created 2 different win 7 thumb drives, but neither of them are bootable. i've tried now almost 50x. it all started as i was following anguish's instructions after the UNR install. maybe i'm getting the order wrong right now, but i followed the instructions VERY carefully. i reinstalled chameleon, then booted off the win 7 usb, so far so good. ran the diskpart commands; everything was going as expected, except i didn't get the repair and restart message, but i went to another screen with a list of repair options. i selected to repair the startup disc.

i have read others having problems where the start up disk it repaired is the usb. i have completely re-created a new usb stick. from the same disc that i have booted with before, but now the computer wont recognize it at all. i can only get to the chameleon screen and select between "os x" and "linux".

disk utility in os x still sees the win 7 partition as greyed out and unmounted. i tried a repair disk, but immediately got a red error message. i hope that didn't screw anything up.

i feel like i'm very close now, and will even (reluctantly) completely reinstall win 7 and re-create a bootable usb drive, but none of what has worked before is having any effect at all now. i tried booting off the os x usb, and that works ok. why is it that nothing windows« is being recognized now?

the mini 10v is brand new, and every install is still clean and i was following instructions; i hope this is something someone else has already encountered and figured out. thanks for listening and for any help.

thanks anguish, for the guide.

Last edited by teklife; 02-19-2010 at 09:32 PM.
Reply With Quote
  (#104) Old
vieirae vieirae is offline
Junior Member
 
Posts: 5
Join Date: Jan 2010
Default Sorry Anguish ! - 02-19-2010, 11:04 PM

I followed the guide to the letter. Got the three installs OK, installed NBI alone, went to fix windows 7, but then I ran into the MBR issue and ran gptsync. Then I was able to fix windows and reset the MacOS partition as active. Upon restart got a kernel panic. I rebooted MacOS using the NBI usb media, installed NBI bootloader as well as the mini10v extensions and the DSDT.aml file. Now the sytem boots into OS only. The other OS's are not seen anymore. Somehow the bootloader gets "killed" at this point...

I installed NBI from a copy of Netbook CD within OSX. Does this have to be installed from "outside" the OS? Is there any reason why the bootloader is installed alone without the other extensions at the same time?
After running gptsync, the number of partitions was lower. The 134 MB free space partition disappears.

What can I do so that the bootloader gets properly installed. Should I reinstall OSX
on partition 2, fix windows and the run NBI again? Or do I have to redo the whole procedure, repartition HDD and redo all 3 installs? I could then try to fix windows without gptsync using the bootrec.exe /fixmbr command and hope that the rest goes OK....

Problem solved: If one looks at the video attentively, one sees that a key is pushed (the enter key !) to get from the first to the second boot screen of chameleon. The triple boot install had worked from the very beginning, I just didn't know how to get to the second boot screen so I thought the bootloader hadn't seen the other installs!

Last edited by vieirae; 03-05-2010 at 10:39 PM. Reason: problem solved
Reply With Quote
  (#105) Old
bsoplinger1 bsoplinger1 is offline
Expert Member
 
Posts: 692
Join Date: Mar 2009
Default 02-22-2010, 09:29 AM

I know its mentioned a few times in this thread, I'll repeat:

Anytime you run NetbookInstaller (NBI) you will need to do the Windows repair.

Follow the directions from the first post for how to do this.


Mini1: Vostro A90, Black, 2G, 1.3 Webcam, Bluetooth, 64G SuperTalent, OS X 10.6.4
Mini2: Mini9, Black, 2G, 0.3 Webcam, Bluetooth, 32G RunCore, OS X/Win 7, internal PCI-e SHDC Reader
Mini3: Mini10v. Black, 2G, Webcam, 640G HD, OS X 10.5.8/Win 7/Ubuntu [Hibernate w/NBI 0.8.3 RC4]
Dropbox Referral
Reply With Quote
  (#106) Old
minimalpc minimalpc is offline
Expert Member
 
Posts: 560
Join Date: Dec 2009
Default 02-23-2010, 01:15 AM

Quote:
Originally Posted by bsoplinger1 View Post
I know its mentioned a few times in this thread, I'll repeat:

Anytime you run NetbookInstaller (NBI) you will need to do the Windows repair.

Follow the directions from the first post for how to do this.
True, unless you replace the standard OS X fdisk with the Windows-safe fdisk that comes with the official Chameleon package, as I described in posts here. If meklort doesn't release an updated NBI that fixes this problem at some point soon, I may put together a dual-boot friendly version that includes both of the fixes I described in that thread.


Dell Mini 10v | Mac OS X 10.6.2 | Windows 7 Professional | Ubuntu Netbook Remix 9.10 | 1GB RAM | 160GB HDD | BIOS A05 | USB Legacy: OFF | USB Wake: OFF | BT: Enabled (self-installed BCM2046) | NBI 0.8.3 final
Reply With Quote
  (#107) Old
bsoplinger1 bsoplinger1 is offline
Expert Member
 
Posts: 692
Join Date: Mar 2009
Default 02-23-2010, 01:36 AM

Quote:
Originally Posted by minimalpc View Post
True, unless you replace the standard OS X fdisk with the Windows-safe fdisk that comes with the official Chameleon package, as I described in posts here.
Very true but I figure folks who are having troubles are just using the official things they were told to download from the first post describing the bits needs and operations to do.

It would be nice of Melkort to use the update fdisk soon in some sort of NBI update. It'd be useful just to have one made for folks to get to use in the meantime. Perhaps set a Mar 1 date and just make one for folks if there isn't a NBI update by then?

Granted, it isn't hard to replace for folks who are comfortable with hacking and playing with terminal, but I get the feeling folks without that sort of background still desire at lease double Win/Mac booting and figure why not all 3 and follow this thread.


Mini1: Vostro A90, Black, 2G, 1.3 Webcam, Bluetooth, 64G SuperTalent, OS X 10.6.4
Mini2: Mini9, Black, 2G, 0.3 Webcam, Bluetooth, 32G RunCore, OS X/Win 7, internal PCI-e SHDC Reader
Mini3: Mini10v. Black, 2G, Webcam, 640G HD, OS X 10.5.8/Win 7/Ubuntu [Hibernate w/NBI 0.8.3 RC4]
Dropbox Referral
Reply With Quote
  (#108) Old
bmcclure937 bmcclure937 is offline
Super Moderator
 
bmcclure937's Avatar
 
Posts: 1,420
Join Date: Mar 2009
Location: United States
Send a message via AIM to bmcclure937
Default 02-23-2010, 06:58 AM

Have either of you considered contacting Meklort regarding this? I think this would be a nice addition to NetbookInstaller, but he is probably not aware unless you have made a feature request on Google Code or contacted him about this

I am going to be taking a look at Triple Booting some time within the next month, so these threads have become even more interesting to me.


 Mini 10v  | 2Gb RAM | 320 Gb HDD | Ubuntu 10.04 | OSX 10.6.3 | NBI .8.4RC1 | Chameleon Bullet Theme | BIOS A05 | USB Wake : OFF | USB Legacy : ON | No BlueTooth
Meklort's Blog | NBI Google Code Page | osx.mechdrew.com -- the best OSX installation guides
Reply With Quote
  (#109) Old
minimalpc minimalpc is offline
Expert Member
 
Posts: 560
Join Date: Dec 2009
Default 02-24-2010, 12:23 AM

Quote:
Originally Posted by bmcclure937 View Post
Have either of you considered contacting Meklort regarding this? I think this would be a nice addition to NetbookInstaller, but he is probably not aware unless you have made a feature request on Google Code or contacted him about this

I am going to be taking a look at Triple Booting some time within the next month, so these threads have become even more interesting to me.
Yes. I posted both issues on the NBI Google Code page at the same time. He accepted one (the change to boot0--issue 190) but not the other (Windows-safe fdisk--issue 189) yet. Just within the past couple of days, another user has posted a new issue (197) that is substantially the same as 189. I think meklort is busy with a new job, so that is understandable. I'm sure he will get to it when he is able.


Dell Mini 10v | Mac OS X 10.6.2 | Windows 7 Professional | Ubuntu Netbook Remix 9.10 | 1GB RAM | 160GB HDD | BIOS A05 | USB Legacy: OFF | USB Wake: OFF | BT: Enabled (self-installed BCM2046) | NBI 0.8.3 final
Reply With Quote
  (#110) Old
Byzentean Byzentean is offline
Junior Member
 
Posts: 14
Join Date: Dec 2009
Default 02-25-2010, 06:34 AM

Quote:
Originally Posted by minimalpc View Post
You need to run gptsync in OS X or Linux to write an MBR that is synced to your GPT.
I dont get how to run GPTSync
can anyone help me.
I got OS X and Ubuntu working but Windows is not even installed because i messed it up,
DO i have 2 restart this whole thing over again.

UPDATE:
Everything is working great and now im dancing because this is sick. OH CRAP! i just dropped it on the ground. Guess this teaches me dont dance with a dell mini 10v.

Last edited by Byzentean; 02-25-2010 at 11:54 PM.
Reply With Quote
Reply

« Previous Thread | Next Thread »
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Copyright © 2008-2016 MyDellMini.com.