Ubuntu Discussion on Ubuntu on the Dell Inspiron Mini range of netbooks.

Reply
 
Thread Tools Display Modes
  (#1) Old
magnetbox magnetbox is offline
Junior Member
 
Posts: 5
Join Date: Aug 2009
Default 10v botched 10.10 install-- bad hardware? - 10-18-2010, 04:39 PM

Hi,

I've been running 10.4 without a hitch. Then I decided to do a fresh install of 10.10, and I've found myself in a world of trouble, with an unusable computer.

I'm running a Mini 10v with 2g ram, 160gig hard disk.

I first installed the 10.10 Netbook Edition, and everything seemed fine-- booted, got wireless drivers working, etc. I ran the Ubuntu update manager, selected everything and restarted, and now I get a fatal error on startup:

mount: mounting /dev on /root/dev failed: 3No such file or directory.

I tried a fresh install of 10.10 netbook, 10.10 desktop, even 10.4 desktop (what I was previously running) and all the installers hang! Tried a different USB drive as well, same results.

Is my HDD dead? Is my motherboard shot? What gives?
Reply With Quote
  (#2) Old
magnetbox magnetbox is offline
Junior Member
 
Posts: 5
Join Date: Aug 2009
Default 10-18-2010, 11:00 PM

Tried a few more things. I can boot from the Live image, but install hangs.

When I try to format my HDD in Disk Utility, I get:

Error creating partition table: helper exited with exit code 1: BLKRRPART ioctl failed for /dev/sda: Device or resource busy

I can perform a read benchmark fine, though.
Reply With Quote
  (#3) Old
reflex reflex is offline
Guru
 
reflex's Avatar
 
Posts: 1,997
Join Date: Apr 2009
Default 10-25-2010, 09:58 PM

I dunno. Assuming that you don't care about data on the disk, I'd try partitioning and formatting manually, outside the installer (but still off the LiveCD). If you're using the whole disk for Ubuntu, I might setup a 2GB swap partition, a 12GB ext4 root partition, and the rest as an ext4 home partition.

If it succeeds, then run the installer, and use manual partitioning to install into the partitions that are already created.


Mini 9 | Intel 5100 Wifi | Ubuntu 10.04 Netbook
Mini 1012 | SSD | Intel 6200 Wifi | Ubuntu 11.10 64bit
Reply With Quote
  (#4) Old
magnetbox magnetbox is offline
Junior Member
 
Posts: 5
Join Date: Aug 2009
Default 10-27-2010, 05:17 AM

Quote:
Originally Posted by reflex View Post
I dunno. Assuming that you don't care about data on the disk, I'd try partitioning and formatting manually, outside the installer (but still off the LiveCD).

Thanks! I tried this on my own a few hours after my last post and managed to get it working. I guess the partition tables must have been messed up somehow...
Reply With Quote
Reply

« Previous Thread | Next Thread »
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Copyright © 2008-2016 MyDellMini.com.