Dell Latitude 2100 Discussion on the Dell Latitude 2100, a rugged 10-inch netbook released to the educational market.

Reply
 
Thread Tools Display Modes
  (#11) Old
tntc.tig tntc.tig is offline
Member
 
Posts: 51
Join Date: Apr 2009
Smile 10-03-2009, 05:16 PM

It looks like the audio drivers work out of the box in the alpha 6 and beta of Ubuntu 9.10, only requiring you to un-mute the mic to get recording in sound recorder. The touchscreen driver from Dell's website under the ubuntu 9.04 drivers catagory also works in 9.10. I will write a tutorial on how to install this when it is not 3AM.


Inspiron E1505 (Silver/White)
Latitude 2100 (Blue Ribbon) w/Touchscreen and WiFi Link 5100 AGN
Want Ubuntu on your 2100? Get your sound and touchscreen working!
Tech blog: Broken Hive Mind
Reply With Quote
  (#12) Old
tntc.tig tntc.tig is offline
Member
 
Posts: 51
Join Date: Apr 2009
Default Get your Latitude 2100 IDC 6680 touchscreen working in Karmic! - 10-18-2009, 06:39 PM

Step 1) Get the drivers:
Go to Welcome to Dell Support, go to driver downloads, select your mode(Latitude 2100), select Ubuntu Desktop Edition 9.04 as the OS, and download the ideacom touchscreen drivers. In my case, the file was called welch_touchscreen_ubunt9.04.tgz. Extract them to whatever folder you like. I chose ~\Downloads, and will use this folder throughout.

Step 2) Stop GDM and X, get an Xorg.conf.
Press CTRL+ALT+F1 to change to TTY1 (Virtual Terminal). Log in using your normal username and password. Stop gdm with the following command: "sudo service gdm stop"
You will be asked for your password.

Next, type "sudo Xorg -configure" to create an Xorg.conf. It will be generated in your home directory (~), and it will be called xorg.conf.new. Type "sudo mv ~/xorg.conf.new /etc/X11/xorg.conf" to move it to the correct folder in etc for the driver. Press CTRL+ALT+F2 to get to TTY2. Log in there, and type "sudo Xorg" to start X for setting up the touchscreen. You will need to enter your password.
Press CTRL+ALT+F1 to change to TTY1 again.

Step 3) Install the drivers:
find where you put the files (again, in my case ~/Downloads/), and do "cd debs/main/". Run
"sudo -s" and enter your password again (if needed). YOU ARE NOW ROOT. BE VERY CAREFUL.
As root, run "DISPLAY=:0 dpkg -i idc-touch*.deb" to install the driver. The DISPLAY=:0 bit is to tell the driver where your X session from before is running.
Hit CTRL+ALT+F1 to get to TTY1. Make sure dpkg finished succesfully and with no errors.
Hit CTRL+ALT+F2 to get back to TTY2. Press CTRL+C to kill the Xorg server.
Type "sudo service gdm start" to restart GDM. Log in.
Run the calibration utlitiy now found under Applications->Accessories->Touch Screen (Likely near the bottom.)
You will need to type in your password.

Step 4) Reboot:
Reboot (sudo reboot) to make sure the touchscreen maps correctly in udev. Log in to your Gnome Desktop. Test your touchscreen. Recalibrate if needed. RECALIBRATION DOES NOT REQUIRE A LOG OUT WITH THIS DRIVER! It takes effect immediately, unlike the previous evtouch driver.

Step 5) Tweaking:
I had some issues with using controls in Gnome on this screen. They are relatively small targets, and this made scrolling, mouse movement, etc, difficult. As a result, I decided to change the window controls to make them easier to use. First, I increased the font size in System->Preferences->Appearance, click the Fonts tab. Change the Window title font to something larger (I picked 12.5), and this will increase the size of the minimize/maximize/close controls in most themes. Next, I wanted to make the scroll bars wider and easy to scroll. I created ~/.gtkrc-2.0 to put some additional settings in. In this file, put the following text:

style "scroll"
{
GtkScrollbar::slider-width = 15
}

class "*" style "scroll"


The line "GtkScollbar::slider-width = 15" is where the action is at. This sets the number of pixels wide that the scrollbars are. I initially tried setting it for 25 and 20, but these were too wide and looked ungainly.

I also had some difficulty getting right click to work on the touchscreen (tap and hold on the touchscreen produces a right click event). I hunted for configuration files for the touchscreen after installing the driver, and discovered that it used configuration files in /etc/. There is a folder called /etc/IDC/ which contains the same files, but the driver appears to ignore these. The file that is important for fixing my right click issue was /etc/settings.txt, specifically "LongTouchTime" and "MoveLimit". The LongTouchTime is how long you must hold the touchscreen before the right click menu comes up. I set mine for 500. MoveLimit is how many pixels you can move your finger before it is considered moving the mouse rather than a right click. I set this for 100. These settings worked for me, but your milage may vary.

I also found that /etc/idctsc.conf had a line called "stabilityRange", with an intial setting of "3". I was able to leave this at the default, but found that increasing this setting makes the cursor move in bursts of pixels: When you click and drag on the touchscreen, you will notice it follows your finger in a jagged line moving across and down in segments rather than a direct diagonal pull. It also means that your mouse stays in one place if you click and hold, ignoring slight movements. This makes right clicking easier, but dragging accurately harder.


Inspiron E1505 (Silver/White)
Latitude 2100 (Blue Ribbon) w/Touchscreen and WiFi Link 5100 AGN
Want Ubuntu on your 2100? Get your sound and touchscreen working!
Tech blog: Broken Hive Mind
Reply With Quote
  (#13) Old
itchyd itchyd is offline
Junior Member
 
Posts: 2
Join Date: Nov 2009
Default 11-13-2009, 12:09 AM

Hey I'm having tons of trouble getting UNR 9.10 on my latitude working. When I boot from the USB key it prompts me to load restricted drivers to get the wifi working. When I boot from the ssd after installing I don't get any option to install those drivers... any advice? I've gone to the hardware drivers screen and it says no proprietary drivers installed.
Reply With Quote
  (#14) Old
reflex reflex is offline
Guru
 
reflex's Avatar
 
Posts: 1,997
Join Date: Apr 2009
Default 11-13-2009, 12:23 AM

Quote:
Originally Posted by itchyd View Post
Hey I'm having tons of trouble getting UNR 9.10 on my latitude working. When I boot from the USB key it prompts me to load restricted drivers to get the wifi working. When I boot from the ssd after installing I don't get any option to install those drivers... any advice? I've gone to the hardware drivers screen and it says no proprietary drivers installed.
I'm guessing your Latitude has a Broadcom WiFi card, so this might be a description of your problem and a potential solution.


Mini 9 | Intel 5100 Wifi | Ubuntu 10.04 Netbook
Mini 1012 | SSD | Intel 6200 Wifi | Ubuntu 11.10 64bit
Reply With Quote
  (#15) Old
itchyd itchyd is offline
Junior Member
 
Posts: 2
Join Date: Nov 2009
Default thanks! - 11-13-2009, 01:23 AM

Hey thanks for the fast response, that solution worked great! I am now trying to get the touch screen working. I followed all the instructions above but when I launch the calibration utility it flashes up on the screen for a second and then crashes... any tips?
Reply With Quote
Reply

Tags
install, latitude 200, linux, ubuntu, welsh

« Previous Thread | Next Thread »
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Copyright © 2008-2016 MyDellMini.com.