General Mac OS X Discussion General Apple and Mac OS X Discussion

Reply
 
Thread Tools Display Modes
  (#51) Old
flipside flipside is offline
Member
 
Posts: 54
Join Date: Dec 2008
Default Re: Type11 v7.5 ISO Posted Please Help Test! [BETA] - 01-03-2009, 06:54 AM

unable to open device '/dev/disk0': no such file or directory
Reply With Quote
  (#52) Old
flipside flipside is offline
Member
 
Posts: 54
Join Date: Dec 2008
Default Re: Type11 v7.5 ISO Posted Please Help Test! [BETA] - 01-03-2009, 06:56 AM

I'll stay up for another 10 minutes or so if you want to try this over msn.. might be a little easier..

flipside99@hotmail.com
Reply With Quote
  (#53) Old
Type11 Type11 is offline
Senior Member
 
Posts: 218
Join Date: Oct 2008
Default Re: Type11 v7.5 ISO Posted Please Help Test! [BETA] - 01-03-2009, 06:57 AM

I also meant to add you most likely will have to do the above booted from leo install disk and go to terminal in tools menu. Check disk0 is the right disk in this setup though by doing diskutil list in terminal and adjust if necessary.

If the above does not work can also try

sudo gpt destroy /dev/disk0
sudo gpt create /dev/disk0
sudo gpt add -i 1 -b 40 -s 409600 -t efi /dev/disk0
sudo gpt add -i 2 -b 409640 -s 59516864 -t hfs /dev/disk0

diskutil eraseVolume "Journaled HFS+" <DISK NAME HERE> /dev/disk0s2

hope that helps
Reply With Quote
  (#54) Old
flipside flipside is offline
Member
 
Posts: 54
Join Date: Dec 2008
Default Re: Type11 v7.5 ISO Posted Please Help Test! [BETA] - 01-03-2009, 07:04 AM

Booted from leopard install and get this for every command:

unable to open device '/dev/disk0': no such file or directory
Reply With Quote
  (#55) Old
Type11 Type11 is offline
Senior Member
 
Posts: 218
Join Date: Oct 2008
Default Re: Type11 v7.5 ISO Posted Please Help Test! [BETA] - 01-03-2009, 07:19 AM

sorry man can't get on msn all I can really say is try and add a -r flag to commands or try rdisk0 disk0 and /dev/rdisk0

My only real experience with gpt is when I expanded my drive size on my AppleTV but it did not have these problems
Reply With Quote
  (#56) Old
blavalla blavalla is offline
Member
 
Posts: 38
Join Date: Nov 2008
Default Re: Type11 v7.5 ISO Posted Please Help Test! [BETA] - 01-03-2009, 09:40 AM

I was having the same problem as flipside and managed to solve it. I did two things and I am not sure which fixed the problem.

I booted off the leopard disc, opened disk utility, and repaired disk permissions which found one conflict and repaired it.
I then opened terminal and typed the following command:

Code:
diskutil eraseVolume "HFS+" "EFI" /dev/disk0s1
I then rebooted with -f and ran the script without problem.

Hopefully this helps!
Reply With Quote
  (#57) Old
flipside flipside is offline
Member
 
Posts: 54
Join Date: Dec 2008
Default Re: Type11 v7.5 ISO Posted Please Help Test! [BETA] - 01-03-2009, 12:39 PM

That did it!

Although disk utility didn't find any issues so it was the eraseVolume command in terminal.

Nice job! It was driving me nuts!
Reply With Quote
  (#58) Old
atoms atoms is offline
Member
 
Posts: 82
Join Date: Dec 2008
Default Re: Type11 v7.5 ISO Posted Please Help Test! [BETA] - 01-03-2009, 03:09 PM

My current setup: 10.5.5 w/ Type 11 install and SD card and Sleep kexts. I have the stock 16GB SSD. Everything is working well. I want to do the 10.5.6 update and then try this new miniscript.

I am about to try this, but wanted to ask a couple questions first:

Is there some new audio bug introduced? Was that only with 7.1?

Is there a new graphics driver? This current one is working well for me and I'd hate to mess it up.

Thanks guys, and especially Type 11. You are the man.
Reply With Quote
  (#59) Old
Jason Jason is offline
Junior Member
 
Posts: 13
Join Date: Jan 2009
Default Re: Type11 v7.5 ISO Posted Please Help Test! [BETA] - 01-03-2009, 03:17 PM

Blavalla's tip worked for me as well. Script ran fine after that trick.

Many thanks to Blavalla and to Type11!
Reply With Quote
  (#60) Old
HMiller HMiller is offline
Junior Member
 
Posts: 11
Join Date: Dec 2008
Default Re: Type11 v7.5 ISO Posted Please Help Test! [BETA] - 01-03-2009, 03:51 PM

atoms, the audio problem seems to be related to the DSDT.aml needing to be slightly different beteen minis. In my case 7.5 fixed it, but I believe a previous post indicated that 7.1 -> 7.5 caused him to have a problem. You could back up DSDT.aml prior to running the script and restore if you have to.

I had no problems with video with either version. Not sure about sleep or SD card as I still have the 16GB STEC drive and heard it would not sleep. Have you got sleep working on yours?

I did the 10.5.6 update prior to the 7.5 script and had zero problems with either step, although some people obviously have.

Don't know if this will help you, but good luck. Time Machine backup does work if you want to go that route


Dell Mini9 OSX 10.5.6 - 1GB/16GB STEC/Cam/BT -Type11 v7.7 Working Sleep/Wake
Asus P5B Deluxe 10.5.5 iDeneb v1.3
Reply With Quote
Reply

« Previous Thread | Next Thread »
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Copyright © 2008-2016 MyDellMini.com.