General Mac OS X Discussion General Apple and Mac OS X Discussion

Reply
 
Thread Tools Display Modes
  (#211) Old
Pantss Pantss is offline
Junior Member
 
Posts: 11
Join Date: Jun 2010
Default 07-16-2010, 05:43 PM

Quote:
Originally Posted by btd29 View Post
Can some post the .IMG file of the .8.4pre for those of us who do not have access to a SL mac, but can use image write on windows? I'm sure there are plenty of others who would apreciate this as well
bump..

i tried 0.8.3 from mechdrew and 0.8.4RC1 from http://www.mydellmini.com/forum/dell...ing-osx-2.html

but i got kernel panics.. sigh. this is my third day trying to get it to work.

would anyone be kind enough to provide an iso or img of 0.8.4pre? thank you!
Reply With Quote
  (#212) Old
Pantss Pantss is offline
Junior Member
 
Posts: 11
Join Date: Jun 2010
Default 07-17-2010, 07:36 AM

Quote:
Originally Posted by Pantss View Post
bump..

i tried 0.8.3 from mechdrew and 0.8.4RC1 from http://www.mydellmini.com/forum/dell...ing-osx-2.html

but i got kernel panics.. sigh. this is my third day trying to get it to work.

would anyone be kind enough to provide an iso or img of 0.8.4pre? thank you!
damn. im getting really desperate. there's pretty much nothing i can do other than slot the retail disc into the imacs at apple store and reset the administrator password in order to get netbookmaker to run and then give me the usb stick.
Reply With Quote
  (#213) Old
Pantss Pantss is offline
Junior Member
 
Posts: 11
Join Date: Jun 2010
Default 07-18-2010, 06:20 AM

I know that I have to use an intel based mac and not a PPC to run the app but may I know why am I getting the
"You cannot use this version of the application NetbookInstaller 0.8.4pre with this version of Mac OS X." error?

I'm using a mac pro running version 10.5.6, 2 x 3 GHz Dual-Core Intel Xeon processors.


Last edited by Pantss; 07-18-2010 at 06:30 AM.
Reply With Quote
  (#214) Old
balisana balisana is offline
Junior Member
 
Posts: 1
Join Date: Jul 2010
Default 07-20-2010, 09:15 AM

Thanks to jedparkes on page 18 of this thread, I was able to successfully install from my 10.6.3 disk onto my dell 1012. I did not do dual boot. I did need to do arch=i386 fix.
I believe the sound is fixed, but haven't really tested it. I have not attempted to upgrade to 10.6.4 yet.
The only problem I have is wireless. Based on this thread, I see I can create a dongle, but I'd rather it work. System profiler doesn't even list a wireless installed. (yet there is one)

The recommendations were to re-run netbookinstaller, which I did. Then to run disk utility and repair permissions, which I also did.
________

Inspiron Mini 10 (Inspiron 1012), Intel Atom N450, 1.6GHz, 667MHz, 512KB L2 Cache
Intel Atom Processor N450 (1.66GHz, 512K L2 Cache)
1GB DDR2 SDRAM
Intel NM10 Express,INFO
250GB 5400RPM SATA Hard Drive
Integrated 10/100 Network Card
Integrated High Definition Audio 2.2
Wireless 802.11n (HB95) Mini Card
Reply With Quote
  (#215) Old
almayer almayer is offline
Junior Member
 
Posts: 1
Join Date: Jul 2010
Unhappy 07-29-2010, 08:30 AM

I have a Dell Mini 1012, I tried to install Mac OS, following the procedure by Jedparkes on page 18, 10.6.3 refuses to boot (Stage 2), 10.6.0 boots, installs, but when I restart the Dell tells me no OS found.
Reply With Quote
  (#216) Old
questionmark425 questionmark425 is offline
Junior Member
 
Posts: 26
Join Date: Jul 2010
Unhappy Dell BIOS question. - 07-30-2010, 06:48 PM

So, I am having interesting problems with my 1012.

I can get the installer to run from NBBM, and it will make it a third of the way through, and then fail.

In order to even get the installer to launch, I must use the arch=i386 command or it will hang at the mach_kernel.

After the install fails, if I attempt to use NBBM again, it just hangs at a grey screen, before I even get the option to enter boot commands.

In order to get NBBM to work again, I have to reformat my hard drive to NTFS. Weird.

Also, I am on BIOS version A09, and I haven't even seen that BIOS version outside of my own 1012, could that be affecting this? If so, how can you downgrade? Dell only offers a windows installer package that will not let you downgrade.

Any suggestions?

Edit: used NBBM 0.8.4pre with 10.6.0 Retail DVD and it worked without a hitch. Updated to 10.6.4 and got KP, but all it took was a restore of my previous mach_kernel and I am now running 10.6.4 swimmingly =)

Last edited by questionmark425; 08-02-2010 at 08:49 PM. Reason: Works now
Reply With Quote
  (#217) Old
questionmark425 questionmark425 is offline
Junior Member
 
Posts: 26
Join Date: Jul 2010
Default AR9285 (HB95 mini card) - 08-02-2010, 08:57 PM

Quote:
Originally Posted by balisana View Post
Thanks to jedparkes on page 18 of this thread, I was able to successfully install from my 10.6.3 disk onto my dell 1012. I did not do dual boot. I did need to do arch=i386 fix.
I believe the sound is fixed, but haven't really tested it. I have not attempted to upgrade to 10.6.4 yet.
The only problem I have is wireless. Based on this thread, I see I can create a dongle, but I'd rather it work. System profiler doesn't even list a wireless installed. (yet there is one)

The recommendations were to re-run netbookinstaller, which I did. Then to run disk utility and repair permissions, which I also did.
________

Inspiron Mini 10 (Inspiron 1012), Intel Atom N450, 1.6GHz, 667MHz, 512KB L2 Cache
Intel Atom Processor N450 (1.66GHz, 512K L2 Cache)
1GB DDR2 SDRAM
Intel NM10 Express,INFO
250GB 5400RPM SATA Hard Drive
Integrated 10/100 Network Card
Integrated High Definition Audio 2.2
Wireless 802.11n (HB95) Mini Card

You're having the same Issue I am having with the wireless card. If you edit the Atheros kext files plists located in the IO80211Family.kext, the card will show in system profiler and will be recognized by AirPort.

However, it does not populate the country code and location fields, which are what tells the WiFi card what networks to search for. Therefore you cannot see or connect to any networks.

This is where I am stuck, if I knew how to edit those fields, I could probably get it working. There is a very similar card (AR9280) that ships with a model of iMac, which is why you can edit the kext to recognize in the first place.

So there is hope.

Anyone have any advice on how to populate the country code and location fields to say "FCC" and "US" instead of "Unknown"?

All of the new Mini 1012 models are shipping with this WiFi card, so I expect there to be several users with this issue.

---------- Post added at 08:57 PM ---------- Previous post was at 08:54 PM ----------

Quote:
Originally Posted by Pantss View Post
I know that I have to use an intel based mac and not a PPC to run the app but may I know why am I getting the
"You cannot use this version of the application NetbookInstaller 0.8.4pre with this version of Mac OS X." error?

I'm using a mac pro running version 10.5.6, 2 x 3 GHz Dual-Core Intel Xeon processors.


In order to use NBBM 0.8.4pre or newer, you NEED to have Snow Leopard installed on the Mac that you are using to create the USB installer.

Since you have an actual Mac Pro, I would upgrade that sucker anyway

it's only $29 after all!
Reply With Quote
  (#218) Old
xinweix xinweix is offline
Junior Member
 
Posts: 1
Join Date: Aug 2010
Default 08-07-2010, 07:18 AM

Can anyone who has 1012 and installed SL successfully tell me that whether the functionalities are fully supported, for example, sound, wireless and graphic. Thanks.
Reply With Quote
  (#219) Old
questionmark425 questionmark425 is offline
Junior Member
 
Posts: 26
Join Date: Jul 2010
Default 08-07-2010, 02:30 PM

Quote:
Originally Posted by xinweix View Post
Can anyone who has 1012 and installed SL successfully tell me that whether the functionalities are fully supported, for example, sound, wireless and graphic. Thanks.

You can find the answers to your questions in this thread, as well as on page 18 you will find a full install / dual boot guide.

Short answers,

Sound: Yes. You may want to use the sound pop fix. Install SL and you will see what I mean.

Wireless: Dell mini card: Yes. Atheros HB95 (9285): Not at this time.

Graphics: Correct resolution: Yes. Hardware acceleration - QE/CI: No. At least not for now, Meklort has been working on it.

Happy installing.
Reply With Quote
  (#220) Old
alphonsine alphonsine is offline
Junior Member
 
Posts: 7
Join Date: Aug 2010
Default 08-08-2010, 06:16 AM

If only the whole Google Universe started making the 1012 to work with mac os x...

---------- Post added at 05:55 AM ---------- Previous post was at 05:39 AM ----------

Can i help you giving the 1012 to work with mac os x, Mek lort?

---------- Post added at 06:16 AM ---------- Previous post was at 05:55 AM ----------

Quote:
Originally Posted by meklort View Post
I recently obtained a Dell Mini 1012 to test out OS X on. It turns out that other than the cpu / gpu combo, the hardware is *exactly* the same as the 10v. In other words, wifi, ethernet, audio and the touchpad all work just like the 10v.

Unfortunately, the GPU is unsupported in OS X. It's a modified GMA 3100, not the supported X3100, so it won't work with hardware acceleration (at least not for a while).

I do have full resolution with no gfx driver, however there is no hardware acceleration.

I have patched the GMA 950 kext to load for the 3150 (they are similar), and the gui is able to partially load (with hardware acceleration), however it is unusable at the moment. The background does not load and it is extremely unresponsive (takes 10 to 20 minuets to just load the menu bar).

So, for now, *Don't* buy the 1012 if you want to run OS X. The 10v is a much better option in terms of support just because the graphics card works. In the future, the 3150 could be made to work, however it's currently a no go. I will be adding 1012 support to NBI, but again, it won't be nearly as good as with the 10v.
How bad is it is Dell Mini 1012 without hardware acceleration?
Reply With Quote
Reply

« Previous Thread | Next Thread »
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Copyright © 2008-2016 MyDellMini.com.