Dell Streak Forum for discussion on Dells 5'' android tablet, the Dell Streak

Thread Tools Display Modes
  (#1) Old
subhro subhro is offline
Junior Member
Posts: 2
Join Date: Apr 2011
Arrow My Dell Mini 5 Streak is unable to connect to Wifi networks with hidden SID - 04-11-2011, 04:15 PM

Hello, I brought my UNLOCKED Dell Streak 5 tablet in February this year from ebay and since then I am unable to connect it to my office wireless network which has a hidden SID. In general any device can connect to it once we manually put in the SID and WAP security credentials. The problem is only happening with my Streak and no other devices. My Streak (with Froyo 2.2) actually cannot connect to any hidden wireless network even if I manually try to configure it. Gives error - "Network not in range" as if the network is out of it's range which is not. However my Streak connects fine with any broadcasted visible WiFi networks. Does anyone has any answer for me ? Thank you, Subhro, Canada
Reply With Quote
  (#2) Old
marvin02 marvin02 is offline
Senior Member
marvin02's Avatar
Posts: 100
Join Date: Sep 2010
Location: Indiana, USA
Default 04-12-2011, 05:01 PM

Connecting to a WiFi network with a hidden SSID

The standard is that the SSID should not be hidden. Devices that won't connect to a network with a hidden SSID are actually working the way they should. I know that many devices ignore this.
Reply With Quote
  (#3) Old
subhro subhro is offline
Junior Member
Posts: 2
Join Date: Apr 2011
Default 04-12-2011, 07:56 PM

@marvin02 - So what I am hearing from you is that Dell Streak DOES NOT have the ability to connect to any hidden SSIDs when most of today's smartphones and tablets have the ability. Right ? If so, is there any possibility for it to be changed by the next Android OS upgrade (next version) or by tweaking some root files ?
Reply With Quote
  (#4) Old
capbobokc capbobokc is offline
Junior Member
Posts: 1
Join Date: Jan 2012
Default I too am not able to connect with ANY wifi at ANY time. - 01-22-2012, 08:10 PM

It says it is connected but times out every time . I tried turning off data to no avail. Is there no one that can help? Not in the last eight months it seams not!

Also how do I turn on 3G. I am on the Edge it seems.
Reply With Quote
  (#5) Old
Strephon Alkhalikoi Strephon Alkhalikoi is offline
Strephon Alkhalikoi's Avatar
Posts: 45
Join Date: Mar 2010
Default 01-25-2012, 03:14 AM

@capbobokc: The simple answer don't turn on 3G.

The long answer is this: The Streak or any cellular device will automatically pick out the strongest signal from a particular tower and lock on to that signal. When you change towers, for example when driving, the Streak repeats the process. Thus you do not "turn on" 3G. While that answers your question, it's not the entire story. The carrier you have and the type of Streak you own play a part in this as well.

There are two different Dell Streaks available. One for use with AT&T's frequencies and one for T-Mobile frequencies. If the carrier and the Streak match, then you will get 3G or HSPA*. If the carrier and the Streak do not match, then you are stuck on EDGE.

So, to summarize:
  1. AT&T (Carrier) and AT&T Streak = 3G, HSPA
  2. T-Mobile (Carrier) and T-Mobile Streak = 3G (To the best of my knowledge T-Mobile does not have HSPA.)
  3. AT&T (Carrier) and T-Mobile Streak = EDGE
  4. T-Mobile (Carrier) and AT&T Streak = EDGE
If option 1 or option 2 are true, then you are either in an area with no 3G/HSPA service, or the tower is malfunctioning. In which case you want to call your carrier and have them service their tower.
If option 3 or 4 are true, you will never get 3G on the Streak.

*Disclaimer: This statement assumes the user is in a 3G coverage area and the nearest cellular tower functions correctly.
Reply With Quote

« Previous Thread | Next Thread »
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Copyright © 2008-2016