Mac OS X Guides Guides for installing and configuring Mac OSX on your Dell Mini.

Comment
 
Tutorial Tools Display Modes
HOWTO: Using mobile broadband / WWAN module in OSX
Published by mbbrocks
01-26-2009
Default HOWTO: Using mobile broadband / WWAN module in OSX

If you've got a Mini 9 with the Dell 5530 HSPA / Mobile Broadband module, here's what you need to know to get it going:
  • Download the following modem script: http://www.mobilebroadbandrocks.com/...-broadband.zip
    Unzip the script and place it in your root:library:modem scripts folder.
    Go into system preferences and select Network
    Select ‘Dell Wireless 5530 HSPA Mobile’ from the list on the left
    Click on advanced
    Under the modem tab, change the vendor to ‘other’ and select ‘Dell Mobile Broadband’ from the list, click on ok
    Back on the network screen, enter ‘none’ as the telephone number. This means the modem script will use the default APN. If you want to specify the APN you want to use, enter it in the telephone number field (e.g. ‘internet’). Leave account name and password blank.
    Select ’show modem status in menu bar’
    Click on apply
    When you want to connect, click on the phone icon on the top menu bar, near the time. Click on ‘Connect Dell Wireless 5530 HSPA Mobile’ and you’re away.

If you're having problems, you may need to enter your APN manually. Back in the connection properties, change the 'telephone number' to the name of your APN. The APN will vary depending on which mobile operator you use - for example, if you're a contract Vodafone UK customer, the APN will be 'internet'. Try http://www.filesaveas.com/gprs.html for details on UK APNs.
Tutorial Tools

Featured Tutorials
  #1  
Old 01-26-2009, 04:40 PM
DanielN's Avatar
DanielN DanielN is offline
Senior Member
 
Join Date: Dec 2008
Location: Austin, Texas
Posts: 159
Default Re: HOWTO: Using mobile broadband / WWAN module in OSX

I've attached the script locally.
Attached Files
File Type: zip dell-mobile-broadband.zip (3.0 KB, 1132 views)
Reply With Quote
  #2  
Old 01-28-2009, 11:08 AM
GreyPaint GreyPaint is offline
Senior Member
 
Join Date: Jan 2009
Posts: 134
Default Re: HOWTO: Using mobile broadband / WWAN module in OSX

Hi
This method works very well, but takes time to connect - about 5 - 10 seconds for me.
Also, with no easy indication of HSDPA, Edge etc. you are unsure if the connection is giving good throughput. From experience, you can be in a good signal area, but getting a persistent connection to a poorer connection. Sometimes re-instigating the conneciton makes all the difference.

I have used this same method for a t-mobile USB 3G card in the UK - then replaced it with a custom Launch2Net program - free for their modems but $80 or so otherwise.
This shows the connection info + the monthly up/down totals + the signal and connects quicker than the script

Don't want to invest in this in case it does not work. Can anyone else try?
__________________
Mini9, 2Gb, 8Gb SSD, 16Gb SDHC, SL 10.6.3, Sound fix without Voodoo, Bluetooth Mod, NBI 0.8.4
Reply With Quote
  #3  
Old 01-29-2009, 05:03 PM
whmcr whmcr is offline
Junior Member
 
Join Date: Jan 2009
Posts: 2
Default Re: HOWTO: Using mobile broadband / WWAN module in OSX

I've attempted to load the launch2net software and it doesnt appear to be working at the moment with the 5530, bombs out with a modem initalisation error
Reply With Quote
  #4  
Old 03-02-2009, 08:08 PM
Bobeee Bobeee is offline
Junior Member
 
Join Date: Mar 2009
Posts: 5
Default Re: HOWTO: Using mobile broadband / WWAN module in OSX

I am having the same problem. I have tried everything. Both of the suggested scripts including the Mobilebroadbandrocks + the launch2net software and which as whmcp says, results in a modem initalisation error.

I even purchased an EU850D card with integral SIM, but this is not even seen by Mac OS

I am in the UK, and the problem is with the Vodafone model.

Mac OS X10.5.6 runs great - its really fast installed on a Runcore 32GB SSD

If I could crack this problem, it would be the perfect Mini Macbook & truly mobile

Any suggestions?
Reply With Quote
  #5  
Old 03-02-2009, 09:00 PM
GreyPaint GreyPaint is offline
Senior Member
 
Join Date: Jan 2009
Posts: 134
Default Re: HOWTO: Using mobile broadband / WWAN module in OSX

My WWAN works fine... no issues, other than as mentioned above...
__________________
Mini9, 2Gb, 8Gb SSD, 16Gb SDHC, SL 10.6.3, Sound fix without Voodoo, Bluetooth Mod, NBI 0.8.4
Reply With Quote
  #6  
Old 03-03-2009, 12:10 AM
ukbodypilot ukbodypilot is offline
Member
 
Join Date: Mar 2009
Posts: 49
Default Re: HOWTO: Using mobile broadband / WWAN module in OSX

Worked for me. I thought it had failed as there are 2 Dell HSPDA modems listed - perhaps my 10.5.6 install had already picked it up. No idea how to get rid of the other one but I am not going to bother messing with it as it works great.

Thanks for the script
Reply With Quote
  #7  
Old 03-05-2009, 07:42 AM
spathi spathi is offline
Junior Member
 
Join Date: Mar 2009
Posts: 1
Default Re: HOWTO: Using mobile broadband / WWAN module in OSX

This also works great with my Dell Mini 9 from Vodafone Australia. You will need to enter the APN of vfinternet.au
Reply With Quote
  #8  
Old 03-06-2009, 04:44 PM
pr6srm pr6srm is offline
Member
 
Join Date: Jan 2009
Posts: 95
Default Re: HOWTO: Using mobile broadband / WWAN module in OSX

Quote:
Originally Posted by ukbodypilot
Worked for me. I thought it had failed as there are 2 Dell HSPDA modems listed - perhaps my 10.5.6 install had already picked it up. No idea how to get rid of the other one but I am not going to bother messing with it as it works great.
It's supposed to show two devices. Not wuite sure why, but that is how it works - perhaps one does 3G and one does GPRS, who knows? Anyway, it works
__________________

Dell Mini 9: Obsidian Black | A05 | Win7 / OS X 10.5.6 Dual Boot | DellEFI 1.1 | 2GB RAM | 64GB RunCore 70mm SSD | 4GB SDHC | Vodafone HSPA | 0.3mP webcam
Dell Mini 9: Obsidian Black | as above except: XP Pro SP3 | 250GB USB HDD
Reply With Quote
  #9  
Old 03-06-2009, 06:23 PM
Bobeee Bobeee is offline
Junior Member
 
Join Date: Mar 2009
Posts: 5
Lightbulb Re: HOWTO: Using mobile broadband / WWAN module in OSX

Update: Started again from scratch and the script is now working for me ;-)
But I did disable the "send PPP echo packets" settings
Reply With Quote
Comment

« Previous Tutorial | Next Tutorial »
Tutorial Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Copyright © 2008-2016 MyDellMini.com.