My Digital Discount MDD are online retailers of Runcore SSD drives and accessories for your Dell Mini netbook.

Reply
 
Thread Tools Display Modes
  (#1) Old
9mini 9mini is offline
Junior Member
 
Posts: 5
Join Date: Dec 2009
Default Damaged ssd received - 12-04-2009, 04:24 PM

I'm based in the UK and I ordered a 64gb runcore ssd. I got this yesterday and the packaging was a bit battered. The seal was broke as well. Looks like someone opened it to have a look at it. There was a also a bit of plastic rattling around. Looks like it came from the underside of the SSD. I tried the ssd in my mini and sadly it shows up as "jm loader 001" From what I can gather this means the ssd is bust.

Now I'm pretty certain that it's not working because of the battering it took. I've sent an email to mydigitaldiscount which hasn't been answered yet. I just don't know how I would go about getting a refund. I know the package was insured. But how do claims work? Surely I don't have to pay to send damaged goods back. It was expensive enough when it was sent the first time.

Has anyone else had any problems with damaged goods?
Reply With Quote
  (#2) Old
holmes4 holmes4 is offline
Administrator
 
holmes4's Avatar
 
Posts: 6,186
Join Date: Nov 2008
Location: New Hampshire
Default 12-04-2009, 04:48 PM

It may have been opened by Customs. I think the "jm loader 001" is correct - MDD loads the SSD with a trial version of Acronis TrueImage to make it easy for you to clone an existing SSD.


Steve
Mini 9|2GB RAM|64GB RunCore|Intel 5300|Windows 10
Reply With Quote
  (#3) Old
9mini 9mini is offline
Junior Member
 
Posts: 5
Join Date: Dec 2009
Default 12-04-2009, 05:27 PM

Right so it isn't broken? I'm not entirely sure how I go about getting it working. If it only ever shows up as being 1.92gb then how does it work?

If i can get it working then great. It would certainly make life easier for me. All i get now is it coming up with pxe boot and saying to check the cable. Much like what i was getting with my failed 16gb ssd.
Reply With Quote
  (#4) Old
MDD Danielle MDD Danielle is offline
Member
 
MDD Danielle's Avatar
 
Posts: 77
Join Date: Sep 2009
Default 12-04-2009, 06:12 PM

Quote:
Originally Posted by 9mini View Post
I'm based in the UK and I ordered a 64gb runcore ssd. I got this yesterday and the packaging was a bit battered. The seal was broke as well. Looks like someone opened it to have a look at it. There was a also a bit of plastic rattling around. Looks like it came from the underside of the SSD. I tried the ssd in my mini and sadly it shows up as "jm loader 001" From what I can gather this means the ssd is bust.

Now I'm pretty certain that it's not working because of the battering it took. I've sent an email to mydigitaldiscount which hasn't been answered yet. I just don't know how I would go about getting a refund. I know the package was insured. But how do claims work? Surely I don't have to pay to send damaged goods back. It was expensive enough when it was sent the first time.

Has anyone else had any problems with damaged goods?
I assure you that item did not leave our facility like that. We will be filing a claim with UPS regarding this. We will be able to ship this item to you as soon as UPS makes their decision. If you have any question or concerns regarding this please feel free to PM me directly.


MyDigitalDiscount.com is your connection to the digital world.

Join the MDD Community: Follow us on Twitter.com/MyDigital or become a fan on Facebook.com/MyDigitalDiscount to get the latest news, product updates and exclusive offers.
Reply With Quote
  (#5) Old
holmes4 holmes4 is offline
Administrator
 
holmes4's Avatar
 
Posts: 6,186
Join Date: Nov 2008
Location: New Hampshire
Default 12-04-2009, 07:00 PM

What shows as 1.92GB? The partition or the whole SSD? What does the BIOS report?


Steve
Mini 9|2GB RAM|64GB RunCore|Intel 5300|Windows 10
Reply With Quote
  (#6) Old
9mini 9mini is offline
Junior Member
 
Posts: 5
Join Date: Dec 2009
Default 12-04-2009, 07:19 PM

Quote:
Originally Posted by holmes4 View Post
What shows as 1.92GB? The partition or the whole SSD? What does the BIOS report?
In the bios it reports as jm loader 001

I tried plugging it into my usb port on my computer. Windows 7 reports it as being a 1.92 gb drive.

In the bios it is reporting the size as 4 gigs. It's very odd reporting 2 different sizes. Though if it has 2 seperate partitions on in maybe thats the reason?

When i plug in my xp installation thats on my usb stick, that reports it as 4 gigs. It wont let me install anything though.

I may have missed something somewhere.
Reply With Quote
  (#7) Old
holmes4 holmes4 is offline
Administrator
 
holmes4's Avatar
 
Posts: 6,186
Join Date: Nov 2008
Location: New Hampshire
Default 12-04-2009, 08:19 PM

Windows will see only the partition size. You'd have to go into the Disk Manager to see the full size. The BIOS should name it as a RunCore disk, though. It does sound as if there is a problem and I'm sure MDD will do right by you.


Steve
Mini 9|2GB RAM|64GB RunCore|Intel 5300|Windows 10
Reply With Quote
  (#8) Old
9mini 9mini is offline
Junior Member
 
Posts: 5
Join Date: Dec 2009
Default 12-17-2009, 01:23 AM

Well I've still got my damaged ssd. Nothing is being done about replacing it. I've just payed for something that is completely useless. Brilliant.
Reply With Quote
  (#9) Old
dasankir dasankir is offline
Junior Member
 
Posts: 1
Join Date: Aug 2010
Default 09-24-2010, 04:39 PM

Quote:
Originally Posted by 9mini View Post
Well I've still got my damaged ssd. Nothing is being done about replacing it. I've just payed for something that is completely useless. Brilliant.
I had the same problem after a power loss.

Fortunately, I fixed the problem with a firmware update/reinstallation.

In my case a Transcend TS32GSSD25S-M.

I downloaded the firmware from Transcend Download Center Welcome to Transcend Website

Made a bootable msdos usb drive and followed the instructions.

My was disk recovered and as new.

Hope it helps.
Reply With Quote
  (#10) Old
9mini 9mini is offline
Junior Member
 
Posts: 5
Join Date: Dec 2009
Default 10-03-2010, 12:05 AM

Just an update to this. It's not far off a year and I still haven't received a refund despite being told in August that UPS had approved the claim.

I've not come on here to have a good old moan about mydigitaldiscount. All I want is for my money from UPS to be refunded. I can't see a problem with this. I've had to make alternative arrangements to get another disk seeing as I've waited so long for this matter to be sorted which is why I would prefer the refund. Though at the end of the day as long as I either get a refund or the drive then I'm happy and I can move on with my life.

I know a lot of people on here rate mydigitaldiscount so I'm not sure why I'm having so much trouble with something that should be easy to resolve.
Reply With Quote
Reply

« Previous Thread | Next Thread »
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Copyright © 2008-2016 MyDellMini.com.