Ubuntu Discussion on Ubuntu on the Dell Inspiron Mini range of netbooks.

Reply
 
Thread Tools Display Modes
  (#21) Old
jmsanzg jmsanzg is offline
Junior Member
 
Posts: 11
Join Date: Nov 2008
Default Re: *.deb installing - 12-23-2008, 08:28 AM

This is what I did:

Code:
$ cd /

$ sudo mkdir opt

$ sudo chmod a+w opt

$ cd opt

$ wget http://download.skype.com/linux/skyp...0.0.72.tar.bz2

$ bzip2 -cd skype_static-2.0.0.72.tar.bz2 | tar xvf -
That's all, after that you'll have a /opt/skype directory and, inside, you'll see a skype startup script.
Reply With Quote
  (#22) Old
kelvin911 kelvin911 is offline
Member
 
Posts: 95
Join Date: Nov 2008
Location: Vancouver, BC, Canada
Send a message via MSN to kelvin911
Default Re: *.deb installing - 12-23-2008, 08:56 AM

what about opera??? i cant run any *.deb i download....

how do i get opera to work?
Reply With Quote
  (#23) Old
kelvin911 kelvin911 is offline
Member
 
Posts: 95
Join Date: Nov 2008
Location: Vancouver, BC, Canada
Send a message via MSN to kelvin911
Default Re: *.deb installing - 12-23-2008, 10:57 AM

pls delete this msg
Reply With Quote
  (#24) Old
kelvin911 kelvin911 is offline
Member
 
Posts: 95
Join Date: Nov 2008
Location: Vancouver, BC, Canada
Send a message via MSN to kelvin911
Default Re: *.deb installing - 12-23-2008, 10:58 AM

Quote:
Originally Posted by Ran
The updated version of gdebi also will install i386 packages under lpia automatically, but you'll need to get it from the dell mini notebook-remix repo rather than the dell mini notebook-base repo. (I'm not sure why Canonical put a bunch of normal system package updates there: ?) Adding the repos updates pretty much every package on the system (probably not really, but it is a *lot*), though; you might want to get the deb file from here:
http://dell-mini.archive.canonical.c...tbook1_all.deb

That should work; I went ahead and did the massive update, though, so I'm not sure. Everything seems to work fine after the update (I suspect if you don't choose to keep your GDM file auto-login will break if you have it enabled), except "Switch Desktop Mode" was moved to be under System>Preferences in the app menu instead of being available in the main part.

After getting the updated version of gdebi, I can install things like skype just by opening the .deb package. I wonder why it didn't ship with the mini, or at least be included in the normal update branch...

is this the ultimate solution??
Reply With Quote
  (#25) Old
yakker.yak yakker.yak is offline
Senior Member
 
Posts: 108
Join Date: Oct 2008
Default Re: *.deb installing - 12-23-2008, 06:05 PM

Another method, that won't mess/mix your repositories is to run each extra, third-party, i386 DEB through a script that will enable you to install the DEB within an LPIA system.

The script is here.

DEBs installed in this way should appear in Synaptic for un-install if needed.
Reply With Quote
  (#26) Old
kelvin911 kelvin911 is offline
Member
 
Posts: 95
Join Date: Nov 2008
Location: Vancouver, BC, Canada
Send a message via MSN to kelvin911
Default Re: *.deb installing - 12-25-2008, 01:34 PM

the script doesnt work on the flash10 installer deb,.... please help
Reply With Quote
  (#27) Old
yakker.yak yakker.yak is offline
Senior Member
 
Posts: 108
Join Date: Oct 2008
Default Re: *.deb installing - 12-27-2008, 04:31 PM

Quote:
Originally Posted by kelvin911
the script doesnt work on the flash10 installer deb,.... please help
There's a little more work with Flash 10.
Reply With Quote
  (#28) Old
kelvin911 kelvin911 is offline
Member
 
Posts: 95
Join Date: Nov 2008
Location: Vancouver, BC, Canada
Send a message via MSN to kelvin911
Default Re: *.deb installing - 12-27-2008, 08:52 PM

i added the netbook-remix repos and did lots of update, and now i am able to run any *.deb without a problem. but someone online says this is a bad idea to mix repos? is it true?
Reply With Quote
  (#29) Old
n4s720 n4s720 is offline
Member
 
n4s720's Avatar
 
Posts: 62
Join Date: Dec 2008
Location: Avila, Spain
Send a message via AIM to n4s720
Default Re: *.deb installing - 12-28-2008, 04:20 PM

Quote:
Originally Posted by yakker.yak
Ok. Turns out this is trickier than it appears. The problem is that there are two packages: gdebi and gdebi-core and the former depends on a particular version of the latter. Just updating the gdebi-core one will break gdebi (and consequently break your system since it'll complain about broken packages and refuse to install other ones).

Also explains why when you try to double-click on a DEB after updating only gdebi-core you get the archive manager trying to unpack the file: gdebi is broken and then next default application is the archive manager.

I've written up detailed instructions for fixing this and enabling both packages here.
I'm trying this guide but I cant get step one to work. I did install that other file from the previous post before I found this and now I cant get it to force the older verision. The force selection is grey and I cant select it.

Please keep in mind I'm a complete Linux n00b.


Black Mini 9, 16 gig SSD, 1 gig of RAM, 1.3mpx webcam, bluetooth, Windows XP
Reply With Quote
  (#30) Old
n4s720 n4s720 is offline
Member
 
n4s720's Avatar
 
Posts: 62
Join Date: Dec 2008
Location: Avila, Spain
Send a message via AIM to n4s720
Default Re: *.deb installing - 01-01-2009, 12:22 PM

Any ideas? I cant install anything nor remove stuff. How can I remedy this? Yaks guide isn't working.


Black Mini 9, 16 gig SSD, 1 gig of RAM, 1.3mpx webcam, bluetooth, Windows XP
Reply With Quote
Reply

« Previous Thread | Next Thread »
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Copyright © 2008-2016 MyDellMini.com.