Ubuntu Discussion on Ubuntu on the Dell Inspiron Mini range of netbooks.

Reply
 
Thread Tools Display Modes
  (#11) Old
JoeinDallas JoeinDallas is offline
Member
 
Posts: 35
Join Date: Nov 2008
Default Re: *.deb installing - 11-12-2008, 09:47 PM

Never mind (I'm talking to myself). I opened up a terminal window and tried "gdebi skypeblah.deb" and it worked. No sure why it didn't work from the gui?

Thanks again, and excuse me while I skype!

Joe
Reply With Quote
  (#12) Old
Ran Ran is offline
Junior Member
 
Posts: 7
Join Date: Nov 2008
Default Re: *.deb installing - 11-13-2008, 12:01 AM

Yay, glad you were able to get it working. It *should* have opened in gdebi from the start... ah, computers.
Reply With Quote
  (#13) Old
moongdss moongdss is offline
Junior Member
 
Posts: 22
Join Date: Oct 2008
Location: Laurel, MD
Default Re: *.deb installing - 11-13-2008, 10:21 PM

Hey Ran,

I downloaded and ran the file from that repository link and came across an "older file" notice, ran it anyway and now i have Broken dependencies. I'm trying to install the .deb of Avast.

Now the Mini is kind enough to tell me to run 'sudo synaptic' or 'sudo apt-get install -f' from a terminal window. Since this is my first real experience with linux, I figure this may be a good point to stop and ask what i just did wrong, and what exactly these commands will do to fix it? Yay learning experience! :lol:

Thanks in advance for the help!


Diana

Dell Mini 9, Ubuntu Remix, 16GB SSD, 1GB RAM, Obsidian
Reply With Quote
  (#14) Old
yakker.yak yakker.yak is offline
Senior Member
 
Posts: 108
Join Date: Oct 2008
Default Re: *.deb installing - 11-14-2008, 08:23 PM

Ok. Turns out this is trickier than it appears. The problem is that there are two packages: gdebi and gdebi-core and the former depends on a particular version of the latter. Just updating the gdebi-core one will break gdebi (and consequently break your system since it'll complain about broken packages and refuse to install other ones).

Also explains why when you try to double-click on a DEB after updating only gdebi-core you get the archive manager trying to unpack the file: gdebi is broken and then next default application is the archive manager.

I've written up detailed instructions for fixing this and enabling both packages here.
Reply With Quote
  (#15) Old
GerallK GerallK is offline
Senior Member
 
Posts: 241
Join Date: Oct 2008
Location: Beaumont, TX US
Send a message via Yahoo to GerallK
Default Re: *.deb installing - 11-14-2008, 09:05 PM

Wow - excellent catch, yakker.yak! I wonder how this is going to pan-out with the next release of updates?

Thanks for posting the info -


Obsidian Mini 9 > 2gb ram, 16gb ssd, bluetooth, 1.3mp webcam, us-intl kbd
Internal Mods > usb hub, 16gb flash drive, 8gb flash drive, added webcam, changed kbd
Software Mods > Dellbuntu 8.04.1 | Gentoo 2008.0
Reply With Quote
  (#16) Old
yakker.yak yakker.yak is offline
Senior Member
 
Posts: 108
Join Date: Oct 2008
Default Re: *.deb installing - 11-14-2008, 09:17 PM

Quote:
Originally Posted by GerallK
Wow - excellent catch, yakker.yak! I wonder how this is going to pan-out with the next release of updates?
The only potential catch is when these newer versions of gdebi and gdebi-core make it into the official Dell repos for the Mini -- not sure if the updates will be picked up automagically. If not, I think we'll need to do a 'Force version' to get them back on the Dell Mini upgrade rails and abandon the temp install of these. Should not be a big deal though.
Reply With Quote
  (#17) Old
moongdss moongdss is offline
Junior Member
 
Posts: 22
Join Date: Oct 2008
Location: Laurel, MD
Default Re: *.deb installing - 11-14-2008, 11:23 PM

awesomeness, than you for the reply! I'm going to follow your walk-thru after dinner.


Diana

Dell Mini 9, Ubuntu Remix, 16GB SSD, 1GB RAM, Obsidian
Reply With Quote
  (#18) Old
mcrider mcrider is offline
Junior Member
 
Posts: 5
Join Date: Nov 2008
Default Re: *.deb installing - 11-23-2008, 02:46 PM

There is an Italian bash script that automates this process of converting i386 debs to lpia, available at http://www.blogwol.com/2008/11/08/sc...er-intel-atom/. Of course it works fine on other language systems. Just put the script in your path, and it will convert all the .debs in the directory you run it from.
Reply With Quote
  (#19) Old
moongdss moongdss is offline
Junior Member
 
Posts: 22
Join Date: Oct 2008
Location: Laurel, MD
Default Re: *.deb installing - 11-23-2008, 07:36 PM

works great! thanks

I recommend translating the page in babelfish for the full instructions for those of us not terribly familiar with Linux.


Diana

Dell Mini 9, Ubuntu Remix, 16GB SSD, 1GB RAM, Obsidian
Reply With Quote
  (#20) Old
kelvin911 kelvin911 is offline
Member
 
Posts: 95
Join Date: Nov 2008
Location: Vancouver, BC, Canada
Send a message via MSN to kelvin911
Default Re: *.deb installing - 12-23-2008, 07:57 AM

so how do i install skype?? i cant get it to work??

is it better if i reinstall ubuntu the full version instead of dell version??

or the ubuntu netbook remix version??

i cant get skype to install

help :cry:
Reply With Quote
Reply

« Previous Thread | Next Thread »
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Copyright © 2008-2016 MyDellMini.com.