Ubuntu Discussion on Ubuntu on the Dell Inspiron Mini range of netbooks.

Reply
 
Thread Tools Display Modes
  (#11) Old
AK Dave AK Dave is offline
Member
 
AK Dave's Avatar
 
Posts: 79
Join Date: Feb 2009
Default 11-09-2009, 09:13 PM

Worked for me too!

Quote:
Originally Posted by Countzer0 View Post
This was my fix:

Edit /usr/sbin/pm-suspend ( ie. sudo gedit /usr/sbin/pm-suspend)

add this line to the beginning

umount <where your card is mounted> (ie. umount /media/mySD)

this worked for me ... good luck

jason


His: Obsidian Mini-9: Karmic UNR w/ Vbox-XP, 2gb, 32gb STEC, 16gb Transcend(6), US-INTL, sgpstore carbon
Hers: Arctic Mini-9: Dell Ubuntu, 1gb, 16gb STEC, 8gb SDHC(6)
Are you a Help Vampire?
Reply With Quote
  (#12) Old
Necrosynth Necrosynth is offline
Junior Member
 
Posts: 1
Join Date: Nov 2009
Default 11-13-2009, 01:15 AM

Quote:
Originally Posted by Countzer0 View Post
This was my fix:

Edit /usr/sbin/pm-suspend ( ie. sudo gedit /usr/sbin/pm-suspend)

add this line to the beginning

umount <where your card is mounted> (ie. umount /media/mySD)

this worked for me ... good luck

jason
Where exactly on the /usr/sbin/pm-suspend to I enter this? I tried immediately under the introduction and it froze when I tried suspend.
Reply With Quote
  (#13) Old
Colaeus Colaeus is offline
Junior Member
 
Posts: 1
Join Date: Nov 2009
Default Suspend not working in 9.10 - 11-15-2009, 03:30 PM

I checked the log file viewer for pm-suspend on mine (the unmount didn't word) and discovered pulseaudio wasn't shutting down. I installed the pulseaudio command line package, then the unmount of the SD card allowed suspend on my machine. Not ideal but it beats setting my system to shut down whenever I close the lid.

You can find the log viewer under System | Administration | Log File Viewer. I shows all the log files it follows in the left panel, just scroll down until you see pm-suspend, select it and scroll down the log on the right side to see the last suspend attempt. If there are any 'hooks' that failed. Here is part of my log that led me to the pulseaudio not shutting down:

Code:
/usr/lib/pm-utils/sleep.d/00powersave suspend suspend: success.
/usr/lib/pm-utils/sleep.d/01PulseAudio suspend suspend: sudo: pacmd: command not found
sudo: pacmd: command not found
Returned exit code 1.
Sun Nov 15 11:02:35 AST 2009: Inhibit found, will not perform suspend
Reply With Quote
  (#14) Old
leeosenton leeosenton is offline
Member
 
Posts: 90
Join Date: Dec 2008
Location: Virginia
Question Makes Sense - 11-22-2009, 02:19 PM

Quote:
Originally Posted by reflex View Post
I believe Linux generally uses swap to store hibernation data. So, your swap space needs to be sufficient. Unfortunately, the only way to determine the exact size of "sufficient" is by trial and error. If you have too much RAM in use, hibernation will fail.

But take my comments with a grain of salt, I never use swap and I never use hibernation.

I am glad that it worked for you with a little patience. The need for patience is one of the reasons I don't use hibernation.
That makes sense. I have been traveling for a while with my little friend and gained a few more Ubuntu experience points. I have reached your conclusion that hibernate is a waste of time and resources, so I have been reading about modifying my install. I monitored my memory footprint while using the system and rarely see more than 500mb in use, so can I just disable hibernate and use gparted to remove the swap? Or do I need to edit fstab manually?

Maybe the sequence should be:
Disable hibernate
Edit fstab to remove /swap
Reboot and remove swap partition
?
Thanks for your advice and 'realworld' opinion,
Lee


Black 2GB Memory, 16GB SSD, BT, 1.3 WebCam, Windows 7 Home Premium
Reply With Quote
  (#15) Old
niw_uk1964 niw_uk1964 is offline
Junior Member
 
Posts: 20
Join Date: Jan 2009
Location: Northern England
Send a message via ICQ to niw_uk1964 Send a message via MSN to niw_uk1964
Default 12-05-2009, 09:55 PM

Fixed! Thanks folks! I like open-source! :-)


2 cylinders is enough, but 3 is a fine compromise
www.twpdracing.com
www.twpd.co.uk
Dell Mini-9, Runcore 32GB ssd, 2GB RAM, Ubuntu 8.10
Reply With Quote
  (#16) Old
Teh Lurv Teh Lurv is offline
Junior Member
 
Posts: 14
Join Date: Aug 2009
Default 12-06-2009, 05:18 PM

Quote:
Originally Posted by Necrosynth View Post
Where exactly on the /usr/sbin/pm-suspend to I enter this? I tried immediately under the introduction and it froze when I tried suspend.
I entered it like this:

# The rule here? Simplicity.
umount /media/<name of SD card>
export STASHNAME=pm-suspend

worked like a charm for both hibernate and suspend. My remaining unresolved issue with my SD card is that it doesn't auto mount on boot. But that's not such a big deal.
Reply With Quote
  (#17) Old
Shawhan Shawhan is offline
Junior Member
 
Posts: 10
Join Date: Jan 2009
Default Thanks - 01-13-2010, 01:57 AM

The above post helped a ton. Keep in mind it is important that when you read umount /media/mySD you read it correctly. My speed reading read it as unmount (which made sense to my linux noob brain) but the system doesn't like the unmount command when i put in umount it immediately changed text color. i knew it would work then. it did.

My SD card auto mounts with a file manager screen as soon as it wakes back up. a bit annoying that you get the pop up but much better than not suspending. I am using an 8GB Sandisk SDHC card.

Still can't get the password that pops up after suspend to go away.

I read in another post that going into gconf-editor and editing the gnome power management lock would do the trick but its not working for me. I unselected all of those in that category and it still asks for a password after each suspend attempt. This is a 4 day old install of 9.10 remix.

Any suggestions would be great. Mostly noob here so please be detailed if you expect me to get it.
Reply With Quote
  (#18) Old
Paul Paul is offline
Member
 
Posts: 44
Join Date: Jan 2009
Red face 01-14-2010, 06:20 PM

Finally I got it right! thanks for the prompt to spell the command correctly! D'oh!
Reply With Quote
  (#19) Old
Shawhan Shawhan is offline
Junior Member
 
Posts: 10
Join Date: Jan 2009
Default Its always something - 01-15-2010, 01:58 PM

After spending a few days playing with the mini my previous posting about the gconf-editor fix not working is incorrect. It seems now that it only asks for the password once after each fresh restart AND one suspend mode. Least that is what i have experienced for far. Otherwise I have no way to explain why it only asks for the password up from one time.

Yesterday afternoon I opened it from suspend and it woke up straight to the desktop (no password) and immediately opened the 8GB sd card file manager window as well.

Again, thanks for everyone's help on the thread. made a huge difference to me.

Shawhan
Reply With Quote
  (#20) Old
ubuntufanXD ubuntufanXD is offline
Member
 
Posts: 38
Join Date: Dec 2008
Default 01-24-2010, 05:42 AM

Quote:
Originally Posted by Teh Lurv View Post
I entered it like this:

# The rule here? Simplicity.
umount /media/<name of SD card>
export STASHNAME=pm-suspend

worked like a charm for both hibernate and suspend. My remaining unresolved issue with my SD card is that it doesn't auto mount on boot. But that's not such a big deal.
This solution worked perfectly thank you so much this has been bugging the crap out of me.
Reply With Quote
Reply

Tags
hibernate, suspend

« Previous Thread | Next Thread »
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Copyright © 2008-2016 MyDellMini.com.