Dell Mini 10v Mac OS X Discussion Discussion dedicated to installing and setting up Mac OS X on the Dell Mini 1011

Reply
 
Thread Tools Display Modes
  (#1) Old
JustAsking JustAsking is offline
Junior Member
 
Posts: 6
Join Date: Dec 2010
Red face "Still waiting for root device" HELP! - 12-16-2010, 03:20 PM

I had a very well running Dell Mini v10 dual boot with Snow Leopard and Win7 on it. On the Apple side everything working fine (airport, touch pad, sound, etc.). After running the 10.6.5 upgrade from Apple (I know, bad idea), I got a messed up multi-boot (that I was able to fix by setting the Win7 partition back to active) as well as other issued. The biggest issue is the "Still waiting for root device" issue.

If I boot "recovery=y" the system boots fine but not if I don't. Is there any way to fix this? I have tried installing both NullCPUPowerManagement.kext and HDAEnabler.kext as well as installing MaxOSXUpdCombo10.6.5 on top of the current setup. I really, really don't want to rebuild as I have a lot of stuff that I have added to the system.

Any help is most appreciated. I planned on working on the airport and sound issues once I can get past this boot issue but if anyone knows a solution to those, I would be grateful as well. I am a bit of a noob with this so in advance, sorry if I respond to any assistance with dumb questions.

Thanks all and I appreciate any help you can give.
Reply With Quote
  (#2) Old
JustAsking JustAsking is offline
Junior Member
 
Posts: 6
Join Date: Dec 2010
Default 12-16-2010, 07:42 PM

After more post reading, I have tried fixing permissions and running NBI "51" in various combinations. No luck. Still need to use recovery=y to boot and both wifi and sound no work (suspect these last two are a result of using the recovery boot option but not positive) though I don't plan on trying to fix those until the boot issue is resolved.

Also, I have tried running the permissions repair twice in a row and the same permission errors get reported the second time too. Do they not get applied until you reboot or do I have bigger issues?
Reply With Quote
  (#3) Old
JustAsking JustAsking is offline
Junior Member
 
Posts: 6
Join Date: Dec 2010
Default 12-16-2010, 10:00 PM

OK, more progress...

After trying "permissions repair" (I now know it mostly does not do much), runs of NBI 51, and reboots, I ran NBI 0.8.4 RC1 and that seems to have fixed my boot problem and sound problem!

Now if I can just get the wifi working again, I should be good to go!

Any suggestions or thoughts on that one? Should I re-run NBI 51 now or re-install the 10.6.5 combo? Thanks all.
Reply With Quote
  (#4) Old
JustAsking JustAsking is offline
Junior Member
 
Posts: 6
Join Date: Dec 2010
Default 12-17-2010, 02:15 PM

Played with the system some more and I can boot into OSX using NBI 0.8.4 RC1, sounds works but no wifi. If an run NBI 51 after that, I can not boot again and am back to the "Still waiting for root device" issue. I also noticed that I get a lot of "can't load" messages through the boot process when I boot after 0.8.4 RC1 so that is likely not a long term answer. Suggestions anyone?
Reply With Quote
  (#5) Old
GunnerH GunnerH is offline
Junior Member
 
Posts: 8
Join Date: Sep 2011
Default PDAnet causing "Still waiting for root device error" - 07-28-2012, 03:28 PM

So I just installed PDAnet because I'l traveling in West Africa and rather than buy a USB 3G modem and have data on my GSM phone, I wanted to just make the phone do double duty.

Running a mini 10v with 10.6.7. Never had a problem before.

So I install the PDAnet package and restart.... only to now get the "Still waiting for root device" error if I boot normally. If I boot without loading cache, then it boots just fine - and I can't seem to boot into a recovery -y version by holding shift.

Should I run NBI 5.1 again maybe? I don't want to run NBI again without knowing that will work out.

Thoughts? Thanks!
Reply With Quote
Reply

« Previous Thread | Next Thread »
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Copyright © 2008-2016 MyDellMini.com.