Mac OS X Guides Guides for installing and configuring Mac OSX on your Dell Mini.

Comment
 
Tutorial Tools Display Modes
  Old
allankelly allankelly is offline
Junior Member
 
Posts: 3
Join Date: Apr 2010
Default Dell Mini 10 (1011) Snow Leopard triple boot - 05-02-2010, 07:45 PM

Hi, I've written up my triple-boot XP/Ubuntu/MacOSX Snow Leopard install. I hope it saves you time and hassle!

I describe how to use a USB install with GUID partitioning and then copy that install to a HDD MBR partition. Then setup Chameleon for a smooth triple-boot menu...
Reply With Quote
  #10  
Old 06-02-2010, 10:35 PM
DDUST DDUST is offline
Junior Member
 
Join Date: May 2010
Posts: 6
Default

Quote:
Originally Posted by b33keeper View Post

Also, DDust you might like to know I kept the Dell Restore Parition, so can confirm you can do this. If you want to keep this though you should first backup the MBR partition. You would have to then restore this partition should you ever want to access your Dell restore parition. I hope that makes sense.

Side note for DDust:
I have got that boot error after trying to boot an empty hfs parition. I suspect you may also get it if you have not set up chameleon and just boot from the hdd. one thing to note, after you have set up chameleon you must set the osx partition to have the 'boot' flag.
Hi B33keeper, and yes i havent install chameleon yet. But it Allan guide doesnt even tell us to install Chameleon first. can you guide me there? i watched couple video on youtube, and many ppl after get there OSX into flash, it boots thru USB without any chameleon and it works. that what make me wonder if i miss anything.

regarding the backing up MBR partition, how do i do that? i thought when i clone the whole entire HDD, the MBR partition get duplictae too.
Thats where i got

partition 1 --> Fat16 --> Dell Utility [MBR Partition]
Partition 2 --> NTFS --> OS (Windows XP)
Partition 3 --> Fat32 --> DellRestore
(unallocated 160gb)

could you guide me to install chameleon & make this work. Greatly appreciated. Thank you very very much in advance.
Reply With Quote
  #11  
Old 06-03-2010, 06:00 PM
jackieboy8 jackieboy8 is offline
Junior Member
 
Join Date: Jun 2010
Location: Netherlands
Posts: 23
Default

Yes i have installed Windows 7 and the partition table = mbr and in the install I Made an 110GB partition for OSX. I know alot about hackintoshes (expert at hackintosh.nl) but today I bought this Dell Mini 10v and forgot to install win7 on an GUID partition and now its mbr. But is there any way without linux to install osx on mbr? Ore do i need to reinstall everything? (used an external dvd drive)
__________________
Dell Mini 10v - A04 - Intel Antom N270 - 1GB Ram - Intel GMA950 - Dell Wi-Fi 1397 - Snow Leopard 10.6.7 - Trackpad works great like sleep. Sound sometimes doesn't work when I boot
Reply With Quote
  #12  
Old 06-15-2010, 04:37 AM
b33keeper b33keeper is offline
Junior Member
 
Join Date: May 2010
Posts: 6
Default

DDust,

The guide says that you have to install chameleon on the flash disk. See step 3 under 'Make it bootable, and add the Hackintosh Kernel Extensions'.

In my opinion you dont HAVE to do this, but you cannot boot off the flash disk if you dont. I did do it, but an alternative would be to just copy the files from the flash drive to your hdd. What I found is reading the OS from the flash disk is painfully slow so as soon as you get that puppy on the hdd things will run much faster and you will be much happier.

Also, I assume you have already shutdown the computer and which case you cannot boot from your OSX install flash drive.

In this case, plug in both the NBI image and OSX install flash. When the system boots off the NIB image, choose the OSX on the flash disk. Then once OSX starts, install chameleon.

As for backing up the MBR, well it may be your cloning software does that, I dont know I have never used cloning software. Anyway if you want to back up the MBR in case here is a site where you can get some free software to do it:

5 Free Tools to Backup and Restore Master Boot Record (MBR) Raymond.CC Blog
Reply With Quote
  #13  
Old 07-20-2010, 02:16 PM
DenisM DenisM is offline
Member
 
Join Date: Mar 2010
Posts: 34
Default

I've been trying to set up a triple boot on my 10V as per Alan's guide.
XP, Ubuntu 9.10 , SL 10.6
I'm stuck at one point -booting to install OSX....

Would some one look at the output below and comment please.
- driving me nuts ! I'm so close......

Dell 10V - Bios A06
2 Gig Memory
160 HD
Partitioned as described in Alan's triple boot guide -using gparted

SnowLeopard ver 10.6 Retail


3 USB sticks in place as advised
boots from small USB :
mac image on 8Gig USB
Blank Fat32 16Gig USb

OUTPUT:

Darwin/x86 boot v5.0.132 - Chameleon v2.0-RC3-nb1 r
Build datw: 2009-12-20 21:10:54
2038 memory

displays XP and Mac installDVD

Select: Mac OS X Install DVD

(no boot switches/options used)

blank for a few seconds ....
Apple Logo ! Yipee

Oh Oh !

You need to restart yout computer. Hold down the Power button until it turns off, then press the Power button again.
(multiple languages)


I also tried with boot -v -x (singly and both together)

Outputs screens of text on grey background ...
changes to black screen and continues to scroll text...

but eventually stops.(indications of panic) .....with last

few(<snipped>lines...

Debugger called: <panic>
Backtrace (CPU 1), Frame Return address (4 potential args on stack)
<snip>
No mapping exists for the frame pointer 0xbffff498
Kernel Extensions in backtrace (with dependancies):
com.apple.BootCache(31)@0x3534a000->0x3534efff

BSD process name corresponding to current thred: BootCacheControl

Mac OS version:
10A432

Kernel Version:
ACPI_SMC_PlatformPlugin::start -

waitForService(resourceMatching(AppleIntelCPUPower Management) timed out
Darwin Kernel Version 10.0.0: Fri July 31 22:47:34 PDT 2009:

root:xnu-1456.1.25~1/RELEASE_I386
System model name: Inspiron 1011

System uptime in nanoseconds: 6659451531

(Freezes..................... )


I've tried all combinations of USB to port installation, set all BIOS options to all possible options....

AAAAARRRRGGGHHHH !!

Any suggestions/pointers ?

DenisM
Reply With Quote
  #14  
Old 07-21-2010, 03:21 AM
b33keeper b33keeper is offline
Junior Member
 
Join Date: May 2010
Posts: 6
Default

It has been ages since I set up mine, here are two things you might like to try:

1. First check your mac osx image is valid. Mine was corrupt and gave me lots of grief. If you are coping it from a windows PC make sure you have a valid iso file. One really rough way to verify is in chameleon the OSX image should say something like 'Mac OSX Install disk' and have a apple logo. If it looks like it is not worded correctly or no apple icon (just a hdd) then it is probably stuffed.

2. Try the alterative methods on mechdrews site for generating the flash drives. For me it was the Windows Alternate 2 that worked all the others did not work or gave KP.

Here is a link to the site: NetbookInstaller 2: USB Mac Installation via Any Operating System | Guides | OS X | mechdrew

Anyway that is just my 2c.
Reply With Quote
  #15  
Old 07-21-2010, 09:30 AM
DenisM DenisM is offline
Member
 
Join Date: Mar 2010
Posts: 34
Default

Thanks for the suggestion.

I did try that link but could not get the partitioning to work and retain the partitions I had already setup. I was forced to partition the whole 160G drive for OSX.
And I did get OSX installed - but only as single boot obviously.

Being impatient . I borrowed an external DVd and successfully installed OSX to the 16G USB stick.....

I followed Alan's guide all the way after that....

at the stage :
Quote:
6. Boot to your new MacOSX on HDD

Restart, and boot from USB. As the timer bar shrinks, press a key. Select the new HDD MacOSX (probably on the right). Boot. Woo-woo. Nearly there. Once logged in, you can eject the USB to prove you're working off the HDD (the USB will be an icon on the desktop). As before, you can use this for a bit to enjoy your progress.
OK, happy? Now, run that NetBookInstaller you downloaded earlier. This time, we'll install to the HDD. Select no install options, only the Chameleon bootloader.
Now, shutdown. Remove the USB stick(s). Boot to HDD. The Chameleon menu will show you Windows, MacOSX and Linux. Result! Test them.
Netbookinstaller ran successfully but on reboot from HDD , I now have ONLY win XP !
It presents no bootloader...

I suspect I might have messed up on the grub.cfg edit & copy stage !

I can still boot into OSXusb, OS X on HDD / XP or Ubuntu with the USB 16G stick, But I do want it to be the full monty and get all three on the mini
Now where to go ?

Clearly my bootloader config is in a mess

D.
Reply With Quote
  #16  
Old 07-21-2010, 06:09 PM
jwc10 jwc10 is offline
Junior Member
 
Join Date: Nov 2009
Posts: 6
Default

I had that issue with the computer just booting into Windows. I went back into Linux (by booting from the USB stick) and found using Gparted that a "boot" flag had been put on the Windows partition. After removing that flag, everything was hunky-dory.
Reply With Quote
  #17  
Old 07-21-2010, 11:23 PM
b33keeper b33keeper is offline
Junior Member
 
Join Date: May 2010
Posts: 6
Default

Yeah I had to do that too. I forgot about that. Just to be clear I set the OSX partition with the boot flag since that is where chameleon is installed.
Reply With Quote
  #18  
Old 07-22-2010, 02:20 AM
DenisM DenisM is offline
Member
 
Join Date: Mar 2010
Posts: 34
Default

Thank you both... That solved the boot loader issue.
It was a wrong boot flag

The menu is now presenting XP , Ubuntu , and Mac OSX.

However while XP and Ubuntu both work , the OSX appears to freeze for a few seconds and then panics:

Quote:
panic(cpu 0 caller 0x2ac0d5): "Incompatible boot args verson 1 revision 4\"@/SourceCache/xnu/xnu-1456.1.25/osfmk/i386/AT386/model_dep.c:532
Debugger caller: <panic>
Backtrace (CPU 0), Frame : Retuen Address (4 potential args n stack)

<snip>....

BSD process name corresponding to current thread: Unknown

Mac OS version:
Not yet set

Kernel version:
Darwin Kernel Version 10.0.0: Fri Jul 31 22:47:34 PDT 2009; root:xnu-1456.1.25~1/RELEASE_I386

System Uptime in nanoseconds: 0
Hmmm......... not there yet

Is this a ref to some error in grub.cfg, I wonder ?
D.
Reply With Quote
  #19  
Old 07-22-2010, 02:48 AM
b33keeper b33keeper is offline
Junior Member
 
Join Date: May 2010
Posts: 6
Default

I did not get that problem, so from here on I am only guessing.

It does sound like a config file problem, but I would have thought you should check the chameleon.conf file.

You might want to check that is set up correctly. Check it is pointing to the correct device /dev/sda?? etc
Reply With Quote
Comment

« Previous Tutorial | Next Tutorial »
Tutorial Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Copyright © 2008-2016 MyDellMini.com.