Ubuntu Discussion on Ubuntu on the Dell Inspiron Mini range of netbooks.

Reply
 
Thread Tools Display Modes
  (#1) Old
Wipeout Wipeout is offline
Member
 
Posts: 57
Join Date: Apr 2009
Location: Portland, OR
Default Way to use Fn+2 to start airplane manager? - 05-13-2009, 11:35 PM

Like the title says...anyone ever make the "wireless switch" work? I'm using 9.04 without netbook remix if it matters...
Reply With Quote
  (#2) Old
cookiemonster cookiemonster is offline
Senior Member
 
cookiemonster's Avatar
 
Posts: 314
Join Date: Jan 2009
Default 05-14-2009, 01:05 AM

You can go to System -> Preferences -> Keyboard Shortcuts. For some reason, it didn't work for me, so I used [url=http://ubuntu-tweak.com/]Ubuntu Tweak[/url|. Anyway, the command is "/usr/bin/aircraft-manager" and when you enter Fn+2 as the shortcut, it will show up as "XF86AudioNext"
Reply With Quote
  (#3) Old
Wipeout Wipeout is offline
Member
 
Posts: 57
Join Date: Apr 2009
Location: Portland, OR
Default 05-14-2009, 01:14 AM

Thanks! That worked perfectly. Keyboard Shortcuts didn't work for me, either.
Reply With Quote
  (#4) Old
yakinikku yakinikku is offline
Senior Member
 
Posts: 252
Join Date: Jan 2009
Default 05-17-2009, 08:40 AM

in ubuntu tweak setting it as fn+2 didnt work for me.

perhaps there is something i am doing wrong?

i set the command path as was listed /usr/bin/aircraft-manager and tried to have it use fn+2 for the keystroke but its not working. any ideas?

edit: nm, i fixed it. i just overrode the skip to next track command with the fn+2 command for aircraft manager via the keyboard shortcuts menu in preferences and its working fine now.
Reply With Quote
  (#5) Old
bowill bowill is offline
Member
 
Posts: 54
Join Date: Feb 2009
Default 05-17-2009, 04:27 PM

There is a bug in 9.04 that will cause the Fn+2 keybinding you configured to stopping working after logout. You will have to change it to something else and then set it back every time you log in.

It's possible to do this using the command line utility gconftool-2 within a startup application. The previous suggestion to use ubuntu-tweak is another way to get around this bug.
Reply With Quote
  (#6) Old
yakinikku yakinikku is offline
Senior Member
 
Posts: 252
Join Date: Jan 2009
Default 05-17-2009, 10:47 PM

Quote:
Originally Posted by bowill View Post
There is a bug in 9.04 that will cause the Fn+2 keybinding you configured to stopping working after logout. You will have to change it to something else and then set it back every time you log in.

It's possible to do this using the command line utility gconftool-2 within a startup application. The previous suggestion to use ubuntu-tweak is another way to get around this bug.
in which case, how do i solve my issue with ubuntu tweak not working properly when i set this command? do i first have to void the other command that uses fn 2?
i just confirmed that upon logout it loses the ability to do what i had set it to do but upon checking in the preferences -> keyboard shortcuts menu it was still bound to that key. I then tried setting ubuntu tweak with the same shortcut and it will not work. what am i doing wrong?
Reply With Quote
  (#7) Old
bowill bowill is offline
Member
 
Posts: 54
Join Date: Feb 2009
Default 05-18-2009, 01:32 AM

I have a startup script call ~/bin/fix_wlan_keymap that looks like this:
Code:
#!/bin/sh
gconftool-2 --set --type=string /desktop/gnome/keybindings/custom0/binding XF86WLAN
gconftool-2 --set --type=string /desktop/gnome/keybindings/custom0/binding XF86AudioNext
I made it executable ('chmod u+x ~/bin/fix_wlan_keymap'), and then I went to Preferences->Startup Applications and added a new entry to run this script on startup.

You might have to use gconf-editor to figure out whether custom0 is the correct binding, and modify the gconftool-2 calls if it isn't.

It's worth trying a little bit more with Ubuntu Tweak, since I haven't heard of anyone else having trouble with it, and it _should_ be both easier and more reliable than this method.
Reply With Quote
  (#8) Old
Wipeout Wipeout is offline
Member
 
Posts: 57
Join Date: Apr 2009
Location: Portland, OR
Default 05-18-2009, 03:01 AM

I would make sure the key is only mapped to wireless. My problem initially was that it was mapped to more than one thing.


Darren
Wipeout
Reply With Quote
  (#9) Old
yakinikku yakinikku is offline
Senior Member
 
Posts: 252
Join Date: Jan 2009
Default 05-18-2009, 05:46 AM

i just checked, the audio one is still disabled and i removed the entry for it from the preferences -> shortcut keys menu, then i readded it via ubuntu tweak and still nothing .
Reply With Quote
  (#10) Old
yakinikku yakinikku is offline
Senior Member
 
Posts: 252
Join Date: Jan 2009
Default 05-18-2009, 06:03 AM

ok, now its mysteriously working :S
Reply With Quote
Reply

« Previous Thread | Next Thread »
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Copyright © 2008-2016 MyDellMini.com.