Dell Mini 1010 Forum for all discussion and support on the first revision of the Dell Mini 10, the Dell Inspiron Mini 1010.

Reply
 
Thread Tools Display Modes
  (#1) Old
berga.d berga.d is offline
Senior Member
 
Posts: 129
Join Date: Aug 2009
Default And Eventually... Moblin for US15W it's here!! - 02-08-2010, 01:39 PM

Credits goes to Kal1.

It's the time for Linux, on our Mini's! It took an absurd amount of time for Intel to release it... But now, the Linux Foundation/Intel sponsored distribution it's now compatible out of the box with our GMA500/Poulsbo!

Here's the link!

2.1 IVI FC release | moblin.org

Use this image: http://repo.moblin.org/moblin/develo...i-20091208.img

Try it and post here your results! (I will try it in the next hours)

EDIT: It doesn't seem to initialize well the screen. Maybe a wrong xorg.conf file, with bad resolution configuration. It seems possible, because IEGD should be configured at build time for your screen...



The GMA500 Guru: ask me for every video problem! (Or if you desire a perfect video experience)
Win Xp, Driver .1016, Full Hd Youtube Working; Win7, Driver .2019
Dell Mini 10, HDD Momentus 7200.2 160gb (best 2.5" access time )
Reply With Quote
  (#2) Old
Xiphias Xiphias is offline
Member
 
Posts: 61
Join Date: Jun 2009
Default 02-08-2010, 07:47 PM

Quote:
Originally Posted by berga.d View Post
Credits goes to Kal1.

It's the time for Linux, on our Mini's! It took an absurd amount of time for Intel to release it... But now, the Linux Foundation/Intel sponsored distribution it's now compatible out of the box with our GMA500/Poulsbo!

Here's the link!

2.1 IVI FC release | moblin.org

Use this image: http://repo.moblin.org/moblin/develo...i-20091208.img

Try it and post here your results! (I will try it in the next hours)
Not gonna work. Uses pre-existing drivers.
Reply With Quote
  (#3) Old
minis minis is offline
Member
 
Posts: 35
Join Date: Dec 2009
Location: Germany
Default 02-08-2010, 10:16 PM

Try Jolicloud! It works like a charm!
Reply With Quote
  (#4) Old
Kal1 Kal1 is offline
Member
 
Posts: 30
Join Date: Jan 2010
Default 02-09-2010, 09:49 AM

moblin 2.1 with iegd driver didn't work, on the moblin dev mailing list some one have got this problem in november but have reported the 2.0 version with iegd was working

Jolicloud use the old psb driver
Reply With Quote
  (#5) Old
berga.d berga.d is offline
Senior Member
 
Posts: 129
Join Date: Aug 2009
Default 02-09-2010, 01:26 PM

Can you link the mailing list? I have built (for win) Iegd many times, and I know that you have to configure it at "build" time with your configuraiton (resolutions, screens, outputs). On windows it write them into the INF file, in Linux into the xorg.conf... So I'm going to try.



The GMA500 Guru: ask me for every video problem! (Or if you desire a perfect video experience)
Win Xp, Driver .1016, Full Hd Youtube Working; Win7, Driver .2019
Dell Mini 10, HDD Momentus 7200.2 160gb (best 2.5" access time )
Reply With Quote
  (#6) Old
Kal1 Kal1 is offline
Member
 
Posts: 30
Join Date: Jan 2010
Default 02-09-2010, 01:47 PM

i have used the working xorg.conf from ubuntu + fitpc2 and didn't work too
Reply With Quote
  (#7) Old
berga.d berga.d is offline
Senior Member
 
Posts: 129
Join Date: Aug 2009
Default 02-09-2010, 02:19 PM

It's for a different driver. Please post here your original xorg.conf, maybe I have found the problem, but I first I should watch your original (the one which didn't work) xorg please



The GMA500 Guru: ask me for every video problem! (Or if you desire a perfect video experience)
Win Xp, Driver .1016, Full Hd Youtube Working; Win7, Driver .2019
Dell Mini 10, HDD Momentus 7200.2 160gb (best 2.5" access time )
Reply With Quote
  (#8) Old
Kal1 Kal1 is offline
Member
 
Posts: 30
Join Date: Jan 2010
Default 02-09-2010, 03:31 PM

This is the fitpc2 xorg.conf

Code:
Section "ServerLayout"
        Identifier     "X.org Configured"
        Screen      0  "Screen0" 0 0
        InputDevice    "Mouse0" "CorePointer"
        InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
EndSection

Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option      "Protocol" "auto"
        Option      "Device" "/dev/input/mice"
        Option      "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
        Identifier   "Monitor0"
        VendorName   "Monitor Vendor"
        ModelName    "Monitor Model"
        Option       "dpms"
EndSection

# Primary (First/only) display
Section "Device"
    Identifier "Card0"
    Driver     "iegd"
    VendorName "Intel(R) DEG"
    BoardName  "Embedded Graphics"
    BusID      "0:2:0"
    Screen      0
    Option     "PcfVersion"            "1792"
    Option     "ConfigId"              "1"
    Option     "SWCursor"              "true"
    Option     "ALL/1/name"                   "fit-PC2 "
    Option     "ALL/1/General/PortOrder"      "20000"
    Option     "ALL/1/General/DisplayConfig"  "1"
    Option     "ALL/1/General/DisplayDetect"  "1"
    Option     "ALL/1/General/xVideo"         "1"
    Option     "ALL/1/General/XVideoBlend"    "0"
    Option     "ALL/1/General/DRI"            "1"
    Option     "ALL/1/Port/2/General/name"           "DVI"
    Option     "ALL/1/Port/2/General/EdidAvail"      "2"
    Option     "ALL/1/Port/2/General/EdidNotAvail"   "1"
    Option     "ALL/1/Port/2/General/Rotation"       "0"
    Option     "ALL/1/Port/2/General/Edid"           "1"
    Option     "PortDrivers"           "sdvo"
EndSection

Section "Screen"
        Identifier "Screen0"
        Device     "Card0"
        Monitor    "Monitor0"
        DefaultDepth    24
        SubSection "Display"
                Viewport   0 0
                Depth     24
                Modes     "1366x768"
        EndSubSection
EndSection

Section "DRI"
        Mode 0666
EndSection

Section "ServerFlags"
        Option "AIGLX" "false"
        Option "GlxVisuals" "all"
EndSection
Reply With Quote
  (#9) Old
berga.d berga.d is offline
Senior Member
 
Posts: 129
Join Date: Aug 2009
Default 02-09-2010, 06:40 PM

I mean the xorg.conf that come with moblin, the first one, not this... Thanks

EDIT: I have seen only now: Fit-pc uses IEGD in Ubuntu too! Maybe this xorg may work. Maybe. However you should change some things:

Code:
Section "Screen"
    Identifier    "Screen0"
    Device        "Intel_IEGD-0"
    Monitor       "Monitor0"
    SubSection    "Display"
    EndSubSection
EndSection


Section "Device"
    Identifier "Intel_IEGD-0"
    Driver     "iegd"
    VendorName "Intel(R) DEG"
    BoardName  "Embedded Graphics"
    BusID      "0:2:0"
    Screen      0
    Option     "PcfVersion"            "1792"
    Option     "ConfigId"              "1"
    Option     "ALL/1/name"                   "daveConf"
    Option     "ALL/1/General/PortOrder"      "42000"
    Option     "ALL/1/General/DisplayConfig"  "1"
    Option     "ALL/1/General/DisplayDetect"  "1"
    Option     "ALL/1/Port/4/General/name"                   "daveLVDS"
    Option     "ALL/1/Port/4/General/EdidAvail"      "3"
    Option     "ALL/1/Port/4/General/EdidNotAvail"   "1"
    Option     "ALL/1/Port/4/General/Rotation"       "0"
    Option     "ALL/1/Port/4/General/Edid"           "1"
    Option     "ALL/1/Port/4/FpInfo/BkltMethod"      "1"
    Option     "ALL/1/Port/4/FpInfo/BkltT1"          "60"
    Option     "ALL/1/Port/4/FpInfo/BkltT2"          "200"
    Option     "ALL/1/Port/4/FpInfo/BkltT3"          "200"
    Option     "ALL/1/Port/4/FpInfo/BkltT4"          "50"
    Option     "ALL/1/Port/4/FpInfo/BkltT5"          "400"
    Option     "ALL/1/Port/4/Attr/27"    "0"
    Option     "ALL/1/Port/4/Attr/26"    "18"
    Option     "ALL/1/Port/2/General/name"                   "davesDVO-B"
    Option     "ALL/1/Port/2/General/EdidAvail"      "3"
    Option     "ALL/1/Port/2/General/EdidNotAvail"   "1"
    Option     "ALL/1/Port/2/General/Rotation"       "0"
    Option     "ALL/1/Port/2/General/Edid"           "1"
    Option     "PortDrivers"           "lvds sdvo"
EndSection
Leave other sections the same



The GMA500 Guru: ask me for every video problem! (Or if you desire a perfect video experience)
Win Xp, Driver .1016, Full Hd Youtube Working; Win7, Driver .2019
Dell Mini 10, HDD Momentus 7200.2 160gb (best 2.5" access time )
Reply With Quote
  (#10) Old
Kal1 Kal1 is offline
Member
 
Posts: 30
Join Date: Jan 2010
Default 02-09-2010, 09:46 PM

xorg.com from moblin

Code:
Section "ServerFlags"
        Option  "AllowMouseOpenFail"
        Option  "Xinerama"  "on"
        Option  "AIGLX" "off"
EndSection

Section "Files"
        RgbPath "/usr/share/X11/rgb"
        ModulePath      "/usr/lib/xorg/modules"
        FontPath        "/usr/share/X11/fonts/local"
        FontPath        "/usr/share/X11/fonts/util"
        FontPath        "/usr/share/X11/fonts/100dpi"
        FontPath        "/usr/share/X11/fonts/75dpi"
        FontPath        "/usr/share/X11/fonts/misc"
        FontPath        "/usr/share/X11/fonts/TTF"
        FontPath        "/usr/share/X11/fonts/Type1"
EndSection

Section "Module"
        Load    "extmod"
        Load    "glx"
        Load    "dri"
        Load    "dbe"
        Load    "record"
        Load    "xtrap"
        Load    "type1"
        Load    "freetype"
EndSection

Section "InputDevice"
        Identifier      "Keyboard"
        Driver  "kbd"
EndSection

Section "InputDevice"
        Identifier      "Mouse"
        Driver  "mouse"
        Option  "Protocol"      "auto"
        Option  "Device"        "/dev/input/mice"
EndSection

Section "Device"
        BusID "0:2:0"
        Identifier      "Dev0"
        Driver  "iegd"
        Screen  0
#       VideoRam 4096

  Option     "PcfVersion"            "1792"
  Option     "ConfigId"              "1"
  Option     "PortDrivers"           "sdvo lvds"
  Option     "ALL/1/name"                          "multipl"
  Option     "ALL/1/General/PortOrder"             "42000"
  Option     "ALL/1/General/DisplayConfig"         "2"
  Option     "ALL/1/General/DisplayDetect"         "0"
  Option     "ALL/1/General/DRI2"                  "1"
  Option     "ALL/1/Port/2/General/name"           "0"
  Option     "ALL/1/Port/2/General/name"           "0"
  Option     "ALL/1/Port/2/General/EdidAvail"      "3"
  Option     "ALL/1/Port/2/General/EdidNotAvail"   "1"
  Option     "ALL/1/Port/2/General/Rotation"       "0"
  Option     "ALL/1/Port/2/General/Edid"           "0"
  Option     "ALL/1/Port/2/Attr/27"                "0"
  Option     "ALL/1/Port/2/Attr/26"                "24"
  Option     "ALL/1/Port/4/General/name"           "0"
  Option     "ALL/1/Port/4/General/EdidAvail"      "4"
  Option     "ALL/1/Port/4/General/EdidNotAvail"   "4"
  Option     "ALL/1/Port/4/General/Rotation"       "0"
  Option     "ALL/1/Port/4/General/Edid"           "1"
  Option     "ALL/1/Port/4/Dtd/1/PixelClock"       "33231"
  Option     "ALL/1/Port/4/Dtd/1/HorzActive"       "800"
  Option     "ALL/1/Port/4/Dtd/1/HorzSync"         "64"
  Option     "ALL/1/Port/4/Dtd/1/HorzSyncPulse"    "128"
  Option     "ALL/1/Port/4/Dtd/1/HorzBlank"        "256"
  Option     "ALL/1/Port/4/Dtd/1/VertActive"       "480"
  Option     "ALL/1/Port/4/Dtd/1/VertSync"         "21"
  Option     "ALL/1/Port/4/Dtd/1/VertSyncPulse"    "2"
  Option     "ALL/1/Port/4/Dtd/1/VertBlank"        "45"
  Option     "ALL/1/Port/4/Dtd/1/Flags"            "0x20000"
  Option     "ALL/1/Port/4/FpInfo/Width"           "800"
  Option     "ALL/1/Port/4/FpInfo/Height"          "480"
  Option     "ALL/1/Port/4/Attr/26"                "24"
  Option     "ALL/1/Port/4/Attr/43"                "5"
  Option     "ALL/1/Port/4/Attr/49"                "0"
  Option     "ALL/1/Port/4/Attr/27"                "0"
  Option     "ALL/1/Port/4/Attr/60"                "1"
Endsection

Section "Device"
    Identifier "Dev1"
    Driver     "iegd"
    VendorName "Intel(R) DEG"
    BoardName  "Embedded Graphics"
    BusID      "0:2:0"
    Screen     1
    Option     "PcfVersion"            "1792"
    Option     "ConfigId"              "1"
    Option     "ALL/1/name"                   "multipl"
    Option     "ALL/1/General/PortOrder"      "24000"
    Option     "ALL/1/General/DisplayConfig"  "8"
    Option     "ALL/1/General/DisplayDetect"  "0"
EndSection

Section "Monitor"
        Identifier      "Mon0"
        HorizSync       10.5 - 500.0
        VertRefresh     30 - 80
EndSection

Section "Screen"
        Identifier      "Screen0"
        Device  "Dev0"
        Monitor "Mon0"
        DefaultDepth    24
        SubSection "Display"
                Depth   24
                Modes   "1024x768"
        EndSubSection
EndSection

Section "Screen"
        Identifier      "Screen1"
        Device  "Dev1"
        Monitor "Mon0"
        DefaultDepth    24
        SubSection "Display"
                Depth   24
                Modes   "800x480"
        EndSubSection
EndSection

Section "Serverlayout"
        Identifier      "ULT Generated"
        InputDevice     "Mouse" "CorePointer"
        InputDevice     "Keyboard" "CoreKeyboard"
  Screen 0       "Screen0" 0 0
  Screen 1       "Screen1" RightOf "Screen0"
EndSection
Reply With Quote
Reply

« Previous Thread | Next Thread »
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Copyright © 2008-2016 MyDellMini.com.