Ubuntu Discussion on Ubuntu on the Dell Inspiron Mini range of netbooks.

Reply
 
Thread Tools Display Modes
  (#1) Old
ugm6hr ugm6hr is offline
Senior Member
 
Posts: 127
Join Date: Jan 2009
Default OpenOffice.org 3.0 on Dell Mini 9 (default 8.04.1 lpia kerne - 01-13-2009, 10:21 AM

Has anyone managed this? I'd like to use OO.org 3.0 if possible.

I ran the i386 debs through the deb2lpia filter http://mydellmini.com/forum/*-deb-in...fd3d3c2#p19834, and then installed with dpkg.

It installs fine, and even launches.

However, unless I create / open a database (Base) file, any other application (i.e. Calc, Writer, Impress) crashes before the new document is even displayed. It then goes into the document recovery, but never manages to recover anything (continuous loop: crash -> recovery attempt -> crash -> recovery attempt etc).

As mentioned, opening a Base file (and then closing it to return to the main launcher window) allows me to work in any of the applications. I think this is OK, but was wondering if anyone had any clue why this would be the case.

I have noticed a small bug in Impress when embedding objects, but that's a different issue.
Reply With Quote
  (#2) Old
craigacp craigacp is offline
Junior Member
 
Posts: 3
Join Date: Jan 2009
Default Re: OpenOffice.org 3.0 on Dell Mini 9 (default 8.04.1 lpia kerne - 01-16-2009, 05:47 PM

I get exactly the same error on doing this, with the same weird fix. Though I had to remove openoffice.org-common before I could install the menus as it conflicted (I assume that was left over from the previous install of 2.4). Its a pretty fresh install as my mini only arrived yesterday, and I've only added TeXlive and vlc.

Anyone got any bright ideas?
Reply With Quote
  (#3) Old
ugm6hr ugm6hr is offline
Senior Member
 
Posts: 127
Join Date: Jan 2009
Default Re: OpenOffice.org 3.0 on Dell Mini 9 (default 8.04.1 lpia kerne - 01-16-2009, 11:39 PM

I didn't bother installing the menu, I just use a custom panel launcher; this way I can keep OO2.4 just in case.

My panel launcher actually runs the command:
Code:
/opt/openoffice.org3/program/soffice /opt/openoffice.org3/Start.odb
I have saved a blank database as Start.odb in /opt/openoffice.org3/ to allow this. That way, I just have to close the database to start using OO3.

I have found a few other bugs, which are lpia specific (I have 64-bit OO3 on Ubuntu 8.04 amd64 on my laptop). The most annoying (so far) is that the Base macros and extensions don't work.
Reply With Quote
  (#4) Old
ugm6hr ugm6hr is offline
Senior Member
 
Posts: 127
Join Date: Jan 2009
Default Re: OpenOffice.org 3.0 on Dell Mini 9 (default 8.04.1 lpia kerne - 01-19-2009, 08:34 AM

This appears possible as a result of the PPA team!

http://ubuntuforums.org/showthread.php? ... ost6576806

Quote:
I added these repos to my Toshiba NB100(also Lpia based) and it installed fine

deb http://ppa.launchpad.net/openoffice-pkgs/ubuntu hardy main
deb-src http://ppa.launchpad.net/openoffice-pkgs/ubuntu hardy main
Quote:
Thanks.

That seems to work much better.

Currently version 1:3.0.1~rc1-2ubuntu2~hardy1

Nice to see that the PPA team are supporting lpia, even though Sun are not.
Reply With Quote
  (#5) Old
psyopper psyopper is offline
Senior Member
 
Posts: 410
Join Date: Dec 2008
Location: Portland, Oregon
Default Re: OpenOffice.org 3.0 on Dell Mini 9 (default 8.04.1 lpia kerne - 01-19-2009, 03:23 PM

That's likely because someone on the team is running the lpia kernel and got miffed that it wasn't working right. It's the beauty of open-source platforms - if you don't like something you have every opportunity to fix it!


Bringing you quality hand made fitted sleeves for the Mini 9 since January
http://shop.psyopper.com
Reply With Quote
Reply

« Previous Thread | Next Thread »
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Copyright © 2008-2016 MyDellMini.com.