Dell Mini 9 OS X Discussion Discussion for installing and setting up Mac OS X on the Dell Mini and Vostro A90

Reply
 
Thread Tools Display Modes
  (#101) Old
nascar nascar is offline
Junior Member
 
Posts: 5
Join Date: Mar 2011
Default 06-11-2011, 06:51 PM

Quote:
Originally Posted by CodF4ther View Post
I was just able to recover from Sleep twice on 10.6.3 after completing the following simple steps, no kext patching required:

#1) Backup & delete /System/Library/Extensions/IOATAFamily.kext
#2) Run UpdateExtra (*** you must click the "Update Extensions" and wait for it to finish before rebooting ***)
#3) Reboot
Thanks for your solution!!

I had upgraded two Mini 9 to OS X 10.6.7 from 10.6.0 without any sleep problems. One of those Minis had a RunCore SSD and the other a Super Talent.

The third Mini has a STEC 32GB SSD. There were no sleep problems after installing 10.6.0 and updating to 10.6.2. However, after the 10.6.7 upgrade, sleep didn't work. I could put it to sleep and get the pulsing power light. After waking it, the mouse would navigate to menu items but clicking the menu item would do nothing. I could not launch any apps and would have to do a hard power down and boot again.

Based on my experience, it seems that the sleep problem was associated with having the STEC SSD.

Your solution is much appreciated. I can now change my signature.


Mini 9 | A05 | 2GB RAM | 32GB Runcore | Bluetooth | Webcam | OS X 10.6.7 | NBI 20100616212351
Mini 9 | A05 | 2GB RAM | 32GB Super Talent | OS X 10.6.7 | NBI 20100616212351
Mini 9 | A05 | 2GB RAM | 32GB STEC | Bluetooth | Webcam | OS X 10.6.2 | NBI 20100616212351
Reply With Quote
  (#102) Old
tryfan36 tryfan36 is offline
Junior Member
 
Posts: 1
Join Date: Jun 2011
Default Worked for me. - 06-25-2011, 06:12 PM

[quote=CodF4ther;162723]I'm really not sure why it isn't working first try for some of you. An alternate approach for those of you getting kernel panics is to use KextHelper. Install and run KextHelper b7 (see attached link), drag and drop the IOATAFamily.kext from /Extra/Mini9Ext onto the KextHelper window and click install. It will install to /S/L/E and backup the original file automatically.


This worked for me after unsuccessfully trying "everything else". Kept getting black screen or various degrees of freeze. depending on what was disabled in BIOS. Many thanks!

Mini9 1GB RAM 8GB STEC webcam wifi NBI 0.8.4
Reply With Quote
  (#103) Old
dchao dchao is offline
Senior Member
 
Posts: 151
Join Date: Apr 2009
Default 06-25-2011, 08:34 PM

[quote=tryfan36;189036]
Quote:
Originally Posted by CodF4ther View Post
I'm really not sure why it isn't working first try for some of you. An alternate approach for those of you getting kernel panics is to use KextHelper. Install and run KextHelper b7 (see attached link), drag and drop the IOATAFamily.kext from /Extra/Mini9Ext onto the KextHelper window and click install. It will install to /S/L/E and backup the original file automatically.

Mini9 1GB RAM 8GB STEC webcam wifi NBI 0.8.4
This works for me too. But like a previous post mentioned, it breaks my BT module, and now BT has stopped working. I'm trying a way to fix that now.

Note: If it isn't working for you after manually installing IOATAFamily.kext. Check your hibernation mode with pmset -g again, make sure hibernation is still disabled. Sometimes, after a system crash, hibernation mode can be reset to ON.

EDIT: I just reverted back to my virgin 10.6.6 image (saved just after 10.6.6 combo update was applied), and sleep was working >_< - now I am not sure anymore, something we did must have broken the wake-from-sleep.


 MINI 9 | 2GB RAM | BIOS A05 | BT | 16GB STEC SSD | OSX 10.6.8 (NBI 2351+Legacy Kernel+SleepEnabler)

Last edited by dchao; 06-25-2011 at 09:03 PM.
Reply With Quote
  (#104) Old
dchao dchao is offline
Senior Member
 
Posts: 151
Join Date: Apr 2009
Default 06-26-2011, 03:54 AM

I was trying to track down my wake-from-sleep problem. My DM9 would wake up, but WiFi will never connect, and I could not shut the machine down properly.

So I managed to track it down to MobileMe Sign In. Yes, MobileMe Sign In!

After I signed in to MM, I could not wake-up properly. I signed off, wake up worked properly. No syncing was turned on, mail accounts and CalDAV were not setup either. I just had to sign in, and then wake-up will stop working correctly.

Very interesting! Looks like MobileMe software is not compatible with NBI.


 MINI 9 | 2GB RAM | BIOS A05 | BT | 16GB STEC SSD | OSX 10.6.8 (NBI 2351+Legacy Kernel+SleepEnabler)

Last edited by dchao; 06-26-2011 at 04:01 AM.
Reply With Quote
  (#105) Old
dchao dchao is offline
Senior Member
 
Posts: 151
Join Date: Apr 2009
Default 06-26-2011, 10:48 PM

Updates:

After trouble shooting the MM and wake-from-sleep problem. I thought it was the Push notification from CalDAV and IMAP, but it's not. I have finally narrowed it down to the Back-to-my-Mac feature. If I turn it off, then and can wake from sleep with no problem what so ever.

(Notes: BTMM can be waken on a Mac, from the sleep state when called by the Bonjour sleep-proxy server, and I have a Apple Extreme Basestation that supports BTMM)

So right now, my DM9 with 10.6.6 is working with MM synching, mail, contacts and calendars. Sleep is also working correctly. For people having the sleep problem, make be worth checking if the BTMM is disabled (enabled by default!) in MobileMe pref pane.

I hope my finding will help someone with the wake-from-sleep problem.


 MINI 9 | 2GB RAM | BIOS A05 | BT | 16GB STEC SSD | OSX 10.6.8 (NBI 2351+Legacy Kernel+SleepEnabler)

Last edited by dchao; 06-26-2011 at 11:00 PM.
Reply With Quote
  (#106) Old
Eligos Eligos is offline
Senior Member
 
Eligos's Avatar
 
Posts: 262
Join Date: Jan 2009
Default 07-04-2011, 03:11 PM

Quote:
Originally Posted by dchao View Post
Updates:

After trouble shooting the MM and wake-from-sleep problem. I thought it was the Push notification from CalDAV and IMAP, but it's not. I have finally narrowed it down to the Back-to-my-Mac feature. If I turn it off, then and can wake from sleep with no problem what so ever.

(Notes: BTMM can be waken on a Mac, from the sleep state when called by the Bonjour sleep-proxy server, and I have a Apple Extreme Basestation that supports BTMM)

So right now, my DM9 with 10.6.6 is working with MM synching, mail, contacts and calendars. Sleep is also working correctly. For people having the sleep problem, make be worth checking if the BTMM is disabled (enabled by default!) in MobileMe pref pane.

I hope my finding will help someone with the wake-from-sleep problem.
Thought you were on 10.6.8?


Dell Mini 9 : OS X 10.6.8 : BIOS A05
32GB STEC SSD : 2GB RAM
NBI Version : Latest
SpeedStep : [Enabled]
USB Legacy support : [Disabled]
Reply With Quote
  (#107) Old
underwhelmed underwhelmed is offline
Guru
 
Posts: 1,375
Join Date: Mar 2009
Location: Texas
Default 07-04-2011, 08:18 PM

Quote:
Originally Posted by Eligos View Post
Thought you were on 10.6.8?
Old post. 6-26-11


Mini 9 | OS X 10.6.7 | NBI 20100616212351| BIOS 05 | 32 GB Runcore | 2 GIGS RAM
10V | OS X 10.6.7 | NBI 20100616212351 |BIOS 06|160 GB|1 GIG RAM| 6 Cell Dell Battery
Functioning Hibernation

Back up Mini 9| OS X 10.6.7| NBI 20100616212351| BIOS 05 | 32 GB SuperTalent | 2 GIGS RAM
Reply With Quote
  (#108) Old
dchao dchao is offline
Senior Member
 
Posts: 151
Join Date: Apr 2009
Default 07-05-2011, 12:44 AM

Quote:
Originally Posted by Eligos View Post
Thought you were on 10.6.8?
Thanks for bring up this old post.

That was when I was trying to get sleep to work under 10.6.6.

Now I am on 10.6.8 and with the legacy kernel + new SleepEnabler. I want to find out if I can turn BTMM back on.

The answer is still a NO

- No problem going to sleep (power light pulsing) but there is still a problem waking up from sleep, the wifi crashes, causing the whole system to be unstable. So we still don't have Bonjour Sleep Proxy support.

---------- Post added at 05:44 PM ---------- Previous post was at 04:35 PM ----------

One last observation.

When ever I change the Energy Saver settings in the pref pane. The hibernation mode is reset back to "3"., and the new sleepimage is then generated in my /var/vm folder

It's kind of annoying, every time, you change the Energy Saver settings, make sure you run the pmset command again from Terminal.


 MINI 9 | 2GB RAM | BIOS A05 | BT | 16GB STEC SSD | OSX 10.6.8 (NBI 2351+Legacy Kernel+SleepEnabler)
Reply With Quote
  (#109) Old
Eligos Eligos is offline
Senior Member
 
Eligos's Avatar
 
Posts: 262
Join Date: Jan 2009
Default 07-07-2011, 12:51 PM

Quote:
Originally Posted by dchao View Post
Thanks for bring up this old post.

That was when I was trying to get sleep to work under 10.6.6.

Now I am on 10.6.8 and with the legacy kernel + new SleepEnabler. I want to find out if I can turn BTMM back on.

The answer is still a NO

- No problem going to sleep (power light pulsing) but there is still a problem waking up from sleep, the wifi crashes, causing the whole system to be unstable. So we still don't have Bonjour Sleep Proxy support.

---------- Post added at 05:44 PM ---------- Previous post was at 04:35 PM ----------

One last observation.

When ever I change the Energy Saver settings in the pref pane. The hibernation mode is reset back to "3"., and the new sleepimage is then generated in my /var/vm folder

It's kind of annoying, every time, you change the Energy Saver settings, make sure you run the pmset command again from Terminal.
Thanks for the info.
I just enabled my MobileMe account to sync address book. Now I have the Window Server (top menubar) that keeps restarting in a loop. Is it a coincidence? I think not. Tried running the NBI again but to no avail. I'm in the process of reinstalling to 10.6.2.
On your 10.6.8 install (without MobileMe) your sleep is ok , right? Just want to make sure.
Can you verify that your microphone also works please?
Thanks dchao.


Dell Mini 9 : OS X 10.6.8 : BIOS A05
32GB STEC SSD : 2GB RAM
NBI Version : Latest
SpeedStep : [Enabled]
USB Legacy support : [Disabled]

Last edited by Eligos; 07-07-2011 at 02:34 PM.
Reply With Quote
  (#110) Old
michaelcly michaelcly is offline
Member
 
Posts: 61
Join Date: Dec 2011
Default 12-29-2011, 08:10 PM

Thanks to Codfather!

Dell mini 9; STEC PATA 32gb, 1gb ram

I have just installed 10.6.3 with NBI 0.8.4. Everything worked except card reader and sleep. Tried almost everything on this thread but no go. Did the codfather method deleting IOATAFamily.kext and updating. Bingo...everything works as it should.

I'm a happy man
Reply With Quote
Reply

« Previous Thread | Next Thread »
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Copyright © 2008-2016 MyDellMini.com.