Mac OS X Development Development and discussion on the latest hackintosh drivers and methods.

Reply
 
Thread Tools Display Modes
  (#1) Old
neilio neilio is offline
Junior Member
 
Posts: 9
Join Date: Mar 2009
Default NetbookInstaller kills bcdedit bootloader - 09-28-2009, 02:58 AM

Hi folks -

I might just be missing something obvious here, but every time I've updated and run NetbookInstaller on my Dell 9 it causes my custom bootloader (via bcdedit) to break. Specifically, it causes both the Windows 7 and Mac OS X partitions to return that the boot device cannot be found.

I've found fixes for this online, but it's a huge PITA to fix this every time I rereun NetbookInstaller. Is this a known issue, or is there a way to work around this so my setup doesn't break?

Dell Mini 9
Two partitions: Windows7 on one, Mac OS X 10.6 on the other.
Reply With Quote
  (#2) Old
shines on shines on is offline
Senior Member
 
Posts: 146
Join Date: Aug 2009
Default 09-28-2009, 03:33 AM

Known issue; the work around is to uncheck 'install chameleon boot loader' unless there is an actual update to it (which is seemingly rare compared to the rest of the package). I think meklort said something about fixing this in the next RC of netbook installer, but don't quote me on that.


Dell mini 10v OSx 10.6.2 | Windows 7
Reply With Quote
  (#3) Old
neilio neilio is offline
Junior Member
 
Posts: 9
Join Date: Mar 2009
Default 09-28-2009, 12:45 PM

Quote:
Originally Posted by shines on View Post
Known issue; the work around is to uncheck 'install chameleon boot loader' unless there is an actual update to it (which is seemingly rare compared to the rest of the package). I think meklort said something about fixing this in the next RC of netbook installer, but don't quote me on that.
Oh, makes sense. Thanks for the heads-up!
Reply With Quote
  (#4) Old
Scooter70 Scooter70 is offline
Senior Member
 
Posts: 112
Join Date: Jul 2009
Location: Metro Detroit
Default 09-29-2009, 01:10 AM

What are you doing to fix it? I can get my dual boot setup to load into Win7 but it gets stuck at Darwin/x86 whenever I try to get into SL. I'm using EasyBCD 2.0 beta but I'm not positive that I have it configured correctly. I can get into SL just fine booting from my USB but the EasyBCD loader doesn't do it.

Thanks.


-=|| Mini10v | 2GB | 120GB | BT | Win7 Pro | OSX 10.6.2 ||=-
Reply With Quote
  (#5) Old
neilio neilio is offline
Junior Member
 
Posts: 9
Join Date: Mar 2009
Default 09-29-2009, 01:32 AM

Quote:
Originally Posted by Scooter70 View Post
What are you doing to fix it?
I tried using the steps outlined in this post but I was getting an error when I ran step two. So what I did was:

1. Boot into my Windows 7 USB flash install image.
2. Run the "fix startup" process to fix Windows 7.
3. Boot back into the installed (and now fixed) Windows 7
4. Delete the Mac OS X listing in bcdedit - note that I was using the release version of bcdedit, and not the beta.
5. Quit bcdedit, and then relaunch it and re-add the mac partition.

I've had the bootloader broken issue three times now, and all three times this process worked to fix it.
Reply With Quote
Reply

« Previous Thread | Next Thread »
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Copyright © 2008-2016 MyDellMini.com.