FAQs and How To's Handy FAQs/How To Guides for installing/configuring Mac OS X.

 
 
Thread Tools Display Modes
  (#11) Old
cubedweller cubedweller is offline
Senior Member
 
Posts: 144
Join Date: Mar 2009
Location: Los Angeles, CA
Default 09-18-2009, 02:23 AM

Quote:
Originally Posted by cf3232 View Post
Does anyone ever post fixes to these issues or just say oh yeah it happened to me as well.
People post fixes when they have been fixed.


mini9 | 32gb runcore | 2gb | osx 10.6.2 | nbi 0.8.3 | a05
  (#12) Old
ebina1 ebina1 is offline
Junior Member
 
Posts: 3
Join Date: Oct 2009
Default 10-03-2009, 10:28 PM

I just installed a Dell Mini 9 using netbookinstaller .8.3RC2 and updated to 10.5.8
I have the same problem with hang in about 1 in 5 boots. Has the 16GB drive shipped from Dell and has bluetooth.

I am going to try booting with -v all the time for a while and see if I can see where it hangs, but in the way of intermittent problems, it will probably never hang on a -v boot.

---------- Post added at 04:23 PM ---------- Previous post was at 03:37 PM ----------

Well, it hung in a -v boot on only the fourth try. Not wanting to type in all the stuff on the screen I took a photo, which is here:
http://www.meer.net/ebina/hang1.png

It sure looks like it is hanging looking up the boot volume by uuid. Why this should happen only some times I have no idea.

Does this help any of you much more knowledgable people with this problem?

---------- Post added at 05:28 PM ---------- Previous post was at 04:23 PM ----------

I wish I knew more about Macs. Here is a second hang (it seems to hang around 1 in 10 now that I'm using -v).
http://www.meer.net/ebina/hang2.png
It is slightly different than the first, this time it seemed to get further from the waiting for boot volume message, so maybe that isn't what it is hanging on. Both hangs happen right after messages about apple intel extensions, but in different orders.
First time it loads AppleIntelGMA950 and then hangs on AppleIntelGMAX3100
Second hang loads AppleIntelGMAX3100 and then hangs on AppleIntelGMA950
Are those graphics extensions?
  (#13) Old
ebina1 ebina1 is offline
Junior Member
 
Posts: 3
Join Date: Oct 2009
Default 10-04-2009, 06:14 AM

Third times a charm? Here is the third hang:
http://www.meer.net/ebina/hang3.png
As you can see it is much like the second only with AppleIntelGMAX3100 and AppleIntelGMA950 reversed. So I googled on those two and found that a number of people on other netbooks had had problems with AppleIntelGMA950.
So I removed /System/Library/Extensions/AppleIntelGMA950.kext
First good news, the system still booted and appeared to run fine so far.
Bad news, after 6 reboots it now hung on AppleIntelIntegratedFramebuffer

So I removed that too. 7 reboots later it hung again:
http://www.meer.net/ebina/hang4.png
I give up on the trial and error debugging.
  (#14) Old
phaseIV phaseIV is offline
Junior Member
 
Posts: 3
Join Date: Apr 2009
Default 10-09-2009, 07:07 PM

I had the same thing on my (DellEFI/NBM OSX installed) Lenovo s10e.
A poster called goldeneye posted a suggestion at the s10lenovo.com forum and I haven't had a stalling boot since.

The fix is to add;
<key>UHCIreset</key>
<string>Yes</string>
into /Extra/com.apple.Boot.plist.

Who knows maybe this fix will also work on the DELL netbooks. Wish you luck !
  (#15) Old
sam21983 sam21983 is offline
Junior Member
 
Posts: 21
Join Date: Aug 2009
Default 10-17-2009, 03:52 AM

Quote:
Originally Posted by phaseIV View Post
I had the same thing on my (DellEFI/NBM OSX installed) Lenovo s10e.
A poster called goldeneye posted a suggestion at the s10lenovo.com forum and I haven't had a stalling boot since.

The fix is to add;
<key>UHCIreset</key>
<string>Yes</string>
into /Extra/com.apple.Boot.plist.

Who knows maybe this fix will also work on the DELL netbooks. Wish you luck !
I have a Dell Mini 10v, and below is the code from the com.apple.Boot.plist file. Where do I insert the code mentioned above? Is there a specific portion the code should be placed?

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>Kernel</key>
<string>mach_kernel</string>
<key>Kernel Flags</key>
<string></string>
<key>Timeout</key>
<string>5</string>
<key>device-properties</key>
<string>c600000001000000020000006100000002000000 02 010c00d041030a000000000101060000027fff040010000000 6d006f00640065006c0000000b000000474d41203935302000 00004100410050004c002c00480061007300500061006e0065 006c0000000800000001000000590000000200000002010c00 d041030a0000000001010600001b7fff0400180000006c0061 0079006f00750074002d00690064000000080000000c000000 160000006200750069006c0074002d0069006e000000050000 0001</string>
<key>Boot Graphics</key>
<string>Yes</string>
<key>SMBIOSdefaults</key>
<string>No</string>
</dict>
</plist>
  (#16) Old
bsoplinger1 bsoplinger1 is offline
Expert Member
 
Posts: 692
Join Date: Mar 2009
Default 10-17-2009, 11:32 AM

Quote:
Originally Posted by sam21983 View Post
I have a Dell Mini 10v, and below is the code from the com.apple.Boot.plist file. Where do I insert the code mentioned above? Is there a specific portion the code should be placed?
You should notice the file is arranged in pairs of lines, first a key then a string. Add the new key/string pair anyplace within the <dict> section you want as long as its not between any existing key/string pairs.


Mini1: Vostro A90, Black, 2G, 1.3 Webcam, Bluetooth, 64G SuperTalent, OS X 10.6.4
Mini2: Mini9, Black, 2G, 0.3 Webcam, Bluetooth, 32G RunCore, OS X/Win 7, internal PCI-e SHDC Reader
Mini3: Mini10v. Black, 2G, Webcam, 640G HD, OS X 10.5.8/Win 7/Ubuntu [Hibernate w/NBI 0.8.3 RC4]
Dropbox Referral
 

« Previous Thread | Next Thread »
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Copyright © 2008-2016 MyDellMini.com.