Mac OS X Development Development and discussion on the latest hackintosh drivers and methods.

Reply
 
Thread Tools Display Modes
  (#1) Old
MidTownHD MidTownHD is offline
Member
 
MidTownHD's Avatar
 
Posts: 38
Join Date: Apr 2009
Default Kext for Broadcom 4353 (Dell wlan 1520) ? - 05-08-2010, 11:48 PM

Can anyone help me get Dell wlan 1520 work under SL?
I've read that 1510 works out of the box,
how can I get get 1520 work?
It's a Broadcom 4353.


Dell Mini 9 | 2 GB RAM | 16GB STEC SSD | 1.3M Webcam | USB BT | BIOS A05 | USB Legacy: Disabled
Snow Leopard 10.6.3 | NetbookInstaller 0.8.4 RC1 |
Reply With Quote
  (#2) Old
meklort meklort is offline
Guru
 
meklort's Avatar
 
Posts: 1,353
Join Date: Feb 2009
Location: Colorado, USA
Send a message via AIM to meklort Send a message via MSN to meklort Send a message via Yahoo to meklort
Default 05-09-2010, 03:26 AM

NetbookInstaller adds the 4353 device id to the AppleAirPortBrcm4311 kext, s (if the driver works with it), it should be loading and working. If not, you can verify your driver's device and vendor id's and that they are in that kext's plist.


Dell Mini 9 | Mac OS X 10.6.5 | 2 GB RAM | 32 GB Buffalo SSD | BIOS A05
Dell Mini 10v | Mac OS X 10.6.5 | 1 GB RAM | 160 GB HDD | BIOS A06
My Blog | NetbookInstaller code repository | NetbookInstaller Website | Want a Lockerz.com invite? message me.
Reply With Quote
  (#3) Old
andykwg andykwg is offline
Senior Member
 
Posts: 120
Join Date: Feb 2009
Default 09-12-2010, 12:21 AM

I have a replacemend 1520 for my 10v also. I don't see AppleAirPortBrcm4311 kext, where it should be?

I have SL 10.6.3 with 0.8.3 Final.

Any help is appreciated.


 Mini 1011 | N280/A05 | OSX 10.6.5 (NBI 0.8.5Pre), WIN 7 Pro | 2G RAM | 250G HD | BT
 MacBookPro2011 | OSX 10.6.7 | 4G RAM | 500 HD
Reply With Quote
  (#4) Old
andykwg andykwg is offline
Senior Member
 
Posts: 120
Join Date: Feb 2009
Exclamation More info ono DL1520 WiFi (BroadCom 4353) - 09-12-2010, 10:25 PM

OK, I search in OSX86 project and read most of the WiFi KEXT stuffs. Still did not figure it out.

I have 10.6.3 with NBI0.8.4RC1, and I found the KEXT in:
/Extra/Mini10vExt/IO80211Family.kext/Contents/PlugIns/AppleAirPortBRCM4311.ext
and
/Extra/Mini10vExt/IO80211Family.kext/Contents/PlugIns/AppleAirPortBRCM43224.ext

There is already something like:
<string>pci14e4,4353</string>

I checked in Win7 and I got this:
PCI\VEN_14E4&DEV_4353&SUBSYS_000E1028&REV_01
PCI\VEN_14E4&DEV_4353&SUBSYS_000E1028
PCI\VEN_14E4&DEV_4353&CC_028000
PCI\VEN_14E4&DEV_4353&CC_0280

So, it seems to me the 0.8.4RC1 already try to add 4353 to both BRCM KEXT. But it is not recognized. When I look at the label on the CARD, it says:
Broadcom BCM943224HMS

So, is it a 4353 or 43224? But both of the kext has 4353 so why it does not see it?

Anyone with experience with KEXT/WIFI can clue me in?

Thanks in advance.


 Mini 1011 | N280/A05 | OSX 10.6.5 (NBI 0.8.5Pre), WIN 7 Pro | 2G RAM | 250G HD | BT
 MacBookPro2011 | OSX 10.6.7 | 4G RAM | 500 HD
Reply With Quote
  (#5) Old
andykwg andykwg is offline
Senior Member
 
Posts: 120
Join Date: Feb 2009
Default 09-15-2010, 01:13 AM

I tested changing the 4311 kext and 43224 kext, does not help.

Anyone know have got DELL 1520 WiFi to work with 10.6.3?


 Mini 1011 | N280/A05 | OSX 10.6.5 (NBI 0.8.5Pre), WIN 7 Pro | 2G RAM | 250G HD | BT
 MacBookPro2011 | OSX 10.6.7 | 4G RAM | 500 HD
Reply With Quote
  (#6) Old
andykwg andykwg is offline
Senior Member
 
Posts: 120
Join Date: Feb 2009
Default 10-03-2010, 04:01 PM

After all the try and error and research online, The 0.8.4RC include drivers that has the 4354 code in the plist, but the DW1520 card do not work with the driver.

That is as far as I went - just thought I report back in case if anyone have the same issue.


 Mini 1011 | N280/A05 | OSX 10.6.5 (NBI 0.8.5Pre), WIN 7 Pro | 2G RAM | 250G HD | BT
 MacBookPro2011 | OSX 10.6.7 | 4G RAM | 500 HD
Reply With Quote
  (#7) Old
JustinParis JustinParis is offline
Junior Member
 
Posts: 1
Join Date: Oct 2010
Default 10-14-2010, 08:48 PM

Hello,

I've got the same issue with my DW1520 in the Latitude E6410. The correct kext is loaded (so the system know this device is here), but the Wifi card is not turned on during startup.

So in my opinion it is more a problem with PCIe kext, or any other kext which does not power on the PCIe bus during start up.

Another possiblity is that the airport program does not find the device (in real mac it is maybe on another bus), so it does not turn it on. The blutooth is working but it is on an internal USB port.

That is what I think and I am not an expert. Thanks for reading.
Reply With Quote
Reply

« Previous Thread | Next Thread »
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Copyright © 2008-2016 MyDellMini.com.