General Mac OS X Discussion General Apple and Mac OS X Discussion

Reply
 
Thread Tools Display Modes
  (#1) Old
nerdtalker nerdtalker is offline
Junior Member
 
Posts: 4
Join Date: Mar 2009
Default Deleted Displays.prefPane/Contents/info.plist and version.plist - 05-19-2009, 07:18 AM

I just ran into the display mirroring artifact (vertical line issue) and, before searching around here (like I should have) followed the unsound advice of some other website and nuked version.plist and info.plist from the Displays.prefPane/Contents directory.

Now, obviously the displays tab in system preferences shows nothing.

I since fixed the display mirroring issue by using the "mirroring off" terminal command while the monitors are mirrored, but I would like to get displays back. Is there any simple way or is a reinstall of OS X in order?
Reply With Quote
  (#2) Old
twl130 twl130 is offline
Junior Member
 
Posts: 7
Join Date: May 2009
Location: Erie, PA, USA
Send a message via AIM to twl130
Default 05-20-2009, 02:12 AM

I did the same thing. However, the terminal command did not work for me. We could use some help, please!


MyDellMini: Obsidian black, 2GB mem, webcam, 16GB SSD, Mac OS X (10.5.7) running perfectly, SIM card slot, two-finger scrolling enabled
Reply With Quote
  (#3) Old
meklort meklort is offline
Guru
 
meklort's Avatar
 
Posts: 1,353
Join Date: Feb 2009
Location: Colorado, USA
Send a message via AIM to meklort Send a message via MSN to meklort Send a message via Yahoo to meklort
Default 05-20-2009, 02:22 AM

Extract the missing file and install it from your install dvd (or an Apple update) with pacifist.


Dell Mini 9 | Mac OS X 10.6.5 | 2 GB RAM | 32 GB Buffalo SSD | BIOS A05
Dell Mini 10v | Mac OS X 10.6.5 | 1 GB RAM | 160 GB HDD | BIOS A06
My Blog | NetbookInstaller code repository | NetbookInstaller Website | Want a Lockerz.com invite? message me.
Reply With Quote
  (#4) Old
nerdtalker nerdtalker is offline
Junior Member
 
Posts: 4
Join Date: Mar 2009
Default 05-20-2009, 05:45 AM

Quote:
Originally Posted by twl130 View Post
I did the same thing. However, the terminal command did not work for me.
I got that to work, but the trick is that you need to do it in the correct order.

1. Fire up terminal, and enter the "mirroring off" line without quotes
2. Make sure you still have focus in the terminal
3. Connect the 2nd monitor
4. Wait for it to mirror and artifact like it does, be patient until this process is totally done
5. Press enter
-Should undo the mirroring now.

I'm going to try the pacifist route with the 10.5.7 combo update and see whether this works, thanks for the tip!
Reply With Quote
  (#5) Old
nerdtalker nerdtalker is offline
Junior Member
 
Posts: 4
Join Date: Mar 2009
Default 05-20-2009, 06:51 AM

Quote:
Originally Posted by meklort View Post
Extract the missing file and install it from your install dvd (or an Apple update) with pacifist.
Thanks a ton, that worked.

I extracted the files and zipped them up if anyone else cares: RequiredMissing.zip
Reply With Quote
  (#6) Old
twl130 twl130 is offline
Junior Member
 
Posts: 7
Join Date: May 2009
Location: Erie, PA, USA
Send a message via AIM to twl130
Default 05-20-2009, 05:12 PM

Thanks for the files. But I can't seem to find out where I deleted them from now! Been searching posts for hours and keep missing it. If you could let me know real quick, I can try the Terminal command method again.

Thanks, both of you.


MyDellMini: Obsidian black, 2GB mem, webcam, 16GB SSD, Mac OS X (10.5.7) running perfectly, SIM card slot, two-finger scrolling enabled
Reply With Quote
  (#7) Old
meklort meklort is offline
Guru
 
meklort's Avatar
 
Posts: 1,353
Join Date: Feb 2009
Location: Colorado, USA
Send a message via AIM to meklort Send a message via MSN to meklort Send a message via Yahoo to meklort
Default 05-20-2009, 05:59 PM

Quote:
Originally Posted by twl130 View Post
Thanks for the files. But I can't seem to find out where I deleted them from now! Been searching posts for hours and keep missing it. If you could let me know real quick, I can try the Terminal command method again.

Thanks, both of you.
/System/Library/PreferencePanes


Dell Mini 9 | Mac OS X 10.6.5 | 2 GB RAM | 32 GB Buffalo SSD | BIOS A05
Dell Mini 10v | Mac OS X 10.6.5 | 1 GB RAM | 160 GB HDD | BIOS A06
My Blog | NetbookInstaller code repository | NetbookInstaller Website | Want a Lockerz.com invite? message me.
Reply With Quote
  (#8) Old
twl130 twl130 is offline
Junior Member
 
Posts: 7
Join Date: May 2009
Location: Erie, PA, USA
Send a message via AIM to twl130
Default 05-21-2009, 12:02 AM

Those are just preference panes. Where do I actually put these files? I know they go inside a folder called Contents, which I thought went inside Displays.prefPane. Help


MyDellMini: Obsidian black, 2GB mem, webcam, 16GB SSD, Mac OS X (10.5.7) running perfectly, SIM card slot, two-finger scrolling enabled
Reply With Quote
  (#9) Old
twl130 twl130 is offline
Junior Member
 
Posts: 7
Join Date: May 2009
Location: Erie, PA, USA
Send a message via AIM to twl130
Default 05-21-2009, 12:09 AM

Nevermind, got the files back in place. I'll try to fix the mirroring now, and get back to you.


MyDellMini: Obsidian black, 2GB mem, webcam, 16GB SSD, Mac OS X (10.5.7) running perfectly, SIM card slot, two-finger scrolling enabled
Reply With Quote
  (#10) Old
twl130 twl130 is offline
Junior Member
 
Posts: 7
Join Date: May 2009
Location: Erie, PA, USA
Send a message via AIM to twl130
Default 05-21-2009, 12:17 AM

Quote:
Originally Posted by nerdtalker View Post
I got that to work, but the trick is that you need to do it in the correct order.

1. Fire up terminal, and enter the "mirroring off" line without quotes
2. Make sure you still have focus in the terminal
3. Connect the 2nd monitor
4. Wait for it to mirror and artifact like it does, be patient until this process is totally done
5. Press enter
This still didn't work for me, even with my preference panes all correct again. I'm trying to hook up a Samsung 19" LCD via VGA and can't get rid of the mirroring. Any other suggestions?


MyDellMini: Obsidian black, 2GB mem, webcam, 16GB SSD, Mac OS X (10.5.7) running perfectly, SIM card slot, two-finger scrolling enabled
Reply With Quote
Reply

« Previous Thread | Next Thread »
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Copyright © 2008-2016 MyDellMini.com.