General Mac OS X Discussion General Apple and Mac OS X Discussion

Reply
 
Thread Tools Display Modes
  (#11) Old
gQstatus05 gQstatus05 is offline
Senior Member
 
Posts: 330
Join Date: Feb 2009
Default Re: OSX SD Card Capacity Limit on Dell Mini 9? - 05-03-2009, 05:20 PM

I have a 32GB SD card and it works.


Dell Mini 9 RED | 1.6GHz | 10.5.7 OSx| 32GB SD Card + 32GB SSD | 2GB RAM | 802.11B/G/N | BT |
Reply With Quote
  (#12) Old
bluloo bluloo is offline
Junior Member
 
Posts: 28
Join Date: Apr 2009
Default Re: OSX SD Card Capacity Limit on Dell Mini 9? - 05-03-2009, 07:37 PM

Quote:
Originally Posted by gQstatus05
I have a 32GB SD card and it works.
Which brand & type of card do you have?

Thanks
Reply With Quote
  (#13) Old
RebelKangaroo RebelKangaroo is offline
Junior Member
 
Posts: 21
Join Date: Feb 2009
Default Re: OSX SD Card Capacity Limit on Dell Mini 9? - 05-03-2009, 08:14 PM

A 4GB SanDisk Ultra II that's marked SDHC is the first one that I tested. I'm not sure where to measure the speed at, but it seems to be going just as fast as my usb keys. I used DellEFI 1.1 and loaded OSX directly onto my Runcore from a mac if that helps.
Reply With Quote
  (#14) Old
Z25MN6 Z25MN6 is offline
Junior Member
 
Posts: 10
Join Date: May 2009
Default Re: OSX SD Card Capacity Limit on Dell Mini 9? - 05-04-2009, 01:04 AM

Quote:
Originally Posted by dchao
I think you have a corrupted SD card driver.

Try downloading the latest version of DellEFI from GoogleCode, and re-run DellEFI again. I use the 1.1 final release, and it works fine.
Thank you to all who replied to my OP - those who listed 8, 16, & 32gb cards that you have that work (which gave me confidence that if I just kept looking, I'd find the reason), but especially to dchao for the link out to the GoogleCode repository that until his post, I did not know existed.

Here's how I resolved my problem:

=I downloaded and installed the DellEFI 1.1 final release from the GoogleCode repository. No help.
=I downloaded and installed the DellEFI 1.2a5 alpha release from the GoogleCode repository. No help.
=I was discouraged at this point, of course, but kept searching. Found an SDHC detection test tool at http://www.mydellmini.com/forum/sd-card ... tml#p20187 (thanks, km9) Ran the tool, but didn't quite understand the output. Even so, AFAICT, it looked as if I indeed had a corrupted driver, so I kept looking for an appropriate kext.
=Found sdhc-km9-20090211.zip at http://www.mydellmini.com/forum/sd-c...00.html#p20187
=Tried to install the kext directly, but failed. Used Terminal and Kext Helper, but must have screwed it up. Gave up on "sudo"
="Fiddled around" (sorry, best I can describe it) to replace this kext into the DellEFI 1.1 file I had downloaded. (A lot of WinRAR, Magic ISO, Img Burn, and a couple CD-R coasters, but I finally did it)
=Reran the modified DellEFI 1.1, rebooted, and presto! It works.

I wish I could document the precise step by step process. But I had so many failures that the only thing that was successful was the last thing I tried, which I'm explaining as well as I recall just in case anyone else runs onto the same problem. From the number of posts in this thread which refer to "it just works," I may have had a one-off issue of some sort. But I couldn't let it go without saying thanks to all who offered help.


 Mini 10v  | 2Gb RAM | 160 Gb HDD | OSX 10.6.3 | NBI 0.8.4RC1 | BIOS A04 | USB Wake : OFF | USB Legacy : OFF | Bluetooth | WebCam
Reply With Quote
  (#15) Old
pirinto pirinto is offline
Junior Member
 
pirinto's Avatar
 
Posts: 19
Join Date: Mar 2009
Default 05-13-2009, 10:53 PM

I got an issue with the operating system (OSX) freezing as soon as I insert an SD or SDHC card. I'm running 10.5.6 and DellEFI 1.1

no SD cards out of two have worked et. I've tried a regular 1Gb SDcard from Kingston an a Sandisk Ultra II 16Gb SDHC Card that I got yesterday.

The Mouse pointer freezes as soon as you insert an SDcard. If you remove it the system continues as normal. I don't know the reason behind this. But it seems I'm not the onl one having this particular issue.

I even tried to roll back to a clean installation to see if it was some driver related thing but none of the cards work.

Anybody know of a solution yet?
Or at least is experiencing the same thing?
Reply With Quote
  (#16) Old
UnaClocker UnaClocker is offline
Guru
 
Posts: 1,744
Join Date: Sep 2008
Location: Olalla, WA
Send a message via AIM to UnaClocker Send a message via Yahoo to UnaClocker
Default 05-14-2009, 02:13 AM

So what it comes down to, it sounds like, is that DellEFI either doesn't have the latest driver from km9 for the SD slot (most likely) or the driver got garbled at some point.. Someone should let bmaltais know.. Maybe he'll swap in the new driver in 1.1 and come out with a 1.1b or something.


Tired of wondering if your Mini9 is doing ANYTHING? - Add a HDD Activity LED
Reply With Quote
  (#17) Old
Richdmoore Richdmoore is offline
Senior Member
 
Posts: 104
Join Date: Mar 2009
Default 05-14-2009, 02:56 AM

Question: Am I better to get some HDSC cards (Class 6) to store movies to play with quicktime on the road, or would USB thumb drives be just as fast (and cheaper?)

I'm just trying to figure out the best way to carry DVD's I want to watch while I travel for work, don't want to invest a lot in 3 or 4 cards/usb drives that turn out to be the wrong way to go.
Reply With Quote
  (#18) Old
emdc emdc is offline
Senior Member
 
Posts: 153
Join Date: Dec 2008
Location: Birmingham, AL
Default 05-14-2009, 03:04 AM

Quote:
Originally Posted by SkyWriter View Post
i have a 16gb class 6 transcend card formatted with Mac OS Extended (Journaled). i never remove it, and never have a problem.
Same here. I also have a 4 GB & a couple of 2 GB that work fine.


Dell mini 9, 2GB RAM, 32GB RunCore SSD, OS X (10.6.7)
Reply With Quote
  (#19) Old
macmac macmac is offline
Junior Member
 
Posts: 8
Join Date: Mar 2009
Default 05-14-2009, 05:20 AM

my 16gb works great!
Reply With Quote
  (#20) Old
HotDog HotDog is offline
Senior Member
 
HotDog's Avatar
 
Posts: 150
Join Date: Mar 2009
Send a message via Skype™ to HotDog
Default SD Card - 05-14-2009, 02:54 PM

I found a 16GB "el cheapo" that is branded "Elite Pro 16GB High Speed Memory Card" that I snagged for no more than $15 on eBay for a camera that I own. I formatted it for the MiniMac 9 and it works just fine. It may be a little slow, but I just use the SD for archival stuff anyway. No problems here.


[ Dell Mini 9 | Black | A04 | NBI 20100616212351 | OS X 10.6.7 | 2GB RAM | 64GB SSD | BT | 1.3MP | WiFi ]
[ Dan-O-Cam : http://smith.soehd.csufresno.edu/ ]
Reply With Quote
Reply

« Previous Thread | Next Thread »
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Copyright © 2008-2016 MyDellMini.com.