Thread: VPN / Hamachi
View Single Post
  (#24) Old
trickyzach trickyzach is offline
Junior Member
 
Posts: 17
Join Date: Jun 2009
Default 06-23-2009, 04:52 PM

Doesnt look like using port 443 makes a difference.

Without http-proxy

Tue Jun 23 12:48:02 2009 OpenVPN 2.0.9 Win32-MinGW [SSL] [LZO] built on Oct 1 2006
Tue Jun 23 12:48:02 2009 LZO compression initialized
Tue Jun 23 12:48:02 2009 TAP-WIN32 device [Local Area Connection 3] opened: \\.\Global\{B26E1A0C-EFCB-43C4-B304-58FB1F1DB0B7}.tap
Tue Jun 23 12:48:02 2009 Notified TAP-Win32 driver to set a DHCP IP/netmask of 192.168.1.126/255.255.255.0 on interface {B26E1A0C-EFCB-43C4-B304-58FB1F1DB0B7} [DHCP-serv: 192.168.1.0, lease-time: 31536000]
Tue Jun 23 12:48:02 2009 Successful ARP Flush on interface [4] {B26E1A0C-EFCB-43C4-B304-58FB1F1DB0B7}
Tue Jun 23 12:48:02 2009 UDPv4 link local (bound): [undef]:443
Tue Jun 23 12:48:02 2009 UDPv4 link remote: xxxxxx:443

It just hangs.

With http proxy

Tue Jun 23 12:51:33 2009 OpenVPN 2.0.9 Win32-MinGW [SSL] [LZO] built on Oct 1 2006
Tue Jun 23 12:51:33 2009 IMPORTANT: OpenVPN's default port number is now 1194, based on an official port number assignment by IANA. OpenVPN 2.0-beta16 and earlier used 5000 as the default port.
Tue Jun 23 12:51:33 2009 Static Encrypt: Cipher 'BF-CBC' initialized with 128 bit key
Tue Jun 23 12:51:33 2009 Static Encrypt: Using 160 bit message hash 'SHA1' for HMAC authentication
Tue Jun 23 12:51:33 2009 Static Decrypt: Cipher 'BF-CBC' initialized with 128 bit key
Tue Jun 23 12:51:33 2009 Static Decrypt: Using 160 bit message hash 'SHA1' for HMAC authentication
Tue Jun 23 12:51:33 2009 LZO compression initialized
Tue Jun 23 12:51:33 2009 Data Channel MTU parms [ L:1579 D:1450 EF:47 EB:135 ET:32 EL:0 AF:3/1 ]
Tue Jun 23 12:51:33 2009 Local Options hash (VER=V4): '62518268'
Tue Jun 23 12:51:33 2009 Expected Remote Options hash (VER=V4): 'cef5322e'
Tue Jun 23 12:51:33 2009 Attempting to establish TCP connection with xxxxxx:8080
Tue Jun 23 12:51:33 2009 TCP connection established with xxxxxx:8080
Tue Jun 23 12:51:33 2009 Send to HTTP proxy: 'CONNECT xxxxx.gotdns.com:443 HTTP/1.0'
Tue Jun 23 12:51:39 2009 recv_line: TCP port read timeout expired
Tue Jun 23 12:51:39 2009 TCP/UDP: Closing socket
Tue Jun 23 12:51:39 2009 SIGUSR1[soft,init_instance] received, process restarting
Tue Jun 23 12:51:39 2009 Restart pause, 5 second(s)


Couldnt figure out where to put the parm auto proxy.

Shame if I cant get this to work at work, but not the end of the world. More just a curiosity thing at this point.
Reply With Quote