View Single Post
  (#1) Old
Tdog Tdog is offline
Junior Member
 
Posts: 6
Join Date: Sep 2010
Default SL/Ubuntu OK, then fails: GRUB error: no such partition - 02-14-2011, 08:38 PM

I have a dual boot system on a Dell Mini 10v, SL 10.6.6 & Ubuntu Netbook 10.10. The HD is partitioned like this:

sda1: System/Boot Partition
sda2: OS X (10.6.6)
sda3: Ubuntu partition. GRUB bootloader installed here.
sda4: Linux Swap
sda5: FAT32, for shared data

I've been using this about 6 months, but twice now I have selected the Linux partition from Chameleon & been unable to boot Ubuntu. I get this GRUB error instead:

error: no such partition.
grub rescue>


running the set command returns this, which seems correct:
prefix=(hd0,gpt3)/boot/grub
root=hd0,gpt3


If I run Ubuntu Live off a USB drive, I can see the partition, mount it & browse it. The file system looks intact. I've tried booting off the Ubuntu Alternate CD & running Rescue Mode to reinstall the GRUB boot loader, but this operation fails, saying: "Executing 'grub-install' /dev/sda3/' failed."

I ran the Boot Info Script & it reports this boot sector info for my Ubuntu partition: "Grub 2 is installed in the boot sector of sda3 and looks at sector 903373787 of the same hard drive for core.img, but core.img can not be found at this location."

Since I haven't figured out a way to repair this problem, I do a complete re-install of Ubuntu, but I'm wondering if others have found a solution. Maybe there is a problem with GRUB being installed on a partition. A note in the GRUB manual says:

If possible, it is generally best to avoid installing GRUB to a partition (unless it is a special partition for the use of GRUB alone, such as the BIOS Boot Partition used on GPT). Doing this means that GRUB may stop being able to read its core image due to a file system moving blocks around, such as while defragmenting, running checks, or even during normal operation.

Dell Mini 10v | Mac OS X 10.6.6 | Ubuntu Netbook 10.10 | 1.6 GHz | 1GB RAM | 500GB HDD | BIOS A06 | NBI 0.8.4 RC1
Reply With Quote