Mac OS X Development Development and discussion on the latest hackintosh drivers and methods.

Thread Tools Display Modes
  (#11) Old
Side.Step.Society Side.Step.Society is offline
Senior Member
Side.Step.Society's Avatar
Posts: 289
Join Date: Dec 2009
Location: Canada
Send a message via MSN to Side.Step.Society
Default 03-19-2010, 08:08 PM

"When you call your machine MacBook Mini via Model Identifier, OS X does not know what that is. I would imagine that is why the icon is not showing up correctly."

This is what I had suspected at first, so I tried swapping the SMBIOS file I had created with a "default" for a MacBook Air. Still, it wouldn't show the MBA icon on other Macs. I'll try it again though just to double check.

*EDIT*: Well, slap a sticker on me and call me stupid.

Tried the default MBA SMBIOS.plist file again, this time, it worked. Showing MBA icon on my Mac mini, just swimmingly. Also, DVD Player does indeed work as posted above.

Perhaps because I changed the RAM speed to actually match that of the Dell mini was creating some issues before.

Now, what would be nice, would be the MBA profile, with the aluminum MBP icon. I'll have to see what I can rig up, if it's possible. Without of course just replacing the icon on each computer in the Coretypes bundle.
Reply With Quote
  (#12) Old
humph humph is offline
Posts: 58
Join Date: Aug 2009
Default 03-19-2010, 08:32 PM

Cool !!!

Some of the patches for Chalemeleon are able to detect RAM stuff now, so am sure that'll be in the next formal release (or you could grab one of the various builds, but watch out as they dont all have the 10.6.2 kernel patch). So, wont need RAM stuff in smbios.plist going forward.
Reply With Quote

« Find/Dev Kexts | Strange Error after installing voodoopower »
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Copyright © 2008-2016