Mac OS X Development Development and discussion on the latest hackintosh drivers and methods.

Thread Tools Display Modes
  (#1) Old
Cruiseman Cruiseman is offline
Junior Member
Cruiseman's Avatar
Posts: 21
Join Date: Nov 2009
Location: Singapore
Default 0.8.3 RC5 Theme Icons - 12-22-2009, 05:43 AM


I am having multiboot configuration using Chameleon bootloader. I used to have the beautiful mac logo and windows logo in my boot selection menu. After I upgraded to RC5 yesterday, I lost these 2 logos. Instead I have the hard disk picture as the logo in my boot selection for both my Mac and Win7. Any kind soul knows how I can tweak to get back these nice pictures .

Many thanks.

Mini 10v | 1GB RAM | 250 GB HDD | NBI .8.3RC5 | BIOS A06 | USB Wake : ON| USB Legacy : ON | Triple OS: Win7 Ultimate/OSX 10.6.2/Ubuntu 9.10
Reply With Quote
  (#2) Old
yidakee yidakee is offline
Senior Member
yidakee's Avatar
Posts: 128
Join Date: Oct 2009
Default 12-22-2009, 06:02 PM


I'm no mod, but you should edit the title to something less vague, like "RC5 and Chameleon themes"..or similar, so as not to confuse folk. There are proper threads where all, and specificly related RC5 issues are discussed.

Did you backup your /Extra folder before upgrading? did you did you ? hmmm...
Because Chameleon themes are inside it, and NBI overwrites the whole thing...
If you did backup, copy the folder name "your_theme" (or whatever) into /Extra/Themes, edit with

But if you didnt back up.... well... dont dispair!
If you look closely, underneath the Extra folder there is an Extra.bak... it will contain your "lost" theme.

If you only have "default" theme there, check the pictures inside, if it is your "lost" theme, just overwrite the RC5 /Extra/Theme/Default content with the backup, run UpdateExtra, let it spin, repair permissions, and reboot!

The BlackMini 10v | 2GB | Seagate 320GB 7,200 rpm | A06 -> A04 (NBI 0.8.3 RC5) | OSX 10.6.2 | Voodoo Power Mini (w/ Sleep Stepping) | ******* My easy 10v trackpad and palm rest mod ->
Reply With Quote
  (#3) Old
minimalpc minimalpc is offline
Expert Member
Posts: 560
Join Date: Dec 2009
Default 12-23-2009, 04:33 AM

FWIW, I had this happen with RC5, too. I had never installed any Chameleon themes beyond whatever NBI itself installed. I figure that RC5 must use a different default theme than RC4. I liked the old one with the Windows and Mac logos better myself.

Dell Mini 10v | Mac OS X 10.6.2 | Windows 7 Professional | Ubuntu Netbook Remix 9.10 | 1GB RAM | 160GB HDD | BIOS A05 | USB Legacy: OFF | USB Wake: OFF | BT: Enabled (self-installed BCM2046) | NBI 0.8.3 final
Reply With Quote

0.8.3 rc5, chameleon, nbi

« Just a thought | 12'' Netbook with RC5 »
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Copyright © 2008-2016