General Mac OS X Discussion General Apple and Mac OS X Discussion

Thread Tools Display Modes
  (#1) Old
edavison edavison is offline
Junior Member
Posts: 4
Join Date: Apr 2009
Default web pages loading slowly in OS X - 05-22-2009, 11:53 PM

I installed OS X 10.5.7 everything works great. and programs load quickly, but when I'm on the internet web pages seem to load a lot slower than when I had XP. Any ideas?

Dell Mini 9 Runcore 32 gb sdd 2gb ram
Reply With Quote
  (#2) Old
emdc emdc is offline
Senior Member
Posts: 153
Join Date: Dec 2008
Location: Birmingham, AL
Default 05-23-2009, 06:38 AM

What browser are you using? If Safari, try Firefox.

Safari 4.x beta is pretty darn speedy.

Dell mini 9, 2GB RAM, 32GB RunCore SSD, OS X (10.6.7)
Reply With Quote
  (#3) Old
ronin510 ronin510 is offline
Posts: 64
Join Date: Feb 2009
Default 05-23-2009, 07:15 AM

Are you by any chance using an AT&T internet service (AT&T/Yahoo DSL, AT&T U-Verse, SBC internet, etc) ?

I was experiencing slow web page loading on Mac OS X on the mini, but not with XP/Ubuntu or on any of my other computers. Searching all over, I found that AT&T's Cable/DSL/Router modems don't work well with Mac OS X. Mac OS X uses the internal IP address (192.168.x.x) as the DNS server. You can manually bypass this by going into the network device (Ethernet, Airport) and configuring the DNS to AT&T's instead of the 192 address. I decided to use alternate, well known DNS servers ( - ).

Once you manually enter and save the DNS server, go into terminal and enter:

dscacheutil -flushcache

Restart Safari/Firefox and you should be good.
Reply With Quote

« I think you can sleep with the stock SSD... | Show off your osX desktop »
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Copyright © 2008-2016