General Mac OS X Discussion General Apple and Mac OS X Discussion

Thread Tools Display Modes
  (#1) Old
ribfeast ribfeast is offline
Junior Member
Posts: 2
Join Date: May 2009
Exclamation Can't enable wireless? Going mad? Try this! - 05-01-2009, 03:35 AM

So you've formatted from XP SP2 and have installed OS X or Windows 7. Everything is great, except you don't have wireless. The card is detected, but you can't turn it on or see any networks. Windows 7 sees it as disconnected, OS X you click to turn airport on to no avail.

What may have happened is wireless was switched off in XP, which tells the chip to turn off. The problem is OS X and Windows 7 can't turn it to turn back on (note: Windows 7 might be able to use an application to toggle the wireless, this method will work if you can't).

Most people say you should format back to XP and turn it back on. This works, but is a pain in the ass.

This is how you fix wireless without reinstalling your OS! 8-)
Note, I am using a windows machine to do this!

Step 1:
Get a USB key, it doesn't have to be big, say 2GB. Make sure it is formatted FAT32.

Step 2:
Go and download the iso of ubuntu here:
Get the 32bit version, I just got the normal 9.04 desktop edition.

Step 3:
Go and download cd2usb here:

Step 4:
Extract the to your desktop, and once ubuntu iso has downloaded drag it into the cd2usb folder. Rename the ubuntu iso from "ubuntu-9.04-desktop-i386" to "os".

Step 5:
Run cd2usb.exe, install ubuntu.iso onto the USB key, make sure you get the drive letter right! It will ask you if you want a persistent file, choose 128MB or more. It will take a while to extract everything, once it is done it might say the persistent file creation failed, don't worry, just ignore it.

Step 6:
Once that is done, take the USB key, stick it into your Mini 9 on the left side, make sure USB legacy is on in bios, and boot up. You should select boot options when starting up and select USB as the boot device. Boot Ubuntu live.

Step 7:
You're in Ubuntu now
You'll need to be plugged into ethernet (as the wireless still isn't going).

Download this:

Just in case the link doesn't work or moves, you are trying to install "aircraft-manager - 12.1". This package allows you to toggle wireless and bluetooth on and off. I've seen people try and use "aircraft-manager - 11" however this crashes in Ubuntu 9.04 and won't open.

Step 8:
Once you've downloaded the aircraft manager .deb package from step 7 you need to install it. Double click the package, it'll install really quickly, and will be in your ubuntu menu at the top (admin/prefs menu I forget). Open it up, and you'll see wireless and bluetooth with tick boxes. Wireless is unticked, tick it and you're done!

Shut down, take out the USB key, reboot back into OS X and enjoy.

Hope this helps!
Reply With Quote
  (#2) Old
Inquieto Inquieto is offline
Junior Member
Posts: 4
Join Date: May 2009
Default 05-12-2009, 04:50 PM

...done...but didn't work...the bluetooth seems to be recognized but still not work, also in ubuntu....what I do wrong?
Reply With Quote
  (#3) Old
Nethfel Nethfel is offline
Posts: 73
Join Date: Apr 2009
Default 05-12-2009, 06:00 PM

Bluetooth is a separate issue - his fix really only addresses the wifi card.
Reply With Quote

« How to fix "operating system not found" | help for this setup: osx on ssd | win 7 on usb hdd »
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Copyright © 2008-2016