General Mac OS X Discussion General Apple and Mac OS X Discussion

Thread Tools Display Modes
  (#1) Old
davpel davpel is offline
Junior Member
Posts: 5
Join Date: Apr 2009
Default Stuck on Apple Logo After DellEFI Reinstall - 04-23-2009, 06:04 AM

My Dell with OSX was running fine until tonight. After trying several times to get the Touchpad Drivers to work without success, I followed the tip at the end of the Touchpad thread and tried to reinstall DellEFI 1.1. After doing so, however, the Dell will not boot back into OSX. Rather, it gets stuck at the grey screen with the Apple logo and spinning wheel. I tried alternate boot methods (e.g. -v -f) to no avail.

The only thing I can think of is that I forgot to uninstall all of the Touchpad drivers before doing the DellEFI reinstall -- including leaving the plst file in the LaunchAgents folder. Could this be what is preventing me from booting up? If not, an ideas on hot to get going again without having to completely reinstall OSX?

Finally, if the problem WAS caused by my forgetting to uninstall the Touchpad drivers first, can I still do so? I suppose I could gain access to Terminal by using the OSX install disk. If so, would the normal Touchpad removal instructions still apply given that I would not be logged in as root (or that's my guess)?

Sorry for so many questions, but I'm just trying to be complete here.

Thanks in advance.
Reply With Quote
  (#2) Old
meklort meklort is offline
meklort's Avatar
Posts: 1,353
Join Date: Feb 2009
Location: Colorado, USA
Send a message via AIM to meklort Send a message via MSN to meklort Send a message via Yahoo to meklort
Default Re: Stuck on Apple Logo After DellEFI Reinstall - 04-23-2009, 01:09 PM

DellEFI overwrites the touchpad drivers so there is no need to uninstall it. The LaunchAgent will run on startup, but it will fail gracefully if the touchpad doesn't support two finger scrolling.

Try booting with -x to get to safe mode. If you can, reinstall DellEFI from there.

Dell Mini 9 | Mac OS X 10.6.5 | 2 GB RAM | 32 GB Buffalo SSD | BIOS A05
Dell Mini 10v | Mac OS X 10.6.5 | 1 GB RAM | 160 GB HDD | BIOS A06
My Blog | NetbookInstaller code repository | NetbookInstaller Website | Want a invite? message me.
Reply With Quote
  (#3) Old
anne anne is offline
Junior Member
Posts: 6
Join Date: Apr 2009
Default Re: Stuck on Apple Logo After DellEFI Reinstall - 04-24-2009, 12:15 AM

The exact same thing happened to me, from start to finish. I posted about it here:

I ended up just completely reinstalling os X. I'm not gonna bother with the touchpad drivers now!
Reply With Quote
  (#4) Old
ImprobableMiniUser ImprobableMiniUser is offline
Posts: 36
Join Date: May 2009
Default Re: Stuck on Apple Logo After DellEFI Reinstall - 05-12-2009, 02:03 AM

Add me to this list. Same exact thing, ran DellEFI 1.1 in hopes of getting the trackpad drivers to work, system hangs on the apple logo + spinning wheel upon reboot. Reinstalling OSX now. :cry:
Reply With Quote
  (#5) Old
gQstatus05 gQstatus05 is offline
Senior Member
Posts: 330
Join Date: Feb 2009
Default 07-02-2009, 09:53 PM

same **** for me. I installed dell efi and I haven't been able to use my mini for a month now. I had so much stuff on that and time machine was taking forever so I didn't backup. I'm hoping I can boot in somehow trying to avoid a complete re-install.

Dell Mini 9 RED | 1.6GHz | 10.5.7 OSx| 32GB SD Card + 32GB SSD | 2GB RAM | 802.11B/G/N | BT |
Reply With Quote

« "cant find mach kernel" error loading WinXP partition on DellEFI 1.2A5 - 1.1 boots | Syncing Address Book and Google Contacts? »
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Copyright © 2008-2016