General Mac OS X Discussion General Apple and Mac OS X Discussion

Thread Tools Display Modes
  (#1) Old
KateKat KateKat is offline
Posts: 80
Join Date: Feb 2009
Location: Reading, UK
Default DellEFI 1.1 Battery Weirdness - 04-03-2009, 07:09 PM

I've successfully installed DellEFI and everything including sleep works just fine, however the battery behavior is a little weird when it runs low. I get the usual battery warning at around 10 mins left however when we get to the last few minutes (sometimes gets to zero) the battery display goes to "(calculating)", if I go into the System Profiler then we get:

Model Information:
Serial Number: Dynapack-W953G-Lion-Unknown
Manufacturer: Dynapack
Device name: W953G
Pack Lot Code: 0000
PCB Lot Code: 0000
Firmware Version: 0000
Hardware Revision: 0000
Cell Revision: 0000
Charge Information:
Charge remaining (mAh): 0
Fully charged: No
Charging: No
Full charge capacity (mAh): 1952
Health Information:
Cycle count: 100
Condition: Check battery
Battery Installed: Yes
Amperage (mA): -720
Voltage (mV): 12983
Although the battery charge shows zero, today I tested the machine to powerdown, WiFi on, web browsing, I got another 15 minutes of operation before the battery gave out and the machine powered off. Is this an internal battery calibration issue or a DellEFI issue???

Reply With Quote
  (#2) Old
solar solar is offline
Junior Member
Posts: 28
Join Date: Mar 2009
Default Re: DellEFI 1.1 Battery Weirdness - 04-03-2009, 07:29 PM

I am having exactly the same issue. Battery seems to be pretty accurate but when i get the low battery warning at about 10 min power left it goes to a never ending calculating.

Not a very big issue but i also would like to know what is causing this. A battery problem or a dellefi problem?

Running dellefi 1.1 final.
Reply With Quote
  (#3) Old
meklort meklort is offline
meklort's Avatar
Posts: 1,353
Join Date: Feb 2009
Location: Colorado, USA
Send a message via AIM to meklort Send a message via MSN to meklort Send a message via Yahoo to meklort
Default Re: DellEFI 1.1 Battery Weirdness - 04-03-2009, 07:42 PM

I think its a battery problem. Since the battery is reporting no charge (its says its empty), the kext is unable to calculate a time remaining.

That or the dsdt / kext might be wrong.
A third possibility is that after the battery reports its empty, it may be reporting an estimated time remaining till it really is empty.

Dell Mini 9 | Mac OS X 10.6.5 | 2 GB RAM | 32 GB Buffalo SSD | BIOS A05
Dell Mini 10v | Mac OS X 10.6.5 | 1 GB RAM | 160 GB HDD | BIOS A06
My Blog | NetbookInstaller code repository | NetbookInstaller Website | Want a invite? message me.
Reply With Quote
  (#4) Old
FrankB FrankB is offline
Junior Member
Posts: 29
Join Date: Mar 2009
Default Re: DellEFI 1.1 Battery Weirdness - 04-03-2009, 07:45 PM

I would guess that once the battery reports 0 mAh, there's no time to calculate. The driver should probably just report 0 minutes left but that's a corner case.

Dell Mini 9 | Mac OS X 10.5.7 | 1 GB RAM | 16 GB STEC SSD | 1.3 Webcam | Bluetooth
BIOS A04 | USB Legacy Mode: OFF | Bluetooth: On | Dell EFI 1.1 | Dropbox
Reply With Quote

« please help please post | Itunes store signin from Mini 9? »
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Copyright © 2008-2016