General Mac OS X Discussion General Apple and Mac OS X Discussion

Thread Tools Display Modes
  (#1) Old
archy archy is offline
Junior Member
Posts: 12
Join Date: Mar 2009
Default SDHC card problem, please help - 03-30-2009, 10:18 PM

Hi all,

I did a bunch of searching, but I don’t know of any threads dealing with SD card problems with the new DellEFI code…

I'm running DellEFI 1.1 with the A04 bios and have had no problems whatsoever. Over the weekend I received a Transcend 16 GB SDHC card that I have formatted as FAT32 (I wanted to use it for both OS X and XP on my dual-boot machine). The card works fine on the Windows side of things, and OS X reads the card no problem. However, in OS X if I let the computer go to sleep and then I shut down the system everything goes away except for my wallpaper, and I have the faint spinning gears. This goes on forever until I do a hard reboot.

When I restart the system, I get an error message about my SD card being corrupted: Disk Repair: the Disk “DOCUMENTS” was not repairable by this computer. It is being made available to you with limited functionality.

Essentially, I can only read only from the SD card. And I can't repair the disk in OS X. But, if the card is corrupt I have no more problems with sleep/reboot.

If I go into my windows side of things and error check the SD card and then restart OS X with the card, I do not get the Disk Repair error anymore. Great! But then if my mini goes to sleep, the problem begins again (sometimes resulting in my mini not coming back from sleep).

I have my USB legacy disabled, and I reinstalled DellEFI 1.1 multiple times. Perhaps this is a bad card? Or is there something else I’m missing?

Thanks for all of your help, this is a great forum (and this is the first time I’ve ever had to ask!)

Reply With Quote
  (#2) Old
neuron neuron is offline
Junior Member
Posts: 1
Join Date: Mar 2009
Default Re: SDHC card problem, please help - 03-31-2009, 01:29 AM

Did you get the card from Amazon?

I tried with another card after my Class 6 Transcend 16GB card failed in the way you're describing. I'd put my homedirectory on it, so it was problematic to diagnose until I created another admin user. Putting the card into a usb reader on another Mac allows me to repair the FS, so I think it's an issue with the SDHC driver.

Previous to 1.1, I received multiple errors of the:

3/20/09 1:34:03 AM kernel SDHCI: I/O timeout during SDMA transfer: Status: 0x0, Error: 0x0, Block: 2173175, Offset: 8, Blocks: 8

format. I've attempted to write zeros to disk to map bad blocks, but to no avail.

I got a little paranoid about the card, as the smaller 8gb card I had seems to function great. I don't think it's a fake, as I'd hope Amazon wouldn't sell them.
Reply With Quote
  (#3) Old
audio_inside audio_inside is offline
Posts: 50
Join Date: Mar 2009
Default Re: SDHC card problem, please help - 04-02-2009, 03:11 AM

My 16GB Transcend Class 6 card works great - no flakiness and I can boot OS X from it as well. Just brainstorming here:

You didn't mention whether you're using the card in a USB SD card reader or in the Mini's native SD slot. If in the USB card reader, there might be a problem with power being applied to the card reader after wakeup. Any difference if you unmount the card before sleep, unplug it and then plug it back in AFTER the machine's fully awake?

What happens if you reformat it as HFS+ instead of FAT32? I know that doesn't meet your use scenario but it might be useful for narrowing down the problem to hardware or not.

Also, you didn't mention if you'd formatted it on the PC or under OS X. If formatted on the PC, you might want to try the other way; if under OS X, try formatting on the PC. If you have another Mac try formatting it there instead of on the Mini.
Reply With Quote
  (#4) Old
archy archy is offline
Junior Member
Posts: 12
Join Date: Mar 2009
Default Re: SDHC card problem, please help - 04-02-2009, 03:32 AM

Thanks for the tip.. haven't worried about this for a few days, but I popped the card in my other PC and gave it a good format (FAT32). No problems so far with 1.1 a2, works great. Thanks again!
Reply With Quote

« What now? | pre-Apple boot screen changed, err »
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Copyright © 2008-2016