General Mac OS X Discussion General Apple and Mac OS X Discussion

Thread Tools Display Modes
  (#1) Old
drheim drheim is offline
Junior Member
Posts: 24
Join Date: Mar 2009
Default Manually rebuild EFI partition - 03-28-2009, 07:26 AM

Hi guys,

This is a weird question, but I installed OSX using the normal instructions under FAQ just a few days ago(using DellEFI 1.1) and everything worked great. I then decided to backup everything and try to rebuild it(long story) and I did and my first 3 partitions are in the same order, but I can no longer boot through my EFI parition and have to use the miniboot CD(on a USB stick). I did not think it would be a big deal and I ran the DellEFI 1.1 utility again and told it through both custom and easy install to rebuild it, but no luck. So I booted Gparted and the DellEFI partition is there and flagged as both hidden and boot and it is formatted as FAT32. Not sure if that is correct or not, but I can use my Dell miniCD usb drive to boot into my OSX(or Vista) partitions fine and keep trying to reinstall the DellEFI partition through the DellEFI utility, but I can never boot off of my SSD.

So basically, I can boot to either MacOS or Vista fine if I use the Miniboot CD, but I am unable to reinstall the EFI partition through the utility so that I can boot off my SSD. When I do try to boot off my SSD I get the error "boot0: MBR boot0: doneThis is not a bootable disk"

I am guessig I could unhide the partition and boot off the CD and then run a dd command from the Dellmini over to partition1, but is there somethiing easier? I just want to make sure I do it the right way.
Reply With Quote
  (#2) Old
drheim drheim is offline
Junior Member
Posts: 24
Join Date: Mar 2009
Default Re: Manually rebuild EFI partition - 03-29-2009, 02:09 AM

Really weird, but I had 3 partitions according to gparted

1 - 200MB EFI flagged as hidden and boot
2 - 30GB as hfs+
3 - 30GB as NTFS

I kept trying to reinstall the DellEFI boot through the 1.1 utility, but everytime I would boot it would give me a non-system disk type of error. I could boot fine from the CD though. I went into parted and deleted partition 1 andmade it free space and now the computer boots again fine and lets me select Vista or OS X.
Reply With Quote

« HELP! Erased my Windows partition by mistake... | before i order my 9 »
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Copyright © 2008-2016