General Mac OS X Discussion General Apple and Mac OS X Discussion

Thread Tools Display Modes
  (#11) Old
pr6srm pr6srm is offline
Posts: 95
Join Date: Jan 2009
Default Re: Problem Booting from external hd - 03-19-2009, 08:26 PM

This is the part that always caused me problems, hence why I prefer to use the hacked installer I mentioned earlier. However, I'm fairly well versed in the theory.
  • Boot to the install DVD/USB key[/*:m:1t0eci0y]
  • Open Disk utility[/*:m:1t0eci0y]
  • Select the partition on your external USB drive and unmount it.[/*:m:1t0eci0y]
  • You can then save an image of this to another partition on that drive or another drive (USB key, network location if you have working WiFi, etc...)[/*:m:1t0eci0y]
  • Scan that image for a restore[/*:m:1t0eci0y]
  • then restore that image to your SSD. Ensure that you don't select the wipe option or it will object on space grounds.[/*:m:1t0eci0y]
  • Reboot using Boot123 and re-run DellEFI.[/*:m:1t0eci0y]

That's the theory... good luck!

Dell Mini 9: Obsidian Black | A05 | Win7 / OS X 10.5.6 Dual Boot | DellEFI 1.1 | 2GB RAM | 64GB RunCore 70mm SSD | 4GB SDHC | Vodafone HSPA | 0.3mP webcam
Dell Mini 9: Obsidian Black | as above except: XP Pro SP3 | 250GB USB HDD
Reply With Quote
  (#12) Old
daktmacfan daktmacfan is offline
Junior Member
Posts: 13
Join Date: Mar 2009
Unhappy Re: Problem Booting from external hd - 03-20-2009, 02:08 AM

I followed the instructions in Disk Utility as follows:

- I started up by booting from my 10.5.6 DVD image on an external flash drive
- I started up Disk Utility and unmounted the partition on my external USB hard drive.
- I then saved this partition as a compressed dmg to a 2nd partition on the external hard drive.
- I next created a single OS X Journaled partition on the internal SSD called "dellmini_osx"
- I next restored the dmg to the internal SSD
- I then rebooted with Boot123 and the internal SSD showsup as "hd(0,1)" (shouldn't it show up as dellmini_osx?)
- I try to boot from that drive and receive the following error:
Boot error

Any thoughts on what I could be doing wrong?
Reply With Quote
  (#13) Old
daktmacfan daktmacfan is offline
Junior Member
Posts: 13
Join Date: Mar 2009
Question Re: Problem Booting from external hd - 03-20-2009, 03:12 PM

The error I was getting above was because I was booting from the bbot disc again. So in the configuration the USB stick was 80, and the internal hard disk either 81 or 82. For mine it was 81.

Problem solved!

Now I don't need to lug that 5+ pound MacBook around everywhere I go!
Reply With Quote

« Strange Install Problem ( RESOLVED. THANK YOU ! ) | SOLVED: copying os x 10.5.6 to HDD taking forever »
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Copyright © 2008-2016