General Mac OS X Discussion General Apple and Mac OS X Discussion

Thread Tools Display Modes
  (#181) Old
ishagi ishagi is offline
Senior Member
ishagi's Avatar
Posts: 187
Join Date: Mar 2009
Location: Kanata, Ontario, Canada
Default Success on Mini9 and VostroA90 - 06-20-2010, 06:06 PM

Updated to 10.6.4 on both these machines (note the bios). Using the modified NBI listed in the first message and installing prior to the update - no issues on either machine. All working including sound, sleep etc.

Dell Mini 9 (96Gb) | White | SL 10.6.5 + Win7 Pro using EasyBCD 2.0 | 2G GSkill 667 RAM | No Webcam | BIOS A05 | 32G Runcore SSD | 32G SDHC (ext) | 32G SDHC (int w/ MR04 Card) | 1505 802.11n | Internal BT | Chrome Apple Logo
Dell Vostro A90 (96Gb) | SL 10.6.5 | 2G HyperX | 0.3Webcam | BIOS A04 | 64G Runcore SSD | 32G SDHC (ext) | and other stock features
Reply With Quote
  (#182) Old
JnC JnC is offline
Senior Member
Posts: 188
Join Date: May 2010
Default 06-20-2010, 07:22 PM

Originally Posted by meklort View Post
Safe mode is a special Mac OS X where even if a kext is loaded, it won't run unless if it has a special property set. the kextd does special things in this mode too (which is why you don't want to run NBI in safe mode, kextd will only add safe mode capable kexts to the extension cache...
Thanks, meklort, for this info.
I asked about this elsewhere on the forum, since on my Macs I do do updates in safe mode.
I'm glad to see your reply here with a clear explanation of why not to run NBI in safe mode (and therefore not to do the OS update in safe mode due to automatic running of NBI after updating?)

Originally Posted by JnC View Post
Just to be clear here, we should simply use the directions in ***Update from (#1) post edited on June 19?
This supersedes meklort's June 17 directions on his blog NetbookInstaller + 10.6.4 Meklort's Blog. and referenced in the post (#143) quoted above?

We do NOT any longer have to, in meklort's words "please boot with recovery=y and run the fixed up version below "

I just want to do the update and get it right.
Am I correct in my understanding here?
Reply With Quote
  (#183) Old
woof woof is offline
Junior Member
Posts: 7
Join Date: Mar 2010
Default working system - 06-20-2010, 08:18 PM

Originally Posted by marimar8989 View Post
so, in conclusion, has anyone actually managed to upgrade to a 100% fully working 10.6.4 on the dell mini 10v?
see my post #141, no troubles here
Reply With Quote
  (#184) Old
madoc1 madoc1 is offline
madoc1's Avatar
Posts: 52
Join Date: Dec 2008
Location: aix en Provence France
Default 06-20-2010, 09:02 PM

Originally Posted by woof View Post
see my post #141, no troubles here
Originally Posted by madoc1 View Post
All works perfectly
thanks to M and coll
all worked fine (cf up)
I re boot one day after
the boot was very very long
I obtain the screen with the gray apple
and a gray line
After 20 min or more the OS X arrive
but the sound is grey no device.
I verify the authorisation
The sound reappear
I reboot
no sound device?
I ran NetbookInstaller
no sound.
Other reboot
sound is present???
So how to fix the sound.????
Reply With Quote
  (#185) Old
n8jjo n8jjo is offline
Junior Member
Posts: 3
Join Date: May 2010
Default 06-20-2010, 09:56 PM

Finally, success. Completely wiped hard drive including partition. Installed 10.6.0. Ran latest NBI. Used software update to install 10.6.4. Recovery=y. Ran NBI. Everything is working including audio, Bluetooth, and sleep. Now dragging apps and data back from Time Machine. I have no idea why my past efforts and careful duplication of procedures failed consistently. Thanks all for this useful and insightful thread.
Reply With Quote
  (#186) Old
alershka alershka is offline
Junior Member
Posts: 25
Join Date: Dec 2008
Default Working - 06-21-2010, 12:47 AM

I had no issues on my Mini9 installing the modified bootloader prior to installing the combo patch. I went from 10.6.2 to 10.6.4.

Dell Mini 9 / Obsidian Black / 2 GB Crucial RAM / Runcore 32 GB SDD / Gigabyte N300 WiFi
Dual Boot Win 7 Home Premium / OSX 10.6.2
Reply With Quote
  (#187) Old
nosushi4you nosushi4you is offline
Junior Member
Posts: 4
Join Date: Jun 2010
Default 06-21-2010, 12:57 AM

So, I'm currently on 10.6.3, and I'm wondering, is the NBI everyone is using an "official" one, or just a "quick fix" until an official one is released? Basically, is this going to be the only way to upgrade, or is there going to be a better way?
Reply With Quote
  (#188) Old
n8jjo n8jjo is offline
Junior Member
Posts: 3
Join Date: May 2010
Default 06-21-2010, 01:18 AM

Well, I spoke too soon. After a shutdown and restart, I lost Bluetooth and audio. Ran NBI. Restarted. Back to the dreaded "waiting for root".

And worse, my Superduper backup, which booted great earlier today, also gives me "waiting for root".

This seems like a house of cards to me. I'm not sure I have the patience. I guess I'll use my MacBook for OS X and put this little devil back on Win7. It's been fun!
Reply With Quote
  (#189) Old
rhycel rhycel is offline
rhycel's Avatar
Posts: 59
Join Date: Mar 2010
Default 06-21-2010, 01:44 AM

Duh...forgot to disable Legacy USB support...

Now truly 100% OK

Originally Posted by rhycel View Post
Thank dagger, madoc1. Just noticed mine doesn't wake from sleep.

I guess theres still some work to be done with mine

DELL MINI 10v | 2G | BLACK OSX 10.6.4
DELL MINI 1012 | 2G | ICE BLUE Windows 7 and OSX 10.6.4
Reply With Quote
  (#190) Old
brian5s brian5s is offline
Junior Member
Posts: 13
Join Date: Nov 2009
Default An hour huh? - 06-21-2010, 02:34 AM

Originally Posted by RaginAsian55 View Post
Used the patch from Meklort's post (#67 on page 7) and had a beautiful, seemless upgrade to 10.6.4 on my 10v. Still bluetooth (and probably sound) issues. Took around an hour from start to finish. THANKS, MEKLORT!
I'm letting this thing spin for a while...didn't know how long to let it sit there before my impatience kicks in and hits the power button
Reply With Quote

« Trouble making a bootable usb flash drive | Trouble installing Max OS X to Mini 10 »
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Copyright © 2008-2016