General Mac OS X Discussion General Apple and Mac OS X Discussion

Thread Tools Display Modes
  (#1) Old
jasperyate jasperyate is offline
Junior Member
Posts: 18
Join Date: Feb 2010
Default Mini 1010 Snow Leopard Magic Number crap - 02-11-2010, 04:36 AM

Ive got the same problem as it seems a lot of people had: with the 'hibernate image' being X seconds too old, but ive seen no solution i can use. i made a single partition in the mini so i cant get to a terminal from which i can execute any sort of commands that will help the computer wake up.

It obviously wont book off the install drive either, so im stuck and furious (yes, for no good reason) that i couldve been fine had i not installed the 10.6.2 update and been warned that this wouldve happened.

so i need to either erase the entire hdd and start from scratch or someone actually has a solution i can use, which seems unlikely. so how do i go about reformatting the drive so i can start over?

---------- Post added at 04:36 AM ---------- Previous post was at 04:23 AM ----------

got it to boot in safe mode by some miracle, now how do i make it so it doesnt pull this on me again?
Reply With Quote
  (#2) Old
nobo_mini nobo_mini is offline
Senior Member
Posts: 122
Join Date: Aug 2009
Default 02-11-2010, 10:19 PM

Bring up a terminal, su to your admin account and then do the following:

Hibernate Image file too old by XXX Seconds

Mini 9 | OS X 10.6.7 | 2GB | 16GB STEC | .3Mp | No BT |
BIOS A05 | USB Legacy: ON | USB Wake: OFF | Bluetooth: OFF | NBI .8.4 RC1.1 (20100616212351)
Sleep: Working | Speakers: Working | Headphone Jack: Working
Reply With Quote
  (#3) Old
82times 82times is offline
Junior Member
Posts: 2
Join Date: Jan 2010
Default 02-13-2010, 07:46 PM

Originally Posted by nobo_mini View Post
Bring up a terminal, su to your admin account and then do the following:

Hibernate Image file too old by XXX Seconds
I have the same problem and this didn't quite work for me.

It did get rid of the 'hibernate image' being X seconds too old error, but I still get:

Mach-0 file has bad magic number
This error message is displayed when attempting to boot from either the internal MiniHD or the OSXInstall external drive. -v, -x, -s, etc. options make no difference.

If anyone has a tip to get beyond this point that would be great. Perhaps it goes without saying, but I'm using the guide here:
How To install OSX on Mini10

I am unable to boot at all. All I get to see is Chameleon.

EDIT: Fixed this by using the alternate kernel mentioned in the guide. In order to do this, though, I had to re-do my OSXInstall external drive--basically, starting from scratch in order to boot to the external drive. After that, I just copied the new mach_kernel on over and it works! Very happy.
Reply With Quote

« question about hacked 10.6.2 on mini10 and non hacked 10.6.2 | ***help please »
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Copyright © 2008-2016