General Mac OS X Discussion General Apple and Mac OS X Discussion

Thread Tools Display Modes
  (#1) Old
grassle grassle is offline
Senior Member
Posts: 373
Join Date: May 2009
Default No reboot after sleep - 10-18-2009, 12:22 PM

What have I overlooked? That mini 9 is a bit erratic...

UPDATE: I migrated from an earlier install but without "Computer" or "Other files", then deleted the fresh user from the clean install. Also inserted the UHCIreset into boot plist. Now Sleep is fine, but Reboot after sleep still the same.

Sleep works from the menu command (display dark and power led pulsing).
When the lid is closed* only the display goes black and the led remains permanently lit, also with no battery inserted or battery 100% charged.

Reboot after (menu) sleep: display goes black, power led stays lit, nothing else happens, not even the little click noise of sleep or shutdown.

*or a magnet is placed left of the upper left corner of the left shift key -- that's where the switch is, you did know that, didn't you? :-)

BIOS A05, USB wake disabled, USB legacy disabled,
fresh clean install w/update to 10.6.1, NBI 0.8.3RC3,
hibernation disabled and sleepimage removed via terminal (sudo pmset -a hibernatemode 0; sudo rm /var/vm/sleepimage).

Have rerun NBI in normal and -x -f boot. Set BIOS to defaults then wake and legacy disabled.

Also weird: I can toggle sound by running NBI in either -x [-f] (=> sound off) or normal (=> on) boot.

Thanks for help,
Reply With Quote
  (#2) Old
vestan_pance vestan_pance is offline
Senior Member
vestan_pance's Avatar
Posts: 144
Join Date: Dec 2008
Location: Surrey, England
Default 10-18-2009, 05:19 PM

I have a similar problem, sleep works when mini 9 is plugged into power supply, but when on battery only I can sleep ok from the apple menu or closing the lid (power LED remains lit) but I can't wake it up without force shutdown then restarting machine.

10.5.8, A05, NBI RC3, USB wake and legacy disabled

Dell Mini 9 2GB 64GB RunCore SSD BT 1.3MP 10.5.8 A05 NBI .8.3 RC3
MBP 2.4 C2D 4GB 160GB 10.6.2
Macmin 2.53 C2D 4GB 320GB 10.6.2
Macmini 1.83 CD 1GB 80GB 10.6.2
iPhone 3Gs 32GB; 2*PS3 (320/40GB + PlayTV); Wii; PS2; PSP Phat; PSP3000
Reply With Quote
  (#3) Old
louididdy louididdy is offline
Senior Member
Posts: 159
Join Date: Jan 2009
Default 10-21-2009, 05:41 PM

I might be able to help with sleep, but I get the same problem when trying to restart after sleep, please check out my guide for more info and to contribute to the evolution of this system:

DellMini9 Runcore SSD/10.6.1/NI 083 RC3 (Full Sound, Sleep, Reliable Restart!)

OSX 10.6.4
Reply With Quote
  (#4) Old
grassle grassle is offline
Senior Member
Posts: 373
Join Date: May 2009
Default 10-21-2009, 10:00 PM

Thanks! I didn't know about SmartSleep. But for restart after sleep we will have to wait for the NBI to evolve further, I guess. But that's a trifle in light of all the working stuff.
Reply With Quote

closed lid, mini 9, sleep, sleep menu

« no audio after wake in NBI 8.3 RC | Bios A05 »
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Copyright © 2008-2016