General Mac OS X Discussion General Apple and Mac OS X Discussion

Thread Tools Display Modes
  (#1) Old
diamond187 diamond187 is offline
Junior Member
Posts: 3
Join Date: Mar 2009
Default Install DellEFI to /dev/hda3? - 08-07-2009, 10:18 PM

With the recent Technet release of win7, I updated my mini from the RC to the full fledged version (which runs excellently, but that's besides the point). As I expected, when I did so it rewrote the boot sector, which is normally as simple as booting off my usb drive into osx and then re-running dellefi (1.2a5) and telling it to reinstall chameleon again.

This time, apparently even though windows created and loved that small first partition, apparently this time it decided to make it's main partition it's boot.

Short story:
Partition map:
/dev/hda1 - 100Mb - Windows 7 boot (old, now apparently unused)
/dev/hda2 - 30Gb - OS X
/dev/hda 3 - 34Gb - Win 7 (it's the boot partition now too)

When I run DellEFI it installed the bootcode to hda1 (assumed), but I get no selection screen anymore, no boot0, no anything but windows. Changing the boot flag didn't do anything besides make it not boot (surprise! )

Any ideas on how to make the DellEFI install to a drive booting /dev/hda3? I hate having to use the USB key to boot osx!

Reply With Quote

« Is there a kext that will fix the lack of mirroring in th 10v | Help!!!! »
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Copyright © 2008-2016