General Discussion General discussion on...anything!

Reply
 
Thread Tools Display Modes
  (#1) Old
TRees TRees is offline
Junior Member
 
TRees's Avatar
 
Posts: 6
Join Date: Feb 2011
Location: Rochester, NY
Question Confusion: virtual memory & disk space - 02-24-2011, 07:02 PM

Hi. First-timer here. I've had a Dell for about three years. During the last several months I keep receiving the "Virtual Memory Low" message along with the "Low Disk Space" message. I'm confused as to why this is doing this now; I don't have that much on the computer; I actually removed the Adobe program to make room, etc; Last week, after searching and learning, I successfully upgraded the memory by adding 2GB; I'm still receiving the "low disk space" and "virtual memory" messages. Not very versed in computer tech talk, etc; the "OS(C) keeps sending "low" messages; attempted to reinstall Adobe, and msg says not enough disk space. The new memory show up on BIOS (which I just learned how to find!) Am running Windows XP. Any suggestions or clues as to what I'm not or didn't do to have this happen. Thank you. .
Tom


TRees
Mini 9 2GB
Reply With Quote
  (#2) Old
holmes4 holmes4 is offline
Administrator
 
holmes4's Avatar
 
Posts: 6,156
Join Date: Nov 2008
Location: New Hampshire
Default 02-24-2011, 07:35 PM

Virtual memory uses disk space to extend the amount of "memory working space" a program can use above what RAM you have installed. This is done using a file called a "pagefile" and, by default, Windows expands this file if you run a program that needs more memory. It tends not to reduce it.

Do this. Right click on My Computer and select Properties. Click on the Advanced tab, then the Settings button under Performance. When the Performance Options dialog comes up, click on the Advanced tab, then the Change button under Virtual Memory. Select the option "No paging file", click Set, then OK, OK, OK. Reboot.

I find that a Mini 9 runs just fine with no paging file and 2GB of RAM. Run that way for a while and see how it works for you.


Steve
Mini 9|2GB RAM|64GB RunCore|Intel 5300|Windows 10
Reply With Quote
  (#3) Old
TRees TRees is offline
Junior Member
 
TRees's Avatar
 
Posts: 6
Join Date: Feb 2011
Location: Rochester, NY
Default 02-25-2011, 12:53 AM

Steve: Thank you very much for the response. I just tried it and it gave me another 200MB to use! Before I logged on to read your response, I deleted just about everything I could from the Mini 9. I just can't figure out where all the disk space is being used. Prior to your suggestion, I didn't even have enough to run a defrag on the Mini or to download a recent security renewal! My Drive C now shows 441MB of free space. I actually don't really know what's left to delete to free up more disk space. Thank you so much for helping me out, and bearing with me! Any other hints will be greatly appreciated. Thanks again.


TRees
Mini 9 2GB
Reply With Quote
  (#4) Old
holmes4 holmes4 is offline
Administrator
 
holmes4's Avatar
 
Posts: 6,156
Join Date: Nov 2008
Location: New Hampshire
Default 02-25-2011, 03:19 PM

That's not much space! Try Start > Accessories > System Tools > Disk Cleanup. Don't choose the option to compress files.


Steve
Mini 9|2GB RAM|64GB RunCore|Intel 5300|Windows 10
Reply With Quote
  (#5) Old
TRees TRees is offline
Junior Member
 
TRees's Avatar
 
Posts: 6
Join Date: Feb 2011
Location: Rochester, NY
Default 02-25-2011, 05:50 PM

Steve: I did the disk cleanup last night, and then again this morning. Available space is now 640MB. I just can't figure where all that other space is allocated.
Thank you for your response and help!
Tom


TRees
Mini 9 2GB
Reply With Quote
  (#6) Old
holmes4 holmes4 is offline
Administrator
 
holmes4's Avatar
 
Posts: 6,156
Join Date: Nov 2008
Location: New Hampshire
Default 02-25-2011, 07:05 PM

How big an SSD do you have? 8GB?

Next thing to do is to disable hibernation -see here.

If you don't see more space, you will have to manually delete the hiberfil.sys from C:\ It is a hidden file, so you'll have to change the "View" properties in Explorer to show hidden files.


Steve
Mini 9|2GB RAM|64GB RunCore|Intel 5300|Windows 10
Reply With Quote
  (#7) Old
TRees TRees is offline
Junior Member
 
TRees's Avatar
 
Posts: 6
Join Date: Feb 2011
Location: Rochester, NY
Default 02-26-2011, 03:44 PM

Will check out the SSD and the hibernation info today. Thanks for your support!
Will let you know my results.


TRees
Mini 9 2GB
Reply With Quote
  (#8) Old
eugene eugene is offline
Senior Member
 
eugene's Avatar
 
Posts: 137
Join Date: May 2010
Default 02-26-2011, 09:15 PM

One point. You mention that you didn't have room to defrag. You really don't want to be doing a defrag on the Mini 9.
Reply With Quote
  (#9) Old
TRees TRees is offline
Junior Member
 
TRees's Avatar
 
Posts: 6
Join Date: Feb 2011
Location: Rochester, NY
Default 02-27-2011, 05:00 AM

Eugene: Thanks for the warning/tip.


TRees
Mini 9 2GB
Reply With Quote
  (#10) Old
HTWingNut HTWingNut is offline
Member
 
Posts: 44
Join Date: Feb 2011
Location: BKAC
Default 02-27-2011, 11:38 PM

Download TreeSize Free. It will tell you where all your space is being allocated.

Secondly, turn off hibernate, unless you absolutely need it. Sleep state should be fine. To turn off hibernate, open your start menu, type: 'cmd' (without quotes) then press ctrl+shift+enter simultaneously (this will put you in elevated command mode or administrator mode). It will open a DOS window. Type:

powercfg -h off

and press enter. This will turn off hibernate and eliminate your hibernate file.

There is nothing wrong with doing a defrag. Just don't do a defrag if you have an SSD.


Mini 1012 "Booger" : 10.1" 1366x768 | N450 | 2GB | 80GB Intel X25-M | Win 7 HP
M11x R1 "Firefly" : 11.6" 1366x768 | SU7300 | 4GB | 120GB Intel X25-M | Win 7 HP
Reply With Quote
Reply

Tags
low disk space, os(c) low, virtual memory

« Thank you! | Great site with 1024x600 wallpapers »
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Copyright © 2008-2016 MyDellMini.com.