General Discussion General discussion on...anything!

Reply
 
Thread Tools Display Modes
  (#1) Old
nextel2010 nextel2010 is offline
Junior Member
 
Posts: 8
Join Date: Mar 2009
Angry What's Up With Dell?? - 02-03-2011, 02:16 AM

I purchased a new(ly refurbished) Dell Mini 10v from an online retailer in Canada last November (I am in the USA). First order of the day: register it. I have a Service Tag number, Express Service number, as well as all my receipts. I tried registering it on Dell's web site. A few weeks later, I get an email saying there were "complications", so they referred me to a toll-free number. I call the number, and get bounced around from one customer service rep. to another (all in India, all following inane scripts with the intention of moving me on). I wasted over an hour getting nothing but frustration and a promise from a manager that he will call me back after "checking a few things". Why is it so hard to register one of their own products?? Yes, I purchased it from Canada, but Dell surely must have a history of every machine they produced?? What use are their own Service Tag etc. numbers then??

I then formatted the drive and installed OSX 10.6.2 without a hitch (first-time ever installing OSX!), thanks to the great information found on this site. Next step was to attempt a dual-boot system with Windows 7. I needed the drivers so off to the Dell web site I go....

I selected my driver files, and was told I needed to use their download manager (DLM). Ok..so I downloaded and installed it. Tried to download the selected files...DLM says no files were selected. Tried again..same thing. After closing the browser tab and trying again, DLM finally started downloading. Then I get periodic messages saying this file or that file is corrupt, and to try again. Ok...but it's nearly impossible to figure out which file hasn't been downloaded because the web site lists driver files by description while the DLM lists "corrupt" files with "RXXXXXX" only. I tried using my browser to download individual files and bypass the DLM, but then I get "Page Not Found" errors (????). I tried to get online assistance but they asked for....my Service tag number, which of course, comes up as invalid.

I've NEVER had the trouble with other tech companies that I have had with Dell. Right now, I am without a warranty on a product which I bought advertised as coming with a 1-year warranty. I can't even download their drivers from their own web site.

I can try to piecemeal the drivers I need through this forum, but does anyone have any suggestions on how to deal with this registration issue???
Reply With Quote
  (#2) Old
rrfranczak3 rrfranczak3 is offline
Super Moderator
 
rrfranczak3's Avatar
 
Posts: 2,902
Join Date: Aug 2009
Location: Upstate New York, U.S of A.
Send a message via AIM to rrfranczak3 Send a message via MSN to rrfranczak3 Send a message via Yahoo to rrfranczak3
Cool 02-03-2011, 02:43 AM

ya gotta play with their download manager a little bit, took me a while too but eventually I got it....you will too....it does work...and once it have it done it works from there forward....


Dell Mini 10 (Obsidian Black 1010), 2gb RAM, 1.66ghz 533mhz FSB (Z530) processor, A10 BIOS, 1 Terabyte (1000 GB) WD Scorpio Blue Hard Drive (5400rpm), Intel GMA 500 Integrated Graphics, TV Tuner, Bluetooth 2.1 module with EDR, 1.3mp Camera, 1366x768 HD Screen, Wireless 1510 b/g/n mini card, 6 cell (56WHr) Battery, 4gb SDHC, 64gb Flashdrive, Targus Netbook Chillpad, Targus Sport Case, Windows 7 Ultimate SP1 (500gb)/Windows 8.1 (500gb) (Dual Boot)

iPad 4 (64gb) w/Retina,Targus Versavu Case
Reply With Quote
Reply

Tags
dell support, drivers, registration

« Dell wireless 1510 Help | malware on mydellmini.com? »
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Copyright © 2008-2016 MyDellMini.com.