Dual Booting All discussion on Dual Booting 2 operating systems (or even more!) on the Dell Mini

Thread Tools Display Modes
  (#1) Old
r6mile r6mile is offline
Junior Member
Posts: 5
Join Date: Mar 2010
Default NBI 0.8.4pre broke my dual-boot - 03-11-2010, 12:32 PM

To summarise:

I had a working Windows XP Pro SP3 - Mac OS X 10.6.2 dual boot, under NBI 0.8.3. I hear that NBI 0.8.4pre comes out, so I decide to run it, and of course stupidly reinstall Chameleon. Now it runs straight into Mac OS X, without letting me boot into XP. If I boot into my SL USB key it detects my Dell XP, but it just does't boot it into it.

It seems like I'm not the only one that's done this, as it is described here: upgraded SL like an idiot and now Win7 wont boot

However, that's relevant to Windows 7. I imagine the same doesn't apply to Windows XP as it doesn't have the same tools. Does anybody know how to repair it?

Reply With Quote
  (#2) Old
minimalpc minimalpc is offline
Expert Member
Posts: 560
Join Date: Dec 2009
Default 03-12-2010, 01:54 AM

Sounds like you had the "quiet boot" option checked when you ran NBI. Run it again and make sure it is unchecked.

Were you using Chameleon previously to choose between booting XP and OS X?

Dell Mini 10v | Mac OS X 10.6.2 | Windows 7 Professional | Ubuntu Netbook Remix 9.10 | 1GB RAM | 160GB HDD | BIOS A05 | USB Legacy: OFF | USB Wake: OFF | BT: Enabled (self-installed BCM2046) | NBI 0.8.3 final
Reply With Quote
  (#3) Old
bmcclure937 bmcclure937 is offline
Super Moderator
bmcclure937's Avatar
Posts: 1,420
Join Date: Mar 2009
Location: United States
Send a message via AIM to bmcclure937
Default 03-12-2010, 02:05 AM

Yes, please check your Chameleon settings or make sure you are running NBI so that the bootloader will allow you to choose the OS to boot into.

The thread you linked to is irrelevant and is a totally different issue. The latest version .8.4pre actually would solve the problem in the other thread and has nothing to do with this.

 Mini 10v  | 2Gb RAM | 320 Gb HDD | Ubuntu 10.04 | OSX 10.6.3 | NBI .8.4RC1 | Chameleon Bullet Theme | BIOS A05 | USB Wake : OFF | USB Legacy : ON | No BlueTooth
Meklort's Blog | NBI Google Code Page | osx.mechdrew.com -- the best OSX installation guides
Reply With Quote
  (#4) Old
r6mile r6mile is offline
Junior Member
Posts: 5
Join Date: Mar 2010
Default 03-12-2010, 12:02 PM

You guys are brilliant! That solved the problem perfectly.

NBI 0.8.4's bootloader is a bit uglier than 0.8.3 though: it actually says 'press key to select startup options' rather than just have the bar, and the apple looks kind of squashed. Not that it's any kind of issue of course! I'm just so glad it works now!
I've also noticed they've got rid of the spinning / (which I thought was kind of cool), but on the bright side it doesn't show that stupid line of text telling me something about 'Force Wake' which annoyed the hell out of me.

What is 'Quiet Boot' meant to do anyway?
Reply With Quote

« Software Update in OSX on 3/7 seems to have broken dual booting | Dualbooting XP & OSX ? »
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Copyright © 2008-2016 MyDellMini.com.