Dual Booting All discussion on Dual Booting 2 operating systems (or even more!) on the Dell Mini

Thread Tools Display Modes
  (#1) Old
tgenereaux tgenereaux is offline
Junior Member
Posts: 5
Join Date: Oct 2009
Default Dual Boot XP with Sl already installed - 11-06-2009, 03:18 AM


I can not get it to boot I get getting errors, I have made a new partition fat32 msdos and the install xp from USB. that is maybe the problem maybe i am making the wrong type of xp install usb.

any thoughts ?


Mini 10v | 1gb Ram| 160gb HD|
Reply With Quote
  (#2) Old
philip philip is offline
Junior Member
Posts: 8
Join Date: Nov 2009
Location: Oceanside, CA
Default 11-11-2009, 09:41 AM

I was kind of stuck at the same place. I used the WinToFlash method for creating the Windows USB drive. I created a FAT partition through Disk Utilities in SL, booted from USB, began Windows set-up without issue, formatted partition as NTFS. When setup requires a restart you have to boot from the USB again and select option 2. (I had to use the debug option at this point and selected partition 3). Went through the normal set-up process, set-up restarted again so I had to boot from USB->debug partition 3 once more which finally got me Windows desktop. Without the USB drive I would receive "hal.dll missing" error. To fix this boot to Windows once again using the USB drive-> partition 3. Right click on Computer -> Properties -> Advanced tab -> Startup and Recovery settings. Click Edit which will bring up the boot.ini file. Replace partition(1) with partition(3) (or whatever yours happens to be). Here is how my boot.ini reads:

[Boot Loader]
Default=multi(0)disk(0)rdisk(0)partition(3)\WINDOW S
[Operating Systems]
multi(0)disk(0)rdisk(0)partition(3)\WINDOWS="Micro soft Windows"

Now it boots to Windows directly without error or need to select anything.

I just need to figure out how to use Chameleon to be able to select which OS to boot. I tried using Meklort's method: Dual booting with NetbookBootMaker 0.8.3 RC2 Meklort's Blog
but when I tried the fdisk terminal command, it said Permission Denied. Now I'm stuck!

---------- Post added at 01:41 AM ---------- Previous post was at 01:16 AM ----------

I used diskpart in Windows as a work-around to my problems with Terminal. Through command prompt:
select disk 0
select partition 1 (snowleopard partition)

Now it boots through Chameleon as expected and all is right in the universe. :-)
Reply With Quote

« SL and Ubuntu Dual Boot | Newbie with a 10v dual-boot question »
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Copyright © 2008-2016 MyDellMini.com.