Dell Mini 9 OS X Discussion Discussion for installing and setting up Mac OS X on the Dell Mini and Vostro A90

Thread Tools Display Modes
  (#1) Old
ccwillia ccwillia is offline
Junior Member
Posts: 8
Join Date: Apr 2009
Default Help - OS X 10.6.8 - 12-06-2011, 04:10 AM

I have made a rookie mistake and I am hoping one of the very intelligent individuals in this forum can help me. I was following a guide to upgrade to 10.6.8 I ran the following

sudo mv /mach_kernel /mach_kernel_bad

followed by

sudo mv /legacy_kernel /mach_kernel

After rebooting i get the following error "Unable to patch 64bit kernel. Please use arch=i386 to use a 10.6.2 or newer kernel. Can't find legacy_kernel"

I assumed that the legacy_kernel was the one created by the nawcom's package for 10.6.8.

I have tried holding shift and typing : recovery=yes, -x , but that does not fix the problem. I am assuming the legacy_kernel needs to be put back, but I have no way of getting to the terminal.

Thanks in advance,

Reply With Quote
  (#2) Old
ccwillia ccwillia is offline
Junior Member
Posts: 8
Join Date: Apr 2009
Default 12-06-2011, 06:05 PM

Since my runcore drive can be removed and connected via USB I was able to mv the directories back and get the system to boot. I then got the appropriate legacy 10.6.8 package and moved it to mach_kernel and again it booted successfully. I then tried to apply the SleepEnabler and now i get a kernel panic. Does anyone know how to resolve this? Is there a way to get in the terminal and remove this kext?
Reply With Quote

« External monitor sugestions for Dell mini 9 10.6.8 | OSX Snow Leopard On Mini 9 - No Wifi or Sound »
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Copyright © 2008-2016