Dell Mini 9 OS X Discussion Discussion for installing and setting up Mac OS X on the Dell Mini and Vostro A90

Thread Tools Display Modes
  (#1) Old
cnc137 cnc137 is offline
Junior Member
cnc137's Avatar
Posts: 15
Join Date: Mar 2009
Question Service Battery - Mac OS X 10.6.7 on Dell Mini 9 - 03-24-2011, 01:12 AM

I searched the forums and found a few threads mentioning re-installing NetbookInstaller and reseting the file permissions to fix the "Service Battery" message under the battery icon in Mac OS X, but they didn't really give much information on this problem.

Is this something new that is happening again after upgrading to 10.6.7 on a Dell Mini 9 or has it been a problem with all version of Snow Leopard? Can it be fixed easily?

I haven't reset my file permissions before, so I am not sure how to do that without messing something up. Will that solve the problem? How would I go about doing that?

I also read that I should regenerate the "DSDT.aml" file, but I don't really want to do that, since I modified it last night after upgrading to 10.6.7. I modified it to fix the sound and microphone using the "Bundle for fixing Mini 9 Sound & Mic" instructions.

Anyone else having this "Service Battery" problem or does anyone know how to solve it? It isn't that big of a deal, but I would like to fix it if I can.
Your video game destination....
Reply With Quote
  (#2) Old
underwhelmed underwhelmed is offline
Posts: 1,375
Join Date: Mar 2009
Location: Texas
Default 03-24-2011, 02:13 AM

It hasn't been an issue, that's why you didn't find anything by searching.

Did you do a clean install of 10.6 or did you try and update from 10.5.8 to SL? I did, back when SL first came out and had all sorts of weird issues, until I did format and a clean install.

Mini 9 | OS X 10.6.7 | NBI 20100616212351| BIOS 05 | 32 GB Runcore | 2 GIGS RAM
10V | OS X 10.6.7 | NBI 20100616212351 |BIOS 06|160 GB|1 GIG RAM| 6 Cell Dell Battery
Functioning Hibernation

Back up Mini 9| OS X 10.6.7| NBI 20100616212351| BIOS 05 | 32 GB SuperTalent | 2 GIGS RAM
Reply With Quote
  (#3) Old
cnc137 cnc137 is offline
Junior Member
cnc137's Avatar
Posts: 15
Join Date: Mar 2009
Default 03-24-2011, 02:44 AM

I did a clean install of 10.6.6 two days ago and then upgraded to 10.6.7 last night. I didn't notice the problem until today when using the system on battery and my battery charge went low.

I posted the details of my install in the OSX 10.6.7 compatibility thread, but here they are again for reference:

I was able to get OS X 10.6.7 working on my Dell Mini 9 last night using the following guide and software to install version 10.6 from DVD and then upgrade to 10.6.6 before upgrading to 10.6.7 using the advice above:

- NetbookInstaller 3: Installation via External DVD Drive using NetbookCD
- NetbookCD 0.8.3 Final
- NetbookInstaller 20100616212351 from Meklort's Blog
- Mini9 Sound Patch Bundle from the Bundle for fixing Mini 9 Sound & Mic thread.

I was able to install all the Apple Software Updates and everything seems to be working as expected using 10.6.7.

I originally tried installing 10.6 and upgrading directly to 10.6.7 using the guide above, but I got the Kernel Panic Screen on reboot. I was using NetbookInstaller 0.8.4 RC1 from Downloads | OS X | mechdrew at that time and maybe that was the problem. I decided to re-install and upgrade to 10.6.6 using NetbookInstaller 20100616212351 after I found it and it worked fine. Then I found this thread and that gave me the courage to upgrade to 10.6.7.
Could my battery actually be going bad and that is why I am getting this message?

It didn't seem to hold a charge as long as it has in the past when I used the system. I am re-charging it now to see what happens.
Your video game destination....
Reply With Quote
  (#4) Old
nesagwa nesagwa is offline
Posts: 37
Join Date: Aug 2009
Default 03-27-2011, 02:36 PM

I've had the same problem on my 10v for a while. The usual answer of "Reinstall NBI, repair permissions and restart" hasn't worked.

So, like you, I'm not sure if my battery is actually slowly dying or if its just a false flag.

Using Coconut to check the battery hasn't really given me anything definitive either.
Reply With Quote
  (#5) Old
CyG CyG is offline
Senior Member
Posts: 233
Join Date: Nov 2008
Default 03-29-2011, 05:05 PM

It really is possible your battery is dying. How many hours of operation are you getting out of it?

Dell Mini 9 | Mac OS X 10.6.6 | BIOS A04 | NBI '51 | 16 SSD | 2 GB RAM | BT
Reply With Quote
  (#6) Old
FattyJay1011 FattyJay1011 is offline
Junior Member
Posts: 7
Join Date: Sep 2010
Exclamation 10v service battery - 06-16-2011, 03:59 PM

I have a 10v I've had for a while. I have two battery's which I know are good. I too am getting a service battery under the battery icon drop down menu on both battery's. I have a fresh install of 10.6.7 (two weeks old) and netbookinstaller 8.5pre. I've never had this problem using previous NBI with prior releases of OS X on the 10v. The life span on the battery's seems to be normal. (I've tried the above post also.)
Reply With Quote

10.6.7, battery, dell mini 9, os x, service battery

« No Wifi | Mini 9 issue..... »
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Copyright © 2008-2016