Dell Mini 9 OS X Discussion Discussion for installing and setting up Mac OS X on the Dell Mini and Vostro A90

Thread Tools Display Modes
  (#21) Old
creativemeat creativemeat is offline
Junior Member
Posts: 18
Join Date: Mar 2009
Default 04-11-2010, 05:30 AM

I think the problem is related to hibernation mode. These steps solved my sleep problems.

Open Terminal and type pmset -g

If hibernatemode has a value of 3, that means hibernation is enabled. NetbookInstaller 0.8.4 RC1 doesn't seem to properly disable it.

To disable hibernation, type sudo pmset -a hibernatemode 0. You'll be asked for your master password. The "-a" parameter tells your mac to disable hibernation on battery and plugin power.

For more information on the pmset command: pmset(1) Mac OS X Manual Page

There's also the issue of BIOS settings. I currently have bluetooth and usb wake disabled and USB legacy enabled. I will continue testing different BIOS settings for any changes.

Update 1: I have confirmed that enabling bluetooth while usb wake is disabled and usb legacy is enabled breaks sleep

Update 2: I kept BT disabled but enabled usb wake and disabled usb legacy. Sleep continues to work.

Update 3: Ok, the correct BIOS setting is this: USB Legacy must be disabled. This is not surprising, as previous versions of OS X on my mini 9 required the same setting. However, the difference this time is that NetbookInstaller .0.8.4 RC1 does not properly disable hibernation, or so I believe.

To recap the steps I took to fix no wake from sleep:
Disable hibernation - Open Terminal and type "sudo pmset -a hibernatemode 0"
Disable USB Legacy in your BIOS settings

10.6.3. 2GB RAM. 32GB RunCore.
Reply With Quote
  (#22) Old
nobo_mini nobo_mini is offline
Senior Member
Posts: 122
Join Date: Aug 2009
Default 04-11-2010, 06:01 AM

Originally Posted by creativemeat View Post
To recap the steps I took to fix no wake from sleep:
Disable hibernation - Open Terminal and type "sudo pmset -a hibernatemode 0"
Disable USB Legacy in your BIOS settings
Makes sense why my sleep is working: I've had these settings since day one (10.5) and have it in my checklist for builds. I did the pmset on the initial/fresh 10.6 build and seemed to have stuck through each upgrade path.


My mistake. I've got Legacy enabled. So, the suggested fix seems to be related to BlueTooth. But, the hibernate 0 I think still stands for all configs.


And per the MechDrew FAQs for BIOS, USB Legacy should be off:

Some hardware configurations are not compatible with each other. Case in point, on the Dell Mini 9/Vostro A90 netbooks "USB Wake from Sleep" does not currently work properly with Mac OS X. Also, the Bluetooth modules that are available from Dell can cause a conflict with the "USB BIOS Legacy Support" feature, which will cause the system to hang during restart and freeze more often after sleep. The best case scenario is to leave "USB Wake from Sleep" disabled. If you have Bluetooth installed and enabled, make sure to disable "USB BIOS Legacy Support" after installation is complete.

USB Legacy Support is useful, but sometimes it can cause issues with sleep and wake functions. If you experience issues and have it enabled, disable the feature except for the instances when you need to boot from an external device.

USB Wake from Sleep is also hard to define. It should be enabled on a 10v after installation, but not always on a Mini 9.

You should always try different combinations of the BIOS settings to see what works best. For me, I have no Bluetooth in my 10v and both USB Legacy Support and Wake from Sleep are enabled without any issues. Not everyone has the same luck, so if sound and/or sleeping are not working try changing settings.

Mini 9 | OS X 10.6.7 | 2GB | 16GB STEC | .3Mp | No BT |
BIOS A05 | USB Legacy: ON | USB Wake: OFF | Bluetooth: OFF | NBI .8.4 RC1.1 (20100616212351)
Sleep: Working | Speakers: Working | Headphone Jack: Working
Reply With Quote
  (#23) Old
grgz grgz is offline
Junior Member
Posts: 1
Join Date: Apr 2010
Default 04-11-2010, 05:48 PM

Another data point:

Sleep worked fine under 10.6.2. Now I get the pegged CPU/beachball described by others on wake.

Mini 9 w/ A05 BIOS
stock 16GB SSD
no bluetooth, no webcam
retail Snow Leopard, upgraded from retail Leopard
- bluetooth disabled
- USB legacy support disabled
- USB wake disabled
LidSleep is loaded (kextstat | grep Lid).
Hibernate is disabled:

mini9:~ greg$ pmset -g
Active Profiles:
AC Power -1
Battery Power -1*
Currently in use:
hibernatefile /var/vm/sleepimage
hibernatemode 0
disksleep 0
sleep 0
displaysleep 2
lidwake 1
ttyskeepawake 1
halfdim 1
Reply With Quote
  (#24) Old
battda battda is offline
Junior Member
Posts: 6
Join Date: Jan 2009
Default 04-11-2010, 07:13 PM

Originally Posted by creativemeat View Post
To recap the steps I took to fix no wake from sleep:
Disable hibernation - Open Terminal and type "sudo pmset -a hibernatemode 0"
Disable USB Legacy in your BIOS settings
I disabled hibernatemode and removed the hibernate file.
My BIOS settings are as per your recommendations.
kextstat | grep meklort shows the following are running: LidSleep, cpuid, CPUIDOverride

I still have the same problem as before.

I wish I understood enough to follow japhex's instructions, but I don't, so I'll just have to wait and see if an easier fix comes along (perhaps in a new version of NBI).
Reply With Quote
  (#25) Old
tonyt3rry tonyt3rry is offline
tonyt3rry's Avatar
Posts: 50
Join Date: Apr 2009
Default 04-11-2010, 09:28 PM

worked like a charm for me thank you verry much

Dell Mini 9 - 16GB RunCore SSD - 1GB Ram - 3G Vodafone Broadband - Bluetooth - 0.3MP Webcam
OS - OsX Snow Leopard. / Currently testing Ubuntu 10.04 Netbook
Reply With Quote
  (#26) Old
GreyPaint GreyPaint is offline
Senior Member
Posts: 134
Join Date: Jan 2009
Default 04-12-2010, 02:27 PM

Checked my state with Pmset and no joy...

When I resume from sleep, it works for a period of time, but when I open a new browser window, the browser becomes unresponsive. I cannot Force Quit, it eventually goes into the pinwheel and then I have to power off.
Reply With Quote
  (#27) Old
amisingh amisingh is offline
Junior Member
Posts: 1
Join Date: Apr 2010
Default 04-12-2010, 07:07 PM

Reply With Quote
  (#28) Old
seren8 seren8 is offline
Junior Member
Posts: 3
Join Date: Aug 2009
Default 04-13-2010, 10:36 PM

The pmset instructions worked for me. Thanks!
Reply With Quote
  (#29) Old
dbculp dbculp is offline
dbculp's Avatar
Posts: 40
Join Date: Apr 2009
Default Sleep Fixed - 04-14-2010, 12:56 PM

Disabling Legacy USB fixed mine, I had it enabled to boot from my USB backup once and I forgot to disable it when I was finished.

Mini 9 with 64GB Runcore SSHD, 2GB RAM, OS X 10.6.8 (BIOS A05)
& Windows 7 (with VirtualBox)
Reply With Quote
  (#30) Old
sthchen sthchen is offline
Junior Member
Posts: 24
Join Date: Dec 2008
Default 04-15-2010, 05:13 AM

Just reporting same problem here.

Sleep working fine on 10.6.2. Did a clean install of 10.6, combo updated to 10.6.3, now I'm getting same issues others are reporting - freezing sometimes when I click on Finder-related things, sometimes when wireless doesn't come back on, etc.

USB Legacy is off. Turned off hibernate; didn't do anything. Lidsleep kext is loaded.

No bluetooth here, stock 16gb ssd.
Reply With Quote

« Help restoring mini 9 from OSX to XP or Linux | Help trying to finish the last chapter of my dell mini 9 »
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Copyright © 2008-2016